Jump to content

Recommended Posts

20 minutes ago, Battlefront.com said:

Some Mods might work "as is", some might work with a name change, but a whole bunch won't work without a total overhaul.  Soldier and vehicle models are pretty much all in the latter category.  Oh, and of course there are no normal maps in the old CMSF1 so those will have to be made to get the full quality effect in CMSF2.

Steve

They are not working at all. I didn't bother with vehicles or stuff like that, just the generic stuff that hasn't changed across titles since the 2.0 engine. The file names, bmp sizes (and bit depths) and sounds are all as they should be. The first thing I did was explode the brz and made sure everything matched up. I use all of them in BN, FI, BS, and RT and they work just fine.  Specifically, explosions, flames, smoke/dust, bases, weapons sounds, us voices, red cross.  No uniforms, no vehicles, nothing from SF1. I am thinking it might have to do with the demo itself.

And there is no 3D preview for maps. I could've sworn the old demos allowed you to view just not save.

 

Mord.

Edited by Mord

Share this post


Link to post
Share on other sites

AHH! On a hunch I just moved my mod folder from "user data" to the "data folder" and the mods work. The "user data folder" is broken. It must be some legacy code left over from SF1 or BN or something.

Checked the RT demo and there is no 3D view in that either. So I guess that is normal. Cool. I was mostly concerned about the mods.

 

Mord.

Edited by Mord

Share this post


Link to post
Share on other sites

Ah, the demo might have some special code restrictions/limitations in terms of the directories.  That's entirely possible.  Glad you got stuff to work because for a second there I was scratching my head!

Steve

Share this post


Link to post
Share on other sites

LOL. Oh, it drove me up the wall. I am pretty adept with mods and their ins and outs and I was going nuts trying to figure out what could be wrong. The data folder idea struck me right when I hit send on the first post. I remembered that both BN and SF1 both used it, so I figured I'd give it a go.

 

Mord.

Share this post


Link to post
Share on other sites

all I want to say is "Wilcox Pass!" What a dam fine map and mission; I just spent about 45 min in completely demolishing those rebels in Syria... in veteran mode.

Just wish I would've gotten the screenshots to work, for some reason the game wouldn't let me get past the UI front end screen splash, that's all it would screenshot of and not the inside of the game. It's as if the UI front end is overlaid on the game itself. so this is a screen shot of the ingame mission? this is all it would let me see if I screenshot from inside of a mission or battle.. 

uisplash.jpg.89262f1d0b4219109f3e211d0994e889.jpg

Share this post


Link to post
Share on other sites

CMSF Demo Tutorial mission has a reference to "Or bring in the Bradleys to bring them down with direct fire" on page two of the briefing, when the Bradleys in the CMBS tutorial have been replaced with Strykers.

(Totally unacceptable, I demand a full refund, Your lineage will cursed until the seventh generation, etc.).

Share this post


Link to post
Share on other sites

Very exciting news!

Please note that the information on the www.battlefront.com main page regarding release dates and demo release is now outdated!

Best regards,
Thomm

 

 

 

Share this post


Link to post
Share on other sites
3 minutes ago, domfluff said:

CMSF Demo Tutorial mission has a reference to "Or bring in the Bradleys to bring them down with direct fire" on page two of the briefing, when the Bradleys in the CMBS tutorial have been replaced with Strykers.

(Totally unacceptable, I demand a full refund, Your lineage will cursed until the seventh generation, etc.).

Dang!!  We fixed that for the full version scenario but apparently missed it for the demo.  If you saw how many emails went back and forth about that little typo you'd crack up :D

Steve

Share this post


Link to post
Share on other sites
1 hour ago, Buzz said:

...macOSMojave v10.14...and CMSF 2 Mac Demo runs without problem. CMSF 2 Mac Demo plays and looks great

Glad to hear that. I am considering upgrading to Mojave and have a concern about my favorite games running okay on it.

Michael

Share this post


Link to post
Share on other sites
2 hours ago, 71st_Mastiff said:

all I want to say is "Wilcox Pass!" What a dam fine map and mission; I just spent about 45 min in completely demolishing those rebels in Syria... in veteran mode.

 

I'm assuming you mean Passage at Wilcox? Glad ya enjoyed it!

Share this post


Link to post
Share on other sites

Hey Guys - the text on the menus and the briefings is very pixellated and hard to read - I remember this issue used to occur way back in the previous titles as well.

Anyone figure out how to force a higher resolution on the menu, and the game itself? The highest I get is 1280x800, but I have a 4k Laptop Screen. When I select desktop resolution option, it still shows me really pixellated graphics within the game. 

 

Edited by VasFURY

Share this post


Link to post
Share on other sites
20 minutes ago, VasFURY said:

Hey Guys - the text on the menus and the briefings is very pixellated and hard to read - I remember this issue used to occur way back in the previous titles as well.

Anyone figure out how to force a higher resolution on the menu, and the game itself? The highest I get is 1280x800, but I have a 4k Laptop Screen. When I select desktop resolution option, it still shows me really pixellated graphics within the game.

That is also a symptom of running the game on a poor graphics card - do you have two on your box? If so you need to make sure CMSF is running on the high powered one and not the on the mother board crappy one. The game .exe is specific for the demo so you will need to create a new mapping for it.

Share this post


Link to post
Share on other sites
8 hours ago, Blazing 88's said:
10 hours ago, 37mm said:

Thank you, just given it a quick whirl... have any of your Beta testers mentioned any issue's with frame rates?

I am guessing (intel integrated video card) with the new install of the demo, your onboard Intel graphics card is now running the game.  If Nvidia, use the control panel and make a profile for the demo.

That's what I was about to say too. Did that help @37mm?

Share this post


Link to post
Share on other sites
2 hours ago, Battlefront.com said:

Dang!!  We fixed that for the full version scenario but apparently missed it for the demo.  If you saw how many emails went back and forth about that little typo you'd crack up :D

Oh man - that was my thought too when I read @domfluff's post. And I was just an observer to the back and forth on the message board and on part of any email thread.

Share this post


Link to post
Share on other sites
31 minutes ago, VasFURY said:

Hey Guys - the text on the menus and the briefings is very pixellated and hard to read - I remember this issue used to occur way back in the previous titles as well.

Anyone figure out how to force a higher resolution on the menu, and the game itself? The highest I get is 1280x800, but I have a 4k Laptop Screen. When I select desktop resolution option, it still shows me really pixellated graphics within the game. 

 

This

6 minutes ago, 71st_Mastiff said:

turn off FXAA if you're running on NVIDIA, the game is openGL. 

P

Share this post


Link to post
Share on other sites
31 minutes ago, IanL said:

That is also a symptom of running the game on a poor graphics card - do you have two on your box? If so you need to make sure CMSF is running on the high powered one and not the on the mother board crappy one. The game .exe is specific for the demo so you will need to create a new mapping for it.

Although I have a laptop (Alienware R17) - I only have the Geforce 1080 inside of it (so, just one dedicated card, no Intel). Nevertheless, I tried messing with the Nvidia control panel, but it doesn't seem to change anything.

 

Tried Turning off FXAA as per Pete's suggestion - still same problem. Game's resolution is just set to very low, and "use desktop" mode doesnt seem to improve it. 

 

Share this post


Link to post
Share on other sites
2 minutes ago, VasFURY said:

Although I have a laptop (Alienware R17) - I only have the Geforce 1080 inside of it (so, just one dedicated card, no Intel). Nevertheless, I tried messing with the Nvidia control panel, but it doesn't seem to change anything.

 

Tried Turning off FXAA as per Pete's suggestion - still same problem. Game's resolution is just set to very low, and "use desktop" mode doesnt seem to improve it. 

 

You will still have a low powered Intel GPU in it.

Edited by Jock Tamson

Share this post


Link to post
Share on other sites
35 minutes ago, 71st_Mastiff said:

turn off FXAA if you're running on NVIDIA, the game is openGL. 

Why?  It is post processing.  It will make your text blurry, but will still work.  A better result can be obtained by injecting SMAA via SweetFX

Share this post


Link to post
Share on other sites
9 hours ago, Blazing 88's said:

I am guessing (intel integrated video card) with the new install of the demo, your onboard Intel graphics card is now running the game.  If Nvidia, use the control panel and make a profile for the demo.

It wasn't that however I've toned down some of the graphics card settings, reduced the display resolution & changed the game settings to low tree detail... the game is now playable for me (indeed with shaders & shadows off it's positively nippy).

However I've never had to do any of that for any of the other Demo's or my CMRT.

i52400 with GTX 1050 Ti card... my CMRT plays smoothly like this (at 4k resolution!).

Share this post


Link to post
Share on other sites
4 minutes ago, 37mm said:

It wasn't that however I've toned down some of the graphics card settings, reduced the display resolution & changed the game settings to low tree detail... the game is now playable for me (indeed with shaders & shadows off it's positively nippy).

However I've never had to do any of that for any of the other Demo's or my CMRT.

i52400 with GTX 1050 Ti card... my CMRT plays smoothly like this (at 4k resolution!).

Wow that looks gorgeous! My SF2 looks nowhere near that, what with all the pixels popping out.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×