Jump to content
  • Announcements

    • Battlefront.com

      Special Upgrade 4 Tech Tips   12/27/2016

      Hi all! Now that Upgrade 4 is out and about in large quantities we have now discovered a few SNAFUs that happen out in the scary, real world that is home computing.  Fortunately the rate of problems is extremely small and so far most are easily worked around.  We've identified a few issues that have similar causes which we have clear instructions for work arounds here they are: 1.  CMRT Windows customers need to re-license their original key.  This is a result of improvements to the licensing system which CMBN, CMBS, and CMFB are already using.  To do this launch CMRT with the Upgrade and the first time enter your Engine 4 key.  Exit and then use the "Activate New Products" shortcut in your CMRT folder, then enter your Engine 3 license key.  That should do the trick. 2.  CMRT and CMBN MacOS customers have a similar situation as #2, however the "Activate New Products" is inside the Documents folder in their respective CM folders.  For CMBN you have to go through the process described above for each of your license keys.  There is no special order to follow. 3.  For CMBS and CMFB customers, you need to use the Activate New Products shortcut and enter your Upgrade 4 key.  If you launch the game and see a screen that says "LICENSE FAILURE: Base Game 4.0 is required." that is an indication you haven't yet gone through that procedure.  Provided you had a properly functioning copy before installing the Upgrade, that should be all you need to do.  If in the future you have to install from scratch on a new system you'll need to do the same procedure for both your original license key and your Upgrade 4.0 key. 4.  There's always a weird one and here it is.  A few Windows users are not getting "Activate New Products" shortcuts created during installation.  Apparently anti-virus software is preventing the installer from doing its job.  This might not be a problem right now, but it will prove to be an issue at some point in the future.  The solution is to create your own shortcut using the following steps: Disable your anti-virus software before you do anything. Go to your Desktop, right click on the Desktop itself, select NEW->SHORTCUT, use BROWSE to locate the CM EXE that you are trying to fix. The location is then written out. After it type in a single space and then paste this:

      -showui

      Click NEXT and give your new Shortcut a name (doesn't matter what). Confirm that and you're done. Double click on the new Shortcut and you should be prompted to license whatever it is you need to license. At this time we have not identified any issues that have not been worked around.  Let's hope it stays that way Steve
    • Battlefront.com

      Forum Reorganization   10/12/2017

      We've reorganized our Combat Mission Forums to reflect the fact that most of you are now running Engine 4 and that means you're all using the same basic code.  Because of that, there's no good reason to have the discussion about Combat Mission spread out over 5 separate sets of Forums.  There is now one General Discussion area with Tech Support and Scenario/Mod Tips sub forums.  The Family specific Tech Support Forums have been moved to a new CM2 Archives area and frozen in place. You might also notice we dropped the "x" from distinguishing between the first generation of CM games and the second.  The "x" was reluctantly adopted back in 2005 or so because at the time we had the original three CM games on European store shelves entitled CM1, CM2, and CM3 (CMBO, CMBB, and CMAK).  We didn't want to cause confusion so we added the "x".  Time has moved on and we have to, so the "x" is now gone from our public vocabulary as it has been from our private vocabulary for quite a while already.  Side note, Charles *NEVER* used the "x" so now we're all speaking the same language as him.  Which is important since he is the one programming them
Mord

How To Install Mods

Recommended Posts

Not sure whats going on but i can not get Tanks a Lot's CMBN buildings, by Tanks a Lot to work, my self and one more member of BOB are unable to get it to work in CMBN.

One more thing, with or with out a mod. Why can you not get a wall or fence ect to go from south to north ^.

Share this post


Link to post
Share on other sites

Most of them will. Some like Vinnart's animated text, need the updated version.

However, before you install MG, remove your z folder. After install put it back. Can cause problems if you forget to do this for any patch.

Share this post


Link to post
Share on other sites
However, before you install MG, remove your z folder. After install put it back. Can cause problems if you forget to do this for any patch.

Ahh...oops, was going to do this but forgot. Hope all is OK.

Thanks for the response. No aminated text mod, mainly just the mod pack.

Share this post


Link to post
Share on other sites

If you have anything odd going on, remove the z folder, start the game, click on something (don't actually have to play any turns), and shut down. Move the z folder back in and all *should* be well.

Share this post


Link to post
Share on other sites

I'm playing CMBN-CW on a MacBook Pro and the game is playing fine. But for the life of me I can't figure out how to get a mod to work. I've got the Z folder in the Data folder and downloaded a zipped mod into that. I unzipped the mod, in this case there were two .bmp images or files, but now what do I do with them? I've read and reread several posts and still can't figure it out. I'm still a newbe with the Mac filing system, so that doesn't help.

I don't suppose there is a video that would show the procedure in detail how to do it?

Share this post


Link to post
Share on other sites

Folks,

I have V2.12 of CMBN running on a Windows 7 box...

Ok, many uniform mods simply don't work for me...e.g. I place afolder called "german soldier m43" with files like "german-uniform-m43 1.bmp" into my data/Z folder and then start the game and use a scenario/quick battle which uses regular army and I don't see them??? I've rezexploded all of the brz files which came with the game to validate the specific bmp file names and they *should* work...but...alas...they don't.

Perhaps I'm doing something basically wrong...although I don't believe I am...

Could someone please assist in this troubleshooting endeavour?

Thanks

Share this post


Link to post
Share on other sites

You don't as far as I know. Those were a hex edit with a long and storied history of misery and woe. It was quite a mystery to solve and was worked on by a couple of us modders. Somehow DC got them to work but the upgrade changed some things and I don't think he went back and was able to figure them out again. So, in short, don't pull your hair out thinking you are doing something wrong. You aren't.

Mord.

Share this post


Link to post
Share on other sites

Hi all.

Currently using Z-Bee mod manager with CMSF.

I understand it also works with CMBN but I would need to install it again. When I try to install a second manager all I get is an option to Repair or Un-Install.

Any advise.

Thanks JTF

Share this post


Link to post
Share on other sites
Hi all.

Currently using Z-Bee mod manager with CMSF.

I understand it also works with CMBN but I would need to install it again. When I try to install a second manager all I get is an option to Repair or Un-Install.

Any advise.

Thanks JTF

You won't technically need to reinstall it again. In the directory that z-bee's mod manager gets installed (C:\Program Files (x86)\zBee14 on my machine) will be a file called "z-Bee 1.4 CMSF Mod Manager.accdr". The mod manager is just a microsoft access database, so if you make a copy of this file you can set the second copy up for CMBN, each file is a completely separate database(making each file a completely separate mod manager). This can be done as many times as you want, one for each CM game. I just renamed the copies to what game I was going to use that file for then setup an icon for it.

Edit- forgot to add that the copy will have the settings saved from the original file as well as the mods installed. The directories you will need to change first, then for the mods you can deactivate them each, then remove them from the mod list. Without changing the directories first you'll deactivate the mods in CMSF, if you change the directories first then deactivate a mod it'll say that the mod wasn't found in the z folder(this is what we want to see)

advanced computer user - you can open z-Bee14CMSFModManager.msi (the install file for the mod manager) using 7-zip and it'll have the original database file, which can then be extracted where you want

Share this post


Link to post
Share on other sites

Hello

I apologise in advance if this problem has already been covered in this thread, I couldn't see it when looking over the weekend. I'm still pretty new to CMx2, and have only just been bitten by the modding bug. Most of the mods I've installed have worked first time, and if they haven't then I've found my answer in here. But, one problem I just can't solve is Infantry Shoulder Insignia....

Example No. 1 .... When I installed DC's 15th Scottish mods, the UI and the vehicles both have the "Lion Rampant" showing. But, the infantry are still sporting the 49th's Polar Bear insignia.

Example No. 2 ... When I've tried ez's American Infantry mods I've encountered the same problem. I attempted to rename folders and individual files without success.

If anyone can help I'd be grateful.

Cheers

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×