Jump to content

Bug in Scenario Editor?


Andy_101
 Share

Recommended Posts

Hi guys,

 

So I'm trying to create a scenario and I've come across a bug (I think it's a bug).  It's something I've come across before on other CM games but never got around to reporting until now.  

You'll see from the below picture I have an enemy squad inside some vehicles.  This screenshot is taken from the scenario editor.

screenshot_2018_12_2_sUbya.jpg.ee4758bd03f3a779532e43e9ec5f94ea.jpg

The below screenshot is the same squad but taken during Scenario testing phase.  As you'll see the troops have disappeared and only the vehicles have remained.  The troops are not on the map anywhere.

screenshot_2018_12_2_AnXgc.jpg.98e1ea1a0b58adb09838a378d10c37b0.jpg

 

The vehicles and the troops are all part of the same squad (2nd platoon) and they do not have different AI orders from each other.  I set up trigger orders for the vehicles to drive to a village and then dismount the troops.   

 

What is going on here?

 

 

Much love,

 

A.  :)

 

Link to comment
Share on other sites

Never seen that and I spend a lot of time in the editor. Can you upload a link to the scenario in Dropbox please? Be easier to see what’s up. My suspicion is you might have inadvertently tagged the squad as a reinforcement rather than an AI group. Easy done. Check number against group should say A* rather than R*. 

Link to comment
Share on other sites

Hi George,

 

Thanks for the reply. Definitely not tagged as 'R'.    And to reiterate this isn't the first time I've come across this.  I've come across this on other CM games too, which makes me think it's most likely something I am doing wrong than a bug.

 

Below is a link to the scenario file. 

 

https://www.dropbox.com/home/CMSF2?preview=Open.btt

Link to comment
Share on other sites

I have seen something like this but caused by something completely different.  When splitting teams and mounting in vehicles I have run into an occasional issue that team members go missing.  If I unmount in the editor and reopen they show up again. It has not been consistent and the simplest remedy for me was to start them unmounted.  As long as they are all in the same set up zone I can then mount them first turn and no ill effect.  I could only make this happen when mounting them in the editor.

Link to comment
Share on other sites

17 minutes ago, MarkEzra said:

Doubtful about bug... Look carefully at the trigger setup... most likely the AI is following your orders... it never cheats

It isn't about cheating.  There are things that you can do in the editor that once you load into a btt don't seem to work.  I'd created a ticket on it and discussion amongst beta folks.  I was experimenting with different ways of mounting a platoon and ran into a situation that once I opened as a battle team members just disappeared.  Recreating it was not consistent and the simplest way to avoid it was as I mentioned to not mount the troops in the editor.  In my case there were no triggers or AI plan whatsoever, it was the human controlled side, no reinforcements set etc.  I would check his file but the link does not seem to work.  Likely a permissions issue on the file link he sent.

 

PM sent

Edited by sburke
Link to comment
Share on other sites

Not looked at the file, but I've just looked at one of my CMBS projects. Quick testing reveals that the visual indicator in the form of a unit icon for the mounted element isn't there but the mounted unit is. Try clicking on your BMPs and see how many passenger slots show as occupied. In my project used for this quick test, I could see both crew and passenger slots occupied but no unit icon for the passengers. On destruction of vehicles, I've seen the crew dismount from their hatches and the pax out of the rear doors. On dismount the unit icons appear.

Here's some pictures:

1793799149_BeforetheGoodNews.png.4378515cf3f4ff03628d59ac9ead5d84.png

1518666254_AftertheGoodNews1.png.3e78615bd2fb56cc624c2ff31fc65e10.png

1198618310_AftertheGoodNews2.thumb.png.8294e16637afa76138f3ff6148ec1b99.png

While only two of the four pax dismount in these screenshots, this is because the other two team members got whacked when the vehicle was KO'd.

I guess it is a bug because in scenario author mode you should see everything but somebody else may have a better view on it than me.

Edited by Combatintman
Link to comment
Share on other sites

This isn't a bug.  It has always been this way.  When you are playing a scenario against the AI in any mode, AI controlled passengers will not show up as separate icons even in scenario author test mode.  You can't select a passenger when it is controlled by the AI, you can only select the vehicle they are riding in.  Now if you are playing as that side and the passengers aren't selectable well then you have a problem, but since AI passengers only dismount when the AI orders tell them to dismount then there is no need for the passengers to be selectable.  Obviously in other modes showing the passengers would be a major fog of war issue.  That isn't an issue in Scenario Author Test mode obviously, but I'm going to guess that it would have taken special 'override' coding of some sort in order to make the passengers show up in that mode and since you can't manually dismount them when they are AI controlled then really, what's the point?

Link to comment
Share on other sites

31 minutes ago, ASL Veteran said:

This isn't a bug.  It has always been this way.  When you are playing a scenario against the AI in any mode, AI controlled passengers will not show up as separate icons even in scenario author test mode.  You can't select a passenger when it is controlled by the AI, you can only select the vehicle they are riding in.  Now if you are playing as that side and the passengers aren't selectable well then you have a problem, but since AI passengers only dismount when the AI orders tell them to dismount then there is no need for the passengers to be selectable.  Obviously in other modes showing the passengers would be a major fog of war issue.  That isn't an issue in Scenario Author Test mode obviously, but I'm going to guess that it would have taken special 'override' coding of some sort in order to make the passengers show up in that mode and since you can't manually dismount them when they are AI controlled then really, what's the point?

Sounds fair enough - as I said in my post 'somebody else may have a better view on it than me'. Looks like you're that guy @ASL Veteran 😉

Link to comment
Share on other sites

9 hours ago, ASL Veteran said:

This isn't a bug.  It has always been this way.  When you are playing a scenario against the AI in any mode, AI controlled passengers will not show up as separate icons even in scenario author test mode.  You can't select a passenger when it is controlled by the AI, you can only select the vehicle they are riding in.  Now if you are playing as that side and the passengers aren't selectable well then you have a problem, but since AI passengers only dismount when the AI orders tell them to dismount then there is no need for the passengers to be selectable.  Obviously in other modes showing the passengers would be a major fog of war issue.  That isn't an issue in Scenario Author Test mode obviously, but I'm going to guess that it would have taken special 'override' coding of some sort in order to make the passengers show up in that mode and since you can't manually dismount them when they are AI controlled then really, what's the point?

Aha,  you're right!  The troops are indeed there and when the vehicles arrived at their destination, out they popped!  

Thanks for the clarification @ASL Veteran

 

:)

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...