Jump to content

Windows 7


Recommended Posts

  • 10 months later...

I am running windows 7-64bit Nvidia G force GTS 250. Games boot up fine and everything is good in game until my mouse touches any of the buttons at the bottom of the screen. If I click the turn camera buttons at the bottom everything freezes up and I get the crazy/absent text boxes. I also get a system alert in a text bubble on the desktop that my display driver stopped working but has recovered. I can alt+ tab back into the program and the text will be back to normal again but as soon as my cursor touches the bottom panel the screen will eventually go entirely black again. I can keep alt tabbing back in.

Whats the best way to fix this? I downloaded the vista patch thinking that might fix it but apparently i just blew my money because all that did is give me a black screen when I booted it up.

I have got the 'combat mission anthology series of discs' (special edition).

Thanks for any help.

Link to comment
Share on other sites

You're having problems getting the Vista patch to work ? Were you able to license the game/patch at all ? Did you get any error dialog boxes ? Did you copy all three files to the appropriate directory (the main game executable, 'elicen40.dll' and 'msvcr71.dll') in the CMAK/CMBB install (they can't run by themselves in their own directory) ?

I don't know if the 1.04 'Vista patch' will address this problem or not. One of the major problems experienced by Vista users with DirectX 10 capable video cards was their 3D screens being "filled with edges" as the 3D view was rotated. The 1.04 patch was created by an outside developer who updated a few of the DirectX calls to be a bit more compliant with newer versions of DirectX. Newer DirectX calls were used in place of older ones that may not see as much support from newer video drivers. So the 1.04 patch should hopefully make the games a bit more future-proof in some respects since a few of the older calls were updated. However not every driver problem will probably be rectified by the 1.04 patch.

It's also possible that this issue may be peculiar to certain driver versions. I don't know which driver to recommend in this case though. The GeForce GTS 250 can work with a driver as old as the 181.71 under Windows 7 64-bit. However some users have had better experiences with some of the 190 series drivers compared to the 180 series when it comes to the CMx1 games, but that has not always been a consistent experience.

Link to comment
Share on other sites

I installed the patches on my special edition version which I later realized didn't need to be done. Maybe this is why I just got a black screen with the mouse visible. I'll retry the process.

I just copy those extracted licence files into the CMBB program file folder, right?

Link to comment
Share on other sites

The 'Combat Mission Anthology' edition has the latest patches, with the possible exception of CMAK (I'm not sure). You'll want your versions updated to the latest patch BEFORE installing the 1.04 patch. I can't recall if the CMAK 1.03 patch has more than just the executable. If it is just the executable alone, then the 1.03 patch wouldn't be needed (since the 1.04 patch will have all of the 1.03 executable's updates).

Yes, you will need to copy all three files extracted that I mentioned earlier into the CMBB folder. The same directory where your current 'Barbarossa to Berlin.exe' file is located (I can't remember if CDV renamed the main executable though).

Link to comment
Share on other sites

  • 2 weeks later...

Hello all. Installed original version - haven't patched yet - on W7 64bit and have no scenarios listed - just see the force icons. I understand this is a known issue but have not seen a solution.

Video card = ATI Radeon HD 5670 1GB (supports DX11 - but I have DX9C installed)

Suggestions?

Also, how does on set Rez to the highest supported?

Link to comment
Share on other sites

For resolution, delete your existing Combat Mission (game name) Pref file ("preferences" for short), and the next time you start the game it will step down through its available screen settings, letting you choose one that looks correct on the screen. I recommend a 60 hz refresh rate if you are using an LCD, but the resolution can be the highest it chooses.

You must patch, but for CMAK the last is an all inclusive so the process is quick.

My only other advice is to be sure you update your video card drivers. I don't have an ATI card, I have a Geforce, so I won't see the same behaviors you do. But I did have issues with 7 until I updated my drivers manually, but afterward it works.

The card companies simply need some time to ensure their settings and the new operating system are playing well together. By now for 7 they should have done so (and appear to have for recent Geforce cards).

Link to comment
Share on other sites

If you're not seeing the scenarios and this is a Battlefront version of CMAK (and not a download from another company), then what you may need to do is to Alt-Tab to minimize the game and then re-maximize it. This should 'force a refresh' and you should hopefully see all of the scenarios listed. However you will have to repeat the 'Alt-Tab / re-maximize' routine for each 2D screen as you select your options to play.

This has been a problem with the ATI/AMD drivers (and some others) for quite awhile now. It isn't consistent for all ATI/AMD Radeon users, but I'm fairly sure it happens very frequently.

Link to comment
Share on other sites

I've got Windows 7 and a Radeon 5850. I'm installing the anthology version of CMAK.

The "choose a resolution" screens are black, but when I pick one, I get the game starting as I'd expect, and the scenario chooser is all fine. The problems start when I'm in the game (the tutorial scenario): there are two regions of screen, about 2/3 of the way up, and a 1/4 the way in from each edge which are scrambled. Looks like label texts and that sort of thing, all jumbled up, with black squares with white dots in.

I can whiffle round the quick battle screens okay, without having to Alt-tab out, and these scrambled bits aren't too much of an issue, so long as they're not supposed to be showing me anything important; I can't see any screenshots in the manual that mention there being any data other than the game field.

Any thoughts?

Link to comment
Share on other sites

This is an issue with some of the newer ATI/AMD Radeons and the Catalyst drivers that have been available lately. Here's another thread that mentions this problem. I believe 4xxx and 5xxx series Radeons will see this problem with Catalyst drivers since the late 9.x series. Older Radeons MIGHT NOT have this problem.

The only hope is that ATI/AMD fix this issue sometime in the future. I don't know of any workarounds at this point, though I haven't checked the latest drivers to see if this somehow got fixed (not likely, unfortunately).

It appears as if the Catalyst driver is caching some sort of text that appears in the control panel and writing it above into the 3D space (overlaid in appearance, rather than actual 3D). I don't believe that the 1.04 patch will fix this issue, though I haven't checked. If you want to check yourself (if you're not already running 1.04), download the CMAK Demo (1.04).

Link to comment
Share on other sites

It appears as if the Catalyst driver is caching some sort of text that appears in the control panel and writing it above into the 3D space (overlaid in appearance, rather than actual 3D). I don't believe that the 1.04 patch will fix this issue, though I haven't checked. If you want to check yourself (if you're not already running 1.04), download the CMAK Demo (1.04).

Well, that works lovely... Thanks Schrullenhaft for your advice.

Edit p.s. It was worth $5 to get rid of the uglies... :) It doesn't fix all graphical issues though; there were some heavy buildings poking through the expanded unit info pane, but it's much better.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...