Jump to content

performance..?


G B Scurlock
 Share

Recommended Posts

I just downloaded the demo. On my machine, it's horrible. I did turn the resolution up to where the game would look somewhat presentable on a wide screen 22" monitor, so that could be the cause of why it's choppy as hell. But for the resolution I chose, the graphics are still very bad. Without throwing my specs out there, let's just say I can run everything else out there.

Is the full version any better? I was a huge fan of the CM series. Although the graphics weren't great, it was revolutionary as far as game play. I just don't see that here. I mean no offense to the developers. I mean I'd certainly like to give it a shot, but if it won't even work on machines that are already pushing the limits of modern technology, where do we turn to?

Link to comment
Share on other sites

I just downloaded the demo. On my machine, it's horrible. I did turn the resolution up to where the game would look somewhat presentable on a wide screen 22" monitor, so that could be the cause of why it's choppy as hell. But for the resolution I chose, the graphics are still very bad. Without throwing my specs out there, let's just say I can run everything else out there.

Is the full version any better? I was a huge fan of the CM series. Although the graphics weren't great, it was revolutionary as far as game play. I just don't see that here. I mean no offense to the developers. I mean I'd certainly like to give it a shot, but if it won't even work on machines that are already pushing the limits of modern technology, where do we turn to?

Well, the game runs GREAT on my system, as well as the demo. I can turn on all the high graphics options and settings, and I run it on my Acer 22" wide screen LCD at 1680x1050 resolution. No chop what so-ever, smooth as silk. My system is high end though. Here are my specs:

SYSTEM SPECS

Hardware:

EVGA X58 TRI-SLI main board

I7 940 cpu with Thermaltake SpinQ Cooler

12 GB Corsair XMS PC1066 Triple Channel Ram

nVidia GeForce 260 Superclocked Edition PCI-E GPU

(2x) Western Digital 150 GB SATA HDD (not currently in RAID config)

(1x) Seagate 500 GB SATA II HDD

RealTek 5.1 Ch Audio

Lite-On DVD Multi Recorder Drive

TSST DVD RW Drive

Antec Nine Hundred Case

Ultra X3 1000w ATX Power Supply

BOSE Companion 3 series 2.1 Speakers

Acer AL2216w 22" widescreen LCD Monitor

Acer X223 Wbd 22" widescreen LCD Monitor

Software:

Dual Boot setup

Microsoft Windows Vista 64-bit w/SP1

Microsoft Windows 7 beta

The ONLY problem I have is that I can not get it to run under Vista64, but it runs great under Windows 7 beta. Has to be some kind of software problem, but I'm not too worried about as I'm sure I and the Battlefront tech folks will get it figured out soon enough.

Link to comment
Share on other sites

The ONLY problem I have is that I can not get it to run under Vista64, but it runs great under Windows 7 beta. Has to be some kind of software problem, but I'm not too worried about as I'm sure I and the Battlefront tech folks will get it figured out soon enough.

This does not bode well, I only have Vista 64 bit.

I will now soon enough...

*pokes installer* :)

Link to comment
Share on other sites

For people having trouble running under Vista 64x, just right click on the games shortct and select the "Run as Admin" option and see if that doesn't work. From the few people that I have seen that had a problem, doing that simple fix, allowed the game to run for them.

I have played and tested ToW-2 with both Vista (64x) and Windows 7 (64x) with no issues, but I had turned off UAC in both OS's a long time ago. ;)

Madmatt

Link to comment
Share on other sites

I had not mentioned this before, but I also have turned of UAC in both Vista64 and Windows 7, yet I still can not get the game to run in Vista 64 (but it will run in Windows 7 great). Even if I just right click on the games shortcut and select the "Run as Admin", in Vista 64, the game loads, but CTD when I try to load a battle/campaign. Again though, this problem does not exist for me in Windows 7 beta, so I can play the game. Still, I would like to get my Vista 64 problem fixed.

Link to comment
Share on other sites

i've vista 64bit and i can run the game. i use the administrator-thing.

btw, my specs and the resulting fps:

intel dual core, 3,6gig

hd4870, 512videoram

4gig ram

soundblaster titanium

1680x1050

all maxed out

fps 15-20 in the cities

40+ in the desert

well, i thing i can play fine with fps in the 15-20. i mean, its not a shooter or a flightsim, where you need high fps.

Link to comment
Share on other sites

The game runs bad with 20 fps. I bought TOW 1, CMSF and TOW 2 and every game sux in performance!!!

My system

e8400 @ 3600 Mhz

4 GB RAM

nvidia 8800 GTX OCC (same settings as the 8800 Ultra)

x-fi Soundcard

I tested Vista 32 and XP. On both systems it runs bad. Im not a noob with computers, games etc...

Link to comment
Share on other sites

The game runs bad with 20 fps. I bought TOW 1, CMSF and TOW 2 and every game sux in performance!!!

My system

e8400 @ 3600 Mhz

4 GB RAM

nvidia 8800 GTX OCC (same settings as the 8800 Ultra)

x-fi Soundcard

I tested Vista 32 and XP. On both systems it runs bad. Im not a noob with computers, games etc...

Do you got the latest drivers?

Link to comment
Share on other sites

 Share

×
×
  • Create New...