Jump to content
Sign in to follow this  
purpheart23

Correct Installation/Patching order

Recommended Posts

Forgive my naivety. It's been a hot minute since CMSF has been installed on my hard drive and I have forgotten the correct install/patching order with all modules. Help would be greatly appreciated.

Share this post


Link to post
Share on other sites

Probably in the same vein, but direct from the knowledge base. This is really a great underutilized resource. I think Erwin's post is actually a direct copy from this. Easier to remember to go back to the knowledge base than find a post however. I just reinstalled CMSF on a new machine this summer and this worked exactly as described.

http://battlefront.mojohelpdesk.com/help/article/127930

I need to reinstall CMSF and one (or more) modules. How do I do that?

If you have a CMSF module, then you do not need your base game license key (ever again). That's because when you activate a module with a module license key, the base game is activated automatically as well. There is no need to license the base game separately if you intend to install a module with it.

For Windows Vista and Windows 7 users we recommend running the installers by right-clicking and selecting "Run as administrator" from the popup menu.

The default directory for Battlefront versions is usually '\Program Files\Battlefront\Combat Mission Shock Force' for 32-bit versions of Windows and '\Program Files (x86)\Battlefront\Combat Mission Shock Force' for 64-bit versions of Windows. Please double-check where you install the game and ensure that modules and patches install to the appropriate directory. A new folder/directory in the game's actual directory would be an incorrect location to install a patch to. Most patches will replace the main game executable and you should get confirmation that the patch installed properly by looking for this version number at the bottom, middle of the main menu screen.

Here is the correct way to reinstall CMSF and its modules (as of patch v. 1.32):

Install CMSF, do NOT license it if it is a Battlefront version.

Install the v. 1.10 patch for your distribution (Battlefront or Paradox). This step is sometimes not needed if you have the Marines module, but bundles that include the Marines module may not have all of the necessary files that are part of the v. 1.10 patch.

If you have the Marines module, install it now.

If you have the Marines module, launch CMSF and use the Marines license key to activate (this activates both CMSF and the Marines module).

If you have the British Forces module, install it now.

If you have the British Forces module, launch CMSF and use the British Forces license key to activate it now.

Install the v. 1.21 patch. Make sure to make the correct selections for the modules you have. Making an incorrect selection will result in modules disappearing or license key requests for modules you do not have. If you run into this problem reinstall the v. 1.21 patch again and make the correct selections. You must install the v. 1.21 patch BEFORE installing the NATO module.

If you have the NATO module, install it now.

If you have the NATO module, launch CMSF and use the NATO license key to activate it now.

Install the v. 1.31 patch. Make sure to make the correct selections for the modules you have. Making an incorrect selection will result in modules disappearing or license key requests for modules you do not have. If you run into this problem reinstall the v. 1.31 patch again and make the correct selections.

Install the v. 1.32 patch. Make sure to make the correct selections for the modules you have. Making an incorrect selection will result in modules disappearing or license key requests for modules you do not have. If you run into this problem reinstall the v. 1.32 patch again and make the correct selections.

Share this post


Link to post
Share on other sites

Thanks sburke, i appreciate the replies. I'm sure I'm not the only one that's had this problem and the forum being a little less utilized nowadays thanks to the fabulous WWII titles had most of the threads disappearing. :)

Share this post


Link to post
Share on other sites

I have concerns by downloading patches for shock strength, no matter the servers, in every download, the file is infected.

If somebody can send my them via dropbox.

Thus, I need patches, 1.21, 1.31 and 1.32.

I wish to design a scenario with the magnificent card of Ramadi, but for it mission shock has to fight strength is updated.

Thank you in advance.

Share this post


Link to post
Share on other sites

You may be getting 'false positives' with the scans of your patch downloads. What exact 'infections' does your security software say that the files have ? The file from the 'Battlefront server' should be fine, though you may still get a false positive from your security software.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...