Jump to content

Interface problem: Cannot step through units


Recommended Posts

I've just installed CMRT, and two interface issues have jumped out at me:

1) the - and + keys normally used to step through units (i.e. to select the previous or next unit) don't function.

2) Looking at the Command list under Options, the final items in the list don't seem to offer the ability to map keys for stepping through units, for changing graphics, or for chat (the items that come last in the list in CMBN and CMFI). Instead, the final items are labeled as repeats of movement keys.

I don't believe I did anything unusual in my installation. Has anyone else noticed these problems?

Link to comment
Share on other sites

Hmmm... I've got the game open now and +- is working just fine. I'm on a PC.

Do not discount the possibility that your keyboard is shot. I've run through three keyoards, myself. Once resorting to daisy-chaining two messed-up keyboards together just so between the two all the keys would function. :)

Link to comment
Share on other sites

Well, I just tried CMBN/CMFI right now and everything is fine, so it's not the keyboard. The lack of correct entries in the Command list makes me wonder if something installed incorrectly. I'll uninstall and try again.

I'm on Windows 8.1.

Link to comment
Share on other sites

Did you move over a hotkeys.txt file from one of the other games? If so, that is likely what's causing the problem. There are slight formatting differences. Start with the default one and you can copy/paste in stuff from the old hotkeys file. As long as you replace like lines with like lines it will work fine.

Steve

Link to comment
Share on other sites

Did you move over a hotkeys.txt file from one of the other games? If so, that is likely what's causing the problem. There are slight formatting differences. Start with the default one and you can copy/paste in stuff from the old hotkeys file. As long as you replace like lines with like lines it will work fine.

Steve

I haven't moved any files at all. This problem occurs with a clean, untouched installation.

I'll try playing with the hotkey file, though, and see what happens.

One interesting point: My (unmodded, unmoved) CMRT hotkeys file ends with the following lines:

Misc Keys

//MOVE RIGHT

<E>-

//MOVE BACK

<E>=

//ROTATE LEFT (-)

<E>{

//ROTATE LEFT (+)

<E>}

//ROTATE RIGHT

<E>`

All those command labels seem wrong. The Move and Rotate have already occurred earlier in the document.

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

×
×
  • Create New...