Jump to content
  • Announcements

    • Battlefront.com

      Final Blitzkrieg v1.01 released!   05/21/2016

      Once again proving that we don't sleep much, we have just released v1.01 for CM: Final Blitzkrieg.  There's lots of great improvements and fixes now just one download away.  Click HERE to see the release notes and download links.  Thanks to everybody for reporting issues and special thanks to the testers who make sure we don't overlook them.
    • Battlefront.com

      Special Upgrade 4 Tech Tips   12/27/2016

      Hi all! Now that Upgrade 4 is out and about in large quantities we have now discovered a few SNAFUs that happen out in the scary, real world that is home computing.  Fortunately the rate of problems is extremely small and so far most are easily worked around.  We've identified a few issues that have similar causes which we have clear instructions for work arounds here they are: 1.  CMRT Windows customers need to re-license their original key.  This is a result of improvements to the licensing system which CMBN, CMBS, and CMFB are already using.  To do this launch CMRT with the Upgrade and the first time enter your Engine 4 key.  Exit and then use the "Activate New Products" shortcut in your CMRT folder, then enter your Engine 3 license key.  That should do the trick. 2.  CMRT and CMBN MacOS customers have a similar situation as #2, however the "Activate New Products" is inside the Documents folder in their respective CM folders.  For CMBN you have to go through the process described above for each of your license keys.  There is no special order to follow. 3.  For CMBS and CMFB customers, you need to use the Activate New Products shortcut and enter your Upgrade 4 key.  If you launch the game and see a screen that says "LICENSE FAILURE: Base Game 4.0 is required." that is an indication you haven't yet gone through that procedure.  Provided you had a properly functioning copy before installing the Upgrade, that should be all you need to do.  If in the future you have to install from scratch on a new system you'll need to do the same procedure for both your original license key and your Upgrade 4.0 key. 4.  There's always a weird one and here it is.  A few Windows users are not getting "Activate New Products" shortcuts created during installation.  Apparently anti-virus software is preventing the installer from doing its job.  This might not be a problem right now, but it will prove to be an issue at some point in the future.  The solution is to create your own shortcut using the following steps: Disable your anti-virus software before you do anything. Go to your Desktop, right click on the Desktop itself, select NEW->SHORTCUT, use BROWSE to locate the CM EXE that you are trying to fix. The location is then written out. After it type in a single space and then paste this:

      -showui

      Click NEXT and give your new Shortcut a name (doesn't matter what). Confirm that and you're done. Double click on the new Shortcut and you should be prompted to license whatever it is you need to license. At this time we have not identified any issues that have not been worked around.  Let's hope it stays that way Steve
    • Battlefront.com

      Forum Reorganization   10/12/2017

      We've reorganized our Combat Mission Forums to reflect the fact that most of you are now running Engine 4 and that means you're all using the same basic code.  Because of that, there's no good reason to have the discussion about Combat Mission spread out over 5 separate sets of Forums.  There is now one General Discussion area with Tech Support and Scenario/Mod Tips sub forums.  The Family specific Tech Support Forums have been moved to a new CM2 Archives area and frozen in place. You might also notice we dropped the "x" from distinguishing between the first generation of CM games and the second.  The "x" was reluctantly adopted back in 2005 or so because at the time we had the original three CM games on European store shelves entitled CM1, CM2, and CM3 (CMBO, CMBB, and CMAK).  We didn't want to cause confusion so we added the "x".  Time has moved on and we have to, so the "x" is now gone from our public vocabulary as it has been from our private vocabulary for quite a while already.  Side note, Charles *NEVER* used the "x" so now we're all speaking the same language as him.  Which is important since he is the one programming them
rocketman

Uniform mods problem after engine 4

Recommended Posts

I started making a scenario along with a uniform mod in the previous engine and has since updated to engine 4. The scenario seems to work like it should but the uniform mod doesn't. Is this a known problem? I have changed the naming to different variants along with the mod tag in line with what should be the correct file names. I even imported the mod tags again to the scenario. But the uniform mod refuses to appear. It is saved in the correct 24 bit bmp format. Can't understand what I'm doing wrong.

Share this post


Link to post
Share on other sites

Some mods do not work when CM is updated.  The problem is that one can't know which unless one tries em all.  I have dozens, probably hundreds of mods from the early days of CM2.  Don't have time to check thru em all - it would take weeks full-time.  So...  :(

Share this post


Link to post
Share on other sites
29 minutes ago, rocketman said:

I started making a scenario along with a uniform mod in the previous engine and has since updated to engine 4. The scenario seems to work like it should but the uniform mod doesn't.

I am unaware of any uniform texture name changes between v3 and v4. You could be certain by cracking open the .brz files and looking at the file names.

29 minutes ago, rocketman said:

Is this a known problem?

Nope.

29 minutes ago, rocketman said:

I have changed the naming to different variants along with the mod tag in line with what should be the correct file names. I even imported the mod tags again to the scenario. But the uniform mod refuses to appear. It is saved in the correct 24 bit bmp format. Can't understand what I'm doing wrong.

Try this. Remove the tag and make sure the mod works. Once it works put the tag back. It is really easy to mess up either step and with no log messages it is basically not possible to debug directly so you have to break things down step by step.

Share this post


Link to post
Share on other sites

Removing the mod tags from the file names worked. I will try to put them back again to test if the mod tags in the scenario didn't carry over with the engine change (despite showing in the editor).

Share this post


Link to post
Share on other sites

Update on this issue: maybe I've missed something, but it turns out that mod tags might not work if they include numbers. After changing the tag name and excluded numbers, it was [28thID], it now works.

Share this post


Link to post
Share on other sites

If you're on a lower graphics setting (I can't recall which) the game automatically limits the random numbered options seen onscreen. I vaguely recall below a certain setting the game will only give you 4-5 face variants, higher setting you'll see all of them. So theoretically numbered variant uniforms on a lower graphics setting wouldn't show all of them. I'm working off old memory and haven't played with uniforms in a dog's age so take all this with a grain of salt.

Share this post


Link to post
Share on other sites
12 hours ago, Badger73 said:

Please clarify.  Did it fail to work using mod tag [28thID]?  If so, what mod tag value worked correctly for you?

The [28thID] didn't work. I thought it might be a conflict with stock tag [muddy] that I also had. Cleared the tags from the editor and imported them again, but no luck. So I renamed it [bloody bucket] and it instantly worked. I wonder if the number messes up the uniform number order and perhaps [ID28th] would have worked. Anyway, a heads up for using numbers in mods.

@MikeyD I run at highest or next to highest settings so this shouldn't have been a problem, though I must admit I didn't know about the thing you mentioned.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×