• Announcements

    • Battlefront.com

      Final Blitzkrieg v1.01 released!   05/21/2016

      Once again proving that we don't sleep much, we have just released v1.01 for CM: Final Blitzkrieg.  There's lots of great improvements and fixes now just one download away.  Click HERE to see the release notes and download links.  Thanks to everybody for reporting issues and special thanks to the testers who make sure we don't overlook them.
    • Battlefront.com

      Special Upgrade 4 Tech Tips   12/27/2016

      Hi all! Now that Upgrade 4 is out and about in large quantities we have now discovered a few SNAFUs that happen out in the scary, real world that is home computing.  Fortunately the rate of problems is extremely small and so far most are easily worked around.  We've identified a few issues that have similar causes which we have clear instructions for work arounds here they are: 1.  CMRT Windows customers need to re-license their original key.  This is a result of improvements to the licensing system which CMBN, CMBS, and CMFB are already using.  To do this launch CMRT with the Upgrade and the first time enter your Engine 4 key.  Exit and then use the "Activate New Products" shortcut in your CMRT folder, then enter your Engine 3 license key.  That should do the trick. 2.  CMRT and CMBN MacOS customers have a similar situation as #2, however the "Activate New Products" is inside the Documents folder in their respective CM folders.  For CMBN you have to go through the process described above for each of your license keys.  There is no special order to follow. 3.  For CMBS and CMFB customers, you need to use the Activate New Products shortcut and enter your Upgrade 4 key.  If you launch the game and see a screen that says "LICENSE FAILURE: Base Game 4.0 is required." that is an indication you haven't yet gone through that procedure.  Provided you had a properly functioning copy before installing the Upgrade, that should be all you need to do.  If in the future you have to install from scratch on a new system you'll need to do the same procedure for both your original license key and your Upgrade 4.0 key. 4.  There's always a weird one and here it is.  A few Windows users are not getting "Activate New Products" shortcuts created during installation.  Apparently anti-virus software is preventing the installer from doing its job.  This might not be a problem right now, but it will prove to be an issue at some point in the future.  The solution is to create your own shortcut using the following steps: Disable your anti-virus software before you do anything. Go to your Desktop, right click on the Desktop itself, select NEW->SHORTCUT, use BROWSE to locate the CM EXE that you are trying to fix. The location is then written out. After it type in a single space and then paste this:

      -showui

      Click NEXT and give your new Shortcut a name (doesn't matter what). Confirm that and you're done. Double click on the new Shortcut and you should be prompted to license whatever it is you need to license. At this time we have not identified any issues that have not been worked around.  Let's hope it stays that way Steve
Mark_McLeod

do newer titles come with 4.0?

12 posts in this topic

I bought Final Blitzkrieg about a month ago or sooner (i can get the exact date if need be) and my game was only at 3.0 even tho the 4.0 had been out for a good amount of time before i purchased it. did something go wrong or do i have buy the 4.0 even tho its already been out for a few months, any help would be awesome aswell as if i should contact battlefront support for this.

Share this post


Link to post
Share on other sites
6 hours ago, Mark_McLeod said:

I bought Final Blitzkrieg about a month ago or sooner (i can get the exact date if need be) and my game was only at 3.0 even tho the 4.0 had been out for a good amount of time before i purchased it. did something go wrong or do i have buy the 4.0 even tho its already been out for a few months, any help would be awesome aswell as if i should contact battlefront support for this.

First of all: Good choice!

I would be surprised, if the old version is still being sold.

However, I would create a ticket and ask. The help desk is normally very responsive and will direct you to the right recipient, if necessary.

 

Share this post


Link to post
Share on other sites

Yeah, if you purchased the full product after the v4 updated was released you should have the latest version. I agree with @StieliAlpha contact the help desk.

Just for clarity the latest version of CMFB is 2.00 engine version 4. On your main menu screen in the bottom right corner that's what you should see with the latest version.

Share this post


Link to post
Share on other sites
4 hours ago, IanL said:

Just for clarity the latest version of CMFB is 2.00 engine version 4. On your main menu screen in the bottom right corner that's what you should see with the latest version.

This. I was going to say you should be careful how you are reading the version number and engine number. They most certainly are not the same thing.

Michael

Share this post


Link to post
Share on other sites

Oh man I recently got FB and the upgrade separately. Reading isn't my strong suit I guess haha. Oh well, an extra $10 for Battlefront, such is life. :rolleyes:

Share this post


Link to post
Share on other sites

Posted (edited)

Thanks for the help everyone, also do i need to install the patches from the battlefront website? or would that downgrade it. because i may or may not have them currently installed. My version is v1.02 game engine 3. i'll reinstall the whole game then ill see if i should contact them or not, once again thanks everyone!

Edited by Mark_McLeod
error

Share this post


Link to post
Share on other sites

Ya... disregard i'm dumb. I installed the patches thinking that i would need to like i did when i first bought CMSF. after a full reinstall i can confirm that it is 4.0 and this problem was on my hands. 

Share this post


Link to post
Share on other sites

Good. Yes, installing older patches over the new game would put an older .exe in place which would then show an older version.

Share this post


Link to post
Share on other sites
18 hours ago, HerrTom said:

Reading isn't my strong suit I guess haha.

What did I learn back then during my military service: Reading is not essential, but it helps a lot. 😎

Share this post


Link to post
Share on other sites

Is 4.0 really better?  Not sure I want to update all of my titles, but it looks like I may be forced to whenever they come out with a new module. 

Share this post


Link to post
Share on other sites

I personally  like 4.0 because of what they did with the infantry, being able to combine squads makes life pretty easy in some occasions. Also the infantry do run a lot more spaced out which is pretty good, and they peak around corners of buildings and walls a lot better which is helpful. Lastly being able to see how many kills your forward observer gets with the call ins is pretty neat. But other than that i dont really know what else there is, there is a hull down command but i never use it nor do i know exactly how it works. 

Share this post


Link to post
Share on other sites
On 6/17/2017 at 2:35 AM, Mark_McLeod said:

Lastly being able to see how many kills your forward observer gets with the call ins is pretty neat.

My reason for getting it.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now