Jump to content

New iMac


Recommended Posts

Just got a new iMac. It has a Geforce2 MX video card. the problem I am having with it doesn't seem to have come up in the various Geforce2 MX threads. Two problems:

CM seems to be rending in software (tres ugly).

The cursor disappears every three files (pbem processing) or so... forcing me to force quit and restart.

Any clues?

Link to comment
Share on other sites

I'm having some problems with my new iMac G4 but not any problems that you are getting. How have you set up your hard drive?

How many copies of 9.2 do you have on your hard drive, and if so which copy are you using to play CM

My only problem is the text. I can't tell how men I have left in a squad, when will my artillery fall. I'm just missing my info text. This is all slight problem compared to previous post about the nvidia. My last iMac had no problems but its graphics were pixelated compared to this powerful new machine. I think I'll settle for better and faster graphics than no text.

Link to comment
Share on other sites

As posted in another thread, I installed a new set of Nvidia drivers yesterday and I am having a variety of problems with CM. The one most relevant to the present discussion is that, while I can still see text in the unit information screens, I can't see text in the save screen.

Michael

Link to comment
Share on other sites

Originally posted by Gyrene:

Berli, I'll send you a couple of different sets of NVidia/Open GL extensions other than the ones I have already sent you to see if anything improves.

Merci beaucoup. Reading these various threads has be completely confused. It seems that what works for one person doesn't for another. I've been a Mac user since '85 and I've never seen a problem like this one
Link to comment
Share on other sites

All these problems come from Apples decision to drop RAVE graphics support. Since NVidia came to mac market only after rave was declared dead, they havent been too much into writing better rave support for their drivers.

But your problem is something else completely. Did you try scavenging the Extensions and Settings folders for ATI exensions. Those might cause a conflict.

Oh, just thought of one more thing that might be the root of the problems. :eek:

OS X installs some crap into the Classic system it uses. I forgot what exactly, but it was reported to cause problems when booting into 9.

I've found it better to have two partitions, one for X and accompanying OS 9, the other one for clean uncrapped OS 9.

Might be a tad inconvenient to reformat&repartition the HD just to see if it helps any, admitted... :rolleyes:

Link to comment
Share on other sites

Hey Berl

Did your system come default mac Os X. Mine did. I'll install these "new" drivers when I get home and check back with the thread.

My computer is 4 days old and I set up my hard drive like this.

1st partition: Mac OS X and Classic 9

2nd partition: Mac OS 9.2.2

3rd partition: Swap file

Like the rest of the mac guys in this thread, I've been using macs since system 7 and I'm the mac tech at work so I know what I'm doing (for the most part).

There is a RAVE classic extension in my system folder but I'm not sure if I disable it or what. This is all new to me.

Cheers to the iMac G4 owners

Link to comment
Share on other sites

Yeah, aint it fun. You know your mac inside out for years, then suddenly you're a know nuthin' newbie. :D

Classic RAVE, I think that's something X puts in OS9 it uses. That might have been just the thing that craps up OS9 when booted in 9, but needs to be there when booted in X.

So if it's in the 9 that's in X partition, leave it there. But if it's in the 9 partition, it shouldnt be. In that case check that X is actually using the right classic.

Link to comment
Share on other sites

There's something else going on here that we are all missing.

The OpenGL-NVidia drivers that came with the last OS update (9.2.2?) fixed most of the GeForce & CM problems for Quicksilver & before users. It worked in my case, although I still went back to the Radeon, but many others reported success with those drivers.

There must be something else in the new iMacs that is causing this problem, maybe something to do with the new screen.

I think the idea of partitioning the drives wouldn't hurt, but OS X will still write new extensions to the OS 9 system folder if Classic is envoked in any case.

Classic RAVE extension has not caused any problem for me in OS 9.

I had Berli try the same exact extension set that I had success with in my DP G4 + GeForce 2 MX in his iMac, but it didn't work.

The only other thing I can think of is the Apple Monitor and Monitor preferences files in the System 9 folder.

Gyrene

Link to comment
Share on other sites

There must be something else in the new iMacs that is causing this problem, maybe something to do with the new screen.
A definitive and a bit worrying possibility...

I think the idea of partitioning the drives wouldn't hurt, but OS X will still write new extensions to the OS 9 system folder if Classic is envoked in any case.

But only to the OS9 it uses, that's the point of partitioning. Have two OS9's, one for the X to screw up with and one "virgin". smile.gif

If someone didn't know, you can choose the 9 to be used from Classic control panel.

Link to comment
Share on other sites

One other thing to check... Are you folks running CM 'virgin', as it comes off the CD, or are you running with heavily modded graphics file? I've had text disappearance problems similar to those mentioned after putting some new mods in.

Otherwise, by having OS 9 on a separate boot drive, I've had no problems getting full 3D on my G4/933 (excepting the 'slowdown' problem I posted about earlier).

Link to comment
Share on other sites

I strongly doubt its anything to do with the screen, more likely something to do with the Nvidia interface to Apple OS. I have been watching the incorporation of Nvidia products into Macs (as well as the various problems MSW users have) and am so far unimpressed with the quality of drivers and hardware implementation. I think I will stick to ATi...

Link to comment
Share on other sites

Originally posted by Hoopenfaust 101:

Like the rest of the mac guys in this thread, I've been using macs since system 7

System 7! The first Mac OS I had was... Mac OS. Came on an all-in-one case and had those new 400k floppies (how in the Hell can I ever fill 400k?). Had a whopping 128k of ram (what do I need with that much ram?) and no hard drive (20mb hard drives were insanely expensive). First OS I really recall the version number of was OS 4 (after my Mac became a Mac Plus... Woot! 4mb ram! I'll never need more ram than that!). Ah, the memories smile.gif
Link to comment
Share on other sites

As a suggestion, in your pure 9.2.2 partition, make a location that includes only the extensions you want to have enabled for game play. I have found that that seems to work best for me. Doubly so since I also dabble with SkyFighters 1945, a WWII air sim game.

Ah, mes infants, you do not know the pleasure of the TRS-80 and its whopping big 4 KB of RAM. I quickly upgraded to an Apple II+.

Link to comment
Share on other sites

My first puter was a Sinclair ZX-81 with a membrane keyboard. Press "P" for "Print" ;)

I think it had 2 or 4k of RAM and wicked monochrome graphics. (50 x30 I think)

I wish I had it still, I still have my Apple IIc clone and my Amiga 500.

I'm on the hunt for a cheap Mac Color Classic II

Gyrene

Link to comment
Share on other sites

What version of OpenGL do you have installed on your 9.2 partition?

What version should we have? Is OGL 1.2.1 the newest or do we have newer versions installed since we have the newest mac on the board. I'm lookin' for any avenue to investigate. I'm gettin' my ass kicked because I don't know how many men I have in a squad or when my arty is gonna fall. Plus I can't see my enemies info. I'm losing and I'm gonna blame Nvidia

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...