Jump to content

OpenGL error 13 or 14

Recommended Posts

First of all, thanks BF for CMSF!

And even though I have only had a few hours with 1.11, it looks like this is the patch we have all been waiting for.

Not sure if this is related to 1.11 or not. I recently did a fresh install of vista32 bit and then installed CMSF, Marines, then 1.11 patch. No mods or anything like that. I randomly get CTD's, with a pop-up of mostly OpenGL error 13 with an occasional 14 instead. Also get "Display driver nvlddmkm stopped responding and has successfully recovered" in the event log. Never had any of these issues with 1.10 and XP on the same hardware. I am using a 9900GT with the 180.48 Forceware drivers.

Ran OpenGL Extension viewer and it shows I'm at OpenGL 2.1 (read elsewhere CMSF uses 2.0?) and all tests pass. It does show some feature of 3.x not enabled if thats relevant.

Is anyone else using 180.x drivers with Vista and a Geforce 9x Card without errors? Or can anyone suggest a stable version for the same? Elsewhere on the web they suggest rolling back drivers for this issue but drivers for the 9.x series are limited.

Thanks for the help and keep up the good work BF!

Link to comment
Share on other sites

  • 4 weeks later...

I uninstalled the drivers and used driver sweeper and installed 179.14 for Vista 64 bit and still I'm getting the white screen with the blue circle and either GL error or CloseCombat.exe has stopped working. I'm going to try the most updated drivers next. Again this wasn't happening until I updated to 1.11.

Link to comment
Share on other sites

After doing some research it looks like this is a Vista/XP/OpenGL issue that is affecting several pieces of software not just CM:SF. I even had the CTD occur while using Google earth. Unfortunately there is no known fix as of yet and it's making lots of software unusable.

Link to comment
Share on other sites

Looking over the City of Heroes thread they initially mention going back to driver 169.25 for the 6xxx, 7xxx and 8xxx series. For the 9xxx series it looks like 177.92 is one of the earlier Beta drivers that supports most of that series (available on Nvidia's site).

The other part of the thread mentions installing a beta of Vista's Service Pack 2 in order to make newer drivers more stable. It apparently boils down to a particular Hotfix (that's still beta) that involves heavy graphics applications and multi-core CPUs (though CMSF doesn't use more than one core). However it is noted that this fix doesn't seem to address the OpenGL 13/14 errors that people get. It might still be worth trying though:

Microsoft is controlling the access to the Vista Hotfix KB 953186 (BETA), so you'll need to click on the "View and request hotfix downloads" link in the upper left corner of the artilcle. Be sure to use Internet Explorer when loading this page in order to be presented with the correct versions of the files for your particular OS (i.e. 32-bit "x86" or 64-bit):

For Vista 64 bit users: (be sure to click show additional information!)

Windows Vista All (Global) x64 sp2 Fix245313 Vista 6000 3177788 10/22/2008 12:26:21 AM

For Vista 32 bit users: (be sure to click show additional information!)

Windows Vista All (Global) x86 sp2 Fix245313 Vista 6000 2529929 10/22/2008 12:25:04 AM

Microsoft will send you an email with the link you need to access the download and the password you need to be able to unpack the download to install it. You'll need to reboot after installing the Hotfix.

Something else to try is making a change in the Nvidia Control Panel. Go to Manage 3D Settings and within the Global Settings tab (assuming you're not using profiles for each of your games) go to Threaded Optimization and turn this OFF and see if that helps any.

One other thing to try is setting the "CPU Affinity". Do this by launching CMSF and then Alt-Tab'ing back to the desktop and press Ctrl-Alt-Del to bring up the Task Manager. In the Processes tab look for the "CM Shock Force.exe" and right-click on the file name and in the menu that pops up go to "Select Affinity...". Make sure that just one of the CPUs is selected and all others unchecked. This setting won't 'stick' when you close down CMSF and launch it later. It has to be set each time.

In the end it may just boil down to uninstalling your current drivers and rolling back to an older version. Unfortunately it may be hard to find a driver that resolves this issue with the 9xxx series.

Link to comment
Share on other sites

I applied the "hotfix" for Vista 64bit and then installed 176.44 drivers for my dell laptop Geforce 8600M GT. These drivers were the ones that originally came with the computer and are considered "stable". SO FAR I have had no OpenGL errors and the other applications that were giving me problems have seemed to become stable also.

Link to comment
Share on other sites

  • 3 weeks later...
  • 2 weeks later...


I just got this error, the OpenGL error 14. I went to bed last night having played CMSF until my eyes were sore and my vision blurry. (I lost several Marines due to my tiredness: sorry guys.) :) All was good.

My son played a bit of Sid Meier's Railroads! (patched to v1.1). No problems.

I woke up, started CMSF, opened my savegame - problem! I got a glimpse of the map before it crashed. It showed hard, long, striated shadows. They were oriented in the correct direction, just not "normal" in any way. Everything else looked okay. Then the crash with the OpenGL error 14 message.

I rebooted: same exact issue.

I installed the latest nvidia driver, 182.06 WHQL, vista64. Now there are no problems. Back to obsessing over my men and our mission!

(I had been using 181.22 WHQL previously.)

8800GTX, q6600 cpu, vista64. (Temps are always low: in game GPU averages 62-65. Yeah, 8800gtx on air with those temps. :) CPU cores average around 50. I don't think temps are a factor.)

Schrullenhaft's level of knowledge is light-years beyond mine. I'm only posting this as some additional information that may help someone else.



Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...