Jump to content

Possible pathfinding issue?

Recommended Posts


I'm currently playing a coop game with a friend by sending turns to each other in the planning phase and watching the replays and came across an interesting issue.


So the campaign we are doing is For King and Country (mission 2 if it's of any matter) and we stumbled across an issue with 2 units struggling with pathfinding. Since pictures say more than words:


The teams in question are the fireteam next to the HQ unit in the corner of the bocage (let them be known as first team for this post) and the section that has already had 3 men ran up to their waypoint (going by the glorious name of second team in this post).

So the two (then full sections) walked up to that corner of the bocage. At this point no teams have been split from either of the sections. They keep moving and from the first team, 2 fireteams walk up fine but one stays at the corner and same with the second team: one fireteam walks up perfectly fine but the other two are stuck. (We tried splitting the teams to see if that did anything, hence the lone fireteam).

If you give them a movement order on the other side of the bocage, they just don't do anything. The way we got it to work was to tell both units to move back from the bocage (the second team being split into individual fireteams at this point) to the road and go around to the openings and then go on the other side. Also another interesting thing is that if you tell the second team to move back 1 AS as a full section and then link up with the team up front they walk back to the road and as the two teams reach the waypoint they move onto the next one and then that counts as done as soon as the 3 man team up front reach that.

Other interesting note is that if you move the teams back 1 AS to the road and tell them to walk straight up to the team next to the shermans, they walk up to the bocage and stop.


Seems to be an issue with the pathfinding on that particular corner of the bocage.


Save file for anyone interested: https://www.dropbox.com/s/hbazpocug60474d/For%20King%20and%20Country%20COOP%202%20-%20007%20%C2%BD.bts?dl=0

Unfortunately we kind of woke up to this issue a tad late and only have the replay saves left from the previous turns.

Link to comment
Share on other sites

I'm having a similar problem in one of my current PBEMs too.

No bocage or hedges of any kind, open field, but when I split a section of engineers into two teams, then ordered one team forward, then only half the guys moved, the other half stayed.

Then I moved the destination waypoint, and one more guy started moving. I repeated this and eventually they all moved, but it took several turns.

Link to comment
Share on other sites

6 hours ago, UselessTalent said:

Ah, fair enough then! Good to hear it's a known issue and it'll be fixed in due time. First time I came across this and I'm guessing my vocabulary failed me (or the fact that it was 4 am for me) when I tried to search for similar threads.

Here´s one of those threads that had the related pathing issues mentioned. IIRC it wasn´t the first time reported, but likely the extended pixeltrooper spacing feature in V4 upgrade made it happen more oftenly since then.


Link to comment
Share on other sites

Ah right, thanks for that! Yeah, looks like very much the same issue. I suppose I've been lucky (or blind) as I haven't encountered this kind of behaviour before. Luckily we we're only playing a SP/"coop" and could savescum easily to find a decent workaround and not get too bothered about it. Could've been a different story with a H2H game 😅

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...