Jump to content

Map design - problems with bridges

Recommended Posts

A friend and I are currently about to embark on a really large battle using Pete Wenman's recently posted 2km by 2km map. I quite like the map but during testing I had trouble getting stuff to cross the bridges sensibility. I could not plot way points to just the other side of the bridge and then move left or right into the woods the way points would drop into the water. I cracked open Huzzar! and looked at the way the bridges were mapped and compared.

Based on what I saw I tweaked the bridges in Pete's map and things improved slightly. With the vanilla map I had to set way points 100m away from the bridge to prevent the odd double back into the water problem. With my tweaks now I can get the tanks to cross the bridge with way point much closer < 30m or so. But for the life of me I cannot get tanks to cross the bridge and then fan out left and right. What ends up happening is the way point I click in the woods doubles back and drops in the water.

I set a way point on my side of the bridge. Then one on the other side of the bridge - which ends up in the middle of the bridge. I can fiddle and get one near the other side of the bridge. Then I set a way point in the woods at the place where the green arrow is located. That way point ends up in the water (but I cannot even see it):


The tank ends up swimming:


Here is what the map looks like (tweaked from Pete's original):


I also though that the fords could be causing the confusion but the same problems happen at the other bridges too - where there are no fords next to the bridge. In the area about 60m around the bridge ends I cannot get my tanks to do sensible things - they keep being drawn back to the water.

I am looking for help - any advice on how to tweak the map to solve this problem?

Pete's original map can be found in the repository here: http://www.battlefront.com/index.php?option=com_remository&Itemid=314&func=fileinfo&id=1921

Link to comment
Share on other sites

That was my first concern too. I assure you that my way points were placed in locations that were not inaccessible. There is plenty of space around the bridge that is accessible to tanks and I cannot select those as way points. Or more accurately it looks like I can place a way point at the cursor but instead the way point jumps back into the water.

Link to comment
Share on other sites

I can't reproduce what you describe on Pete's map. The only thing that would happen sometimes is that a tank would make a circle right on the end of the bridge after crossing, but other than that they would go to the woods on either side. Sometimes the AI couldn't figure a route from the end of the bridge and would just stop there.

I see you have added a row on land tiles on either end of the bridge, and it looks like you have raised the land elevation as well.

I did the same thing with the land at the end of the bridge, but lowered the water to 18 in one tile and changed the land back to 19 leading up to the bridge. This got rid of the visual gap and smoothed out the bump in the ends of the bridge for the vehicles.:)

I'm sure by now you have exited the game and restarted to see if that changes anything. After changing some things and loading the file the game froze up one time, but restarting cured that.

Link to comment
Share on other sites

I don't know if this will help... I had trouble placing waypoints along the bank of a river. The problem was solved by rotating the view point until I could look almost straight down on the bank.

That worked perfectly! Thanks. I usually work at view 1, 2 or 3 and when I do that with these bridges I can repeat it. But go to view 7 and it works. I don't have to go that high for t to work. I am so pleased. Thanks - a new trick for the tool box.

Link to comment
Share on other sites

Something I think I noticed since the 1.1 patch: I see this when positioning infantry in buildings. While at view level 3 (approx, I scroll up and down with the mouse wheel as I see fit) I click on the building I want them to enter and they actually end up in the building closer to the camera even though that building is off camera. I have to delete the last way point and reposition the camera away from the other building and try again.

Could this be the same thing? I try to click on the woods near the end of the bridge and instead it thinks I am clicking on the ford under the camera. The suggestion offered by @Barrage works because now you are clicking to place way points more under the camera.

Link to comment
Share on other sites

Ian, way back when CMBN first came out a PBM friend and I complained to ADMIN about the plotting across bridges problem and got no real tips to solve the problem of plotting of units to cross bridges. We posted on the Forum and got tips from members that we found work. I know you are trying to make scenarios without this from happening but I think there is nothing you can do to prevent it from happening in this game system. We made a scenario and posted it and it has several bridges but if you follow these tips when playing with bridges and creeks and rivers you can get by this game glitch. When plotting units to cross bridges change your view to be across the bridge facing the front of your vehicle/unit and then draw the path towards you on the side of the bridge you want to be and you won't get those disappearing way-points that stop and disappear under the bridge or into the embankment etc. You can also change your view to the side of the bridge and then draw the way-point/movement plotting from this angle and you can make more accurate plots that you want onto or away from the bridge. When discovering this glitch bigtime in "Huzzar" I actually had a vehicle stop on the middle of one of the key bridges by his own decision and for about 8 turns I could not even get my mouse to highlight him until one turn I finally was able to click on him and plot him to get the Hell off the bridge! By then the enemy had already got to the other side of the bridge and was waiting for me when originally I should have gotten there first! It actually cost me the game because some tanks got killed behind him that eventually jammed up the bridge behind my glitch-stopped tank! Admin said in the first patch they addressed this issue....I didn't see any change.....

Link to comment
Share on other sites

That's odd because it was my good experience with bridges in Huzzar that lead me to believe that this was a map issue. I read about people having trouble with bridges and that those issues were fixed in the patch. So, when my friend and I played Huzzar with the 1.01 patch I did not expect any problems crossing bridges and indeed there were none. I was pleased that things worked so well.

Then when testing Pete's new map and did the same way point plotting I did in Huzzar (follow along the path the unit will be going on at level 2 or 3 plotting way points) failed so badly I assumed it was a map design issue. Sorry Pete!

The odd thing is other people have tested Pete's map and do not see my issues. I don't get it:(

@barrage thanks again for the tip. I have been using it for crossing bridges and dealing with narrow city streets. I am much happier now.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...