Jump to content

black bar...


Kohler
 Share

Recommended Posts

when i play cmak, i get a thin black bar at the bottom of the screen from the centre to the right hand side above the bar with hotkeys etc on it, when this bar moves over a selected unit the yellow outline of that unit stays on this black bar so i end up with a load of yellow lines on it , i have a ati radeon 9000. anyone else have this problem?, i know it sounds strange any help would be welcomed , thankyou

Link to comment
Share on other sites

I can't recall if I've seen this problem myself. Is the 'thin black bar' always there once you start the game or does it pop up at some point ? Which Catalyst driver are you using ? Which Windows version and DirectX version do you have installed ? Have you tried different resolutions (for CM) ?

Do you have the Rage 3D Tweaker installed and the Z-Mask disabled (by the tweaker) ? I don't think that contributes to this particular problem, but it does help with some slowness experienced with the Radeons.

Link to comment
Share on other sites

thanks for replying, the black bar appears when i start a battle as soon as it loads, i have 4.8 catalyst driver, windows xp and directx 9.0c.

i got the rage tweaker and put z-mask off this didnt solve the problem, i think the problem was from updating drivers. i had the same driver for ages, then a couple of months ago i thought it might be worth an update, all the new driver seems to have done is put extra strain on my resources, so i was wondering do you think its worth updating the drivers if u have no tech issues? what are the advantages of updating?

Link to comment
Share on other sites

Updating drivers varies in what problems are solved or possibly created. Sometimes an issue may be resolved or performanced enhanced. At the same time it is possible for a newer driver to break something that an earlier driver did well.

I tested out a Powercolor Radeon 9000 Pro 128Mb under Win98SE and WinXP SP1 (DirectX 9.0b). I did not duplicate the problem that you were seeing (just browsing around the setup phase 3D screen). I was running at 1024x768, 32-bit and Catalyst version 4.2. Anisotropic filtering was set to 2X (I believe) and AA (Smoothvision) was off since the driver claimed I had to be at 800x600 to run it (which is strange for a 128Mb card).

The only problems (other than a lack of fog) I saw were the 'selector boxes' in the 2D screen being a bright medium blue instead of white (?).

Interestingly SmartGART allowed me to enable 'fast-writes' under Win9x. But under WinXP it didn't really work. The Rage 3D Tweaker was installed in both OSes. I'm not sure if there is any setting I've made in there that could possibly account for the differences in what we've seen with CM. Most likely the problem lies within the latest Catalyst driver.

When you download the ATI drivers, there's typically a link for 'what's fixed in this release'. Clicking on that should give you a listing of specific problems addressed in this driver release along with acknowledged problems still existing (though that isn't necessarily an exhaustive list of what is completely wrong with the driver).

I'm not sure if it will be worth uninstalling and down-grading your Catalyst driver to an earlier version. You could remove the 4.8 Catalyst and install the 4.2 Catalyst, but you may run into the same problem. Make sure that you've installed any necessary AGP/chipset drivers for your motherboard (Intel, VIA, SiS, etc.).

Link to comment
Share on other sites

i have downgraded to the catalyst 4.2 driver , this didnt solve the problem but was worth doing just because it took some of the strain off my system resources. this makes me think that a mod might have caused the problem, do you think that is possible? and also how do u change resolutions? , thanks for your help so far

Link to comment
Share on other sites

Changing resolutions within CM requires that you delete the 'Preferences' file (in the same directory/folder as the executable). Once this file is deleted the next time you start CM it will come up with the resolution selection screens, starting with your current desktop resolution (though possibly at a higher vertical refresh rate than you're running now).

Did you fully uninstall the 4.8 Catalyst drivers (and preferably reboot afterwards) before installing the 4.2's ? I also suggest playing around with the Direct3D settings of Anisotropic filtering and Smoothvision. The Anisotropic filtering may have prevented the problem that you're seeing. Smoothvision (anti-aliasing) on the other hand can cause problems with text colors in CM and maybe responsible for the issue that you're seeing.

Link to comment
Share on other sites

i fully uninstalled the 4.8 driver before putting 4.2 back in. i played around with the settings you suggested still no luck, i dont really understand most of the stuff in that rage3d program its a bit out of my league. What setting do you think i should set the Anisotropic filtering at?, i also changed the resolutions but still the black bar stays. thanks again for your help

Link to comment
Share on other sites

I have a PowerColor Radeon 9000 Pro installed in an ASUS CUSL2-M motherboard based on an Intel 815E chipset. Running Windows XP SP1 w/ DirectX 9.0b and the Catalyst 4.2 drivers along with the Rage 3D Tweaker v. 3.9 (I believe) installed.

In ATI's 3D tab for the Display control panel I have 'Use custom settings' checked and with the 'Direct3D' radio button selected and pressing the 'Custom' button I have the following set:

Anisotropic 2X, Application Preference NOT checked.

Smoothvision 3X, Application Preference NOT checked. 'Quality' is selected with the radio button.

Texture Preference set to High Quality.

Mipmap Detail Level set to High Quality.

Wait for Vertical Sync set to Always On.

Truform set to Application Preference.

On the 'VPU Recover' tab I have VPU enabled.

On the Rage 3D Tweak tab I have the following settings checked (most of the slider-based settings are not operable within the tweaker, possibly due to the settings I have):

Under Direct3D:

Bump Mapping

Compressed Textures

Fast Z Clear

Table Fog

TCL Back Face Culling

TCL Hardware

Texture Micro Tiling

Tile Back Buffer

Tile Primary Buffer

Tile Textures

Vertex Blend Extension

Vertex BlendUseProjMat

Volume Textures

W Fog

Z Fog

and Z Mask is UNchecked (this is the one that effects the performance of CM).

for the Tweaker section:

DAL Restricted Modes BCD

No ATI tabs in Taskbar

for the Driver & Display section:

Accelerate Alpha Blending

Accelerate Block Writes

Accelerate StretchBlts

ATI D3D Tab

ATI OpenGL Tab

Shimmer Fix

for the Overclocker section:

My core is set to 274.50MHz (default) and the Memory is clocked at 249.75MHz (default). This particular (Pro version) card is NOT being overclocked.

Some caveats regarding the Rage 3D Tweaker settings. A majority of these settings are the defaults set by the tweaker (or enabled via ATI settings). A number of these settings don't really make a difference to the driver (an example - "Table Fog" does not allow CM to have fog nor do any of the other x Fog settings). Not all of these settings make a difference to CM and some of them may not actually be the optimal setting for performance or quality.

The ATI SmartGART tab in the Display control panel is set to:

AGP Speed: 4X

Fast Writes: OFF

I have attempted to enable Fast Writes with the SmartGART controls, but it never seems to work for XP and returns to 'OFF'. However it is enabled under Win98SE on this same box - I have no idea what the difference is. Perhaps I haven't installed the Intel chipset drivers or XP doesn't like this particular setting controlled via software - at least for the Intel 815 series (some BIOS/CMOS setups allow for this setting to be controlled, but that will vary on motherboard model, manufacturer and northbridge chipset type and revision).

You may need to reboot in order to have all of these settings take effect.

I checked these settings this morning and ran CMAK v. 1.01, but I still didn't see the issue that you're running into (though I also have never installed a Catalyst driver newer than 4.2 on this machine either).

Link to comment
Share on other sites

  • 2 weeks later...

Hi there!

2 weeks ago i got an old but good Radeon 8500.

After installing i had the same problem that you described. Here is my solution:

First of all, the latest catalyst is 4.9. That did nothing to the problem, but perhaps it helps with the next part(?).I too heard of the Rage3DTweak.Nothing changed, the black bar was still there. With this installed, you can click it and you will see a dropdown-menu. I chose Optimal-Quality, and it worked. Dont know if this will fix your problem, but it works here. The only strange thing i still have is what Schrullenhaft described. All briefings have a blue background now, and, another oddity, when i click on start game, the insert"scanning disc..." is blue instead of red.So it could have something to do with some settings for the card, although i am too lazy to find out.

Link to comment
Share on other sites

I had the same problem with briefings appearing blue & in the game text ( text in the unit information boxes ) also appeared in a very bright blue. This occured when I switched to the Nvidia 56.72 driver running on a BFG Geforce FX 5500 OC card. I found in very difficult to read the text so I uninstalled those drivers & installed the 61.77 drivers. This appeared to solve that problem.

Link to comment
Share on other sites

  • 5 weeks later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...