Jump to content

Black screen problem

Recommended Posts

Hi, new to the game. CMAK

I'm getting the black screen with intro with intor music playing when I start up the game. I've tried the fixes I've read about -- no anti-aliasing; cntl/tab . . . still nothing.

I'm running it on XP Home

1.5 Ghz Celeron

256 Ram

Video card is the standard lap-top Intel 82852 (which doesn't have anti-aliasing.

ANy suggestions????

Please help -- I need to knock out some tanks ;)

[ March 12, 2006, 01:29 PM: Message edited by: annarborhawk ]

Link to comment
Share on other sites

Still no luck when I tried the other screen settings. . . .

I should mention. The screen isn't totally black. There is a small grey square top center, and another one bottom center. The words "Main Menu" appear on the bottom in -- but nothing is clickable, and I hear the background music.

I tried the hitting "shift" thing two, but it didn't work.

Link to comment
Share on other sites

Which driver for the 82852 are you using ? The latest is 14.19.50 (dated 2/8/2006) and is actually driver version, which you can download for Windows XP from here:


I don't know if a newer driver will help in this situation or not however.

I know the Intel integrated video chipsets typically have a problem displaying fog in CM, but I wasn't aware of any other display problems. In the past the 810/815/845/865 & 900 series integrated video has worked basically well with CM.

As mentioned before, deleting the CM Prefs file forces CM to reselect a resolution the next time it is launched. For the BFC (internet purchase, non-boxed) edition the file is usually located (with the default install) at c:\Program Files\Battlefront\Combat Mission Afrika Korps with a filename of Combat Mission AK Prefs.

When CM offers resolutions (when launching it for the first time or after deleting the Prefs file) it starts at the same resolution as your desktop is set at. However for a vertical refresh rate it may offer something much higher than you're running. Essentially it is limited by the highest vertical refresh rate at your current resolution that is offered by the video driver (not essentially what the monitor is capable of). On laptops this probably isn't too much of a problem, unless it pulls a refresh rate meant for an external display. But even in this case I wouldn't exactly expect the results to be what you're currently seeing (if you were running a refresh rate that your LCD didn't support).

One other note, it is actually "Alt+Tab" to switch back to the desktop from CM (rather than "Ctrl+Tab" you wrote earlier). This method sometimes helped with anti-aliasing and video drivers that weren't all that great with CM's 2D screens.

So to be clear on what you're seeing... When CM launches for the very first time (or after deleting the Prefs file) you typically see a little green/white box with text in it listing the current resolution and possibly the vertical refresh rate. It is either within one of these boxes that you select the current resolution/refresh rate or skip to the next one (or wait for it to time out and automatically offer the next resolution/refresh rate combo). The resolutions and refresh rates are offered singly in a sequentially descending fashion. The resolution that you select here is what CM will be running at. If you just change your desktop resolution it shouldn't make hardly any difference to CM, unless your desktop ends up being set for a resolution that is lower than what CM has been set for. In that case you should be offered the resolution selection screens again. You will also always be offered the resolution selection screens every time you start CM if you never get the chance to write out the Prefs file, which occurs when you exit CM normally (on-screen Exit button or Alt-Q).

Once you've selected one of these resolutions you should be shown the CMAK splash screen (a bitmap painting of a moving Grant tank in the foreground) with the menu buttons arrayed in two columns underneath this. Do you see this or is this display corrupted like you wrote above ? If this screen is corrupted, try the "Alt+Tab" to switch out of CM and then re-maximize it. This should refresh the 2D screen to make it viewable. If it doesn't, then there's definitely an issue with your current video setup and CM that hopefully a driver update might be able to fix.

Link to comment
Share on other sites

Thanks. Yes, I downloaded and installed the latest driver, but still no luck.

It was Alt+Tab I tried with not lcuk either.

And yes, I'm getting the resolution preference box, but no matter which one I chose the next thing I get is the black-screen with the intro music playing. As I said, there are two very small gray boxes, and the bottom says something like "Main Menu" -- but nothing on the whole screen is clickable.

But thanks for the detailed response. I'l try again tonight for another go.

Link to comment
Share on other sites

I don't have an 82852-based laptop to try the drivers out on, but I have tested it with some related Intel graphics cores.

With an 865G I tried both the

( http://downloadfinder.intel.com/scripts-df-external/filter_results.aspx?strTypes=all&ProductID=1044&OSFullName=Windows*+XP+Professional〈=eng&strOSs=44&submit=Go%21 )

and the

( http://downloadfinder.intel.com/scripts-df-external/Detail_Desc.aspx?agr=N&ProductID=950&DwnldID=8391&strOSs=44&OSFullName=Windows*%20XP%20Professional〈=eng )

drivers, which both worked and both support the 82852GM & 82852GME chipsets. I also tried out the driver I linked to before ( with an Intel 915G graphic core and it worked with CMAK fine also. Both setups had 512Mb of RAM, though I don't know how much of a difference this may make compared to your 256Mb setup (possibly limiting the maximum amount of memory dedicated to video).

The one problem I ran into with the driver was of Alt-Tab'ing out of the game and back in. The screen remained black and didn't fully refresh. However all other screens displayed properly with no problems.

The 82852GM & GME graphic cores are based on the Intel "Extreme Graphics 2" core, which has cousins in the 865G and 855GM. However the latest driver provided by Intel for the 852/855GM chipsets doesn't support the 865G series.

There may be some unique differences between the 852GM and the 865G and 915G chipsets that I've tested that may account for the differences in compatibility that we've seen here. The only thing I can recommend from here is to uninstall all of your video drivers (from the Add/Remove Programs control panel), reboot and reinstall either the newest 852GM driver or one of the 865G drivers (which are older, but compatible with the 852GM) that I've linked to above. Also I assume that you have DirectX 9.0c installed (not that CM needs it, but it is probably recommended for any newer video drivers). And make sure that any anti-virus utilities are disabled while installing the video drivers.

Link to comment
Share on other sites

  • 3 weeks later...

I'm experiencing a similar problem with ATI Radeon 9000 Mobility. I've got the latest drivers (Omega), disabled the Z-thingy mentioned in 1.03 patch troubleshooting and tried to switch of anti-aliasing, but for some reason it doesn't have the option to do so. Only possible "mode" besides the 3 different speed options is called Application Controlled and I've got it on.

I even tried to run CM without the latest Omega drivers, and without ANY drivers at all, still no go. This is particulary strange because the game has worked well with this laptop before. I've tried to re-install the game and patches, and tried to start it with each version and with different drivers and settings, without any luck.

I'm suffering from serious lack of CMBB and I need to get this game up and running soon before I lose my marbles! x(


Link to comment
Share on other sites

What happened between when CMBB was working and when it wasn't ? Was it a video driver update ?

"Application Controlled" typically means off for CM's purposes when it comes to videocard features. CM doesn't directly control any of those features (unlike some newer games) and therefore it needs to be enabled via control panels for the videocard. In this case "Application Controlled" means that it will be off until the application turns on that feature, which CM won't do.

What exactly are you seeing on the screen now ? Is it completely black or what ? What version of the drivers (ATI Catalyst or modified Omega Catalyst) are you currently using ? CM does need video drivers to be installed since they are always necessary for 3D functionality. Without video drivers, Windows runs the video with some default driver that only supports 2D at certain resolutions. In some cases Windows itself can provide a matching driver for certain video hardware (though that is somewhat rare with laptop video chipsets). Those drivers will often support Direct3D (but not OpenGL most of the time).

Disabling the 'ZMask' with the Rage3D Tweaker isn't something you can do with the latest Catalysts and Omegas with their CCC control software. The developers of Rage3D Tweaker are concentrating on overclocking right now rather than registry controls of the drivers. I don't know if a "driver only" install of a Catalyst with an older registry-based Rage3D Tweaker tool will work or not. The standard 'large' install of the latest Catalysts pretty much forces you to use CCC and the registry settings for controlling those drivers don't seem easy to access (thus allowing control over the ZMask feature), since they're often added by Rage3D Tweak.

It's also possible that disabling the ZMask may not be necessary with the latest Catalysts (I'm not sure). What disabling the ZMask did was speed up turn crunching (stangely enough). With the ZMask on (which is the driver default since it is typically a speedup) and an unit selected in CM, if you click go to have the turn calculated, it would take significantly longer with ZMask enabled. So this setting shouldn't really be involved with a black screen to my knowledge.

Link to comment
Share on other sites

A lot has happened in between, that's why it is hard to pinpoint a certain change to this problem. I have updated the driver several times, can't remember which version I had the last time it worked. Omega Catalyst I currently have installed is version 3.8.231.

There was an option in one of the setting windows in ATI Tray Tools to disable ZMask but I'm not quite sure if it did anything, and according to what you're saying (if I understood it right) it certainly did nothing.

What I'm seeing is the same as above with annarborhawk, at loading stage a black screen with a small checkbox in the center. The checkbox actually appeares right after I click the quickstart icon on the desktop and disappeares again before the resolution switch. The intro music plays allright, but I only see the checkbox. After that, two checkboxes appear to upper-middle and lower-middle of the screen, the top one has partial text of the version number (parts of the letters are scrambled with some other letters) and the lower box has a title "Main Screen". Thats all. The upper checkbox is responding to mouseclicks, but the lower one does not. Clicking the upper box plays the same sound as selecting the main menu buttons. At this point only Alt-Q helps. After that, I hear the "boom" sound of quitting the program and it jumps back to desktop.

The resolution selection window does NOT appear at any stage, nor is there any preferences file in the main folder.

This is really frustrating, I'm sure you understand x(

Link to comment
Share on other sites

If there is no Prefs file with that particular install, then CM will go through the resolution selection process the very first thing and do it every time CM is launched until a Prefs file is written out (normally with a standard exit of the game, Alt-Q or 'Exit').

I haven't used the Omega Catalysts in quite awhile so I'm not familiar with all of the options that they may offer. It appears that the ATI Tray Tool (an Omega original control panel) has the ability to change the ZMask. If that's the case, then you can ignore what I said about the Rage3D Tweak and the latest Catalysts. However the info on the reason for the ZMask disable is still accurate and shouldn't have an effect on the issue that you're seeing to my knowledge.

I'm not sure what you're seeing when you say "checkbox". Is this some drop-down dialog box like some of the CM screens for selecting fog-of-war, etc. ? When you say "quickstart icon" is this just a normal shortcut to the game or are you using some other utility to launch CM ? What resolution did you used to run CMBB at and what is your current desktop resolution ?

Do you have access to the installer for the drivers provided by the laptop manufacturer ? You may want to completely uninstall the Omega drivers (and reboot) and reinstall those and see if this makes any sort of difference (of course the laptop OEM's drivers will be significantly older).

Link to comment
Share on other sites

About the prefs file; I'm 100% sure there is no prefs file, and 90% sure that it has not opened the resolution selection window after last install.

But to the other more important points; by checkbox, I mean a standard Windows checkbox, which you'd see at certain selection windows anywhere, an empty box means 0 and a checked box 1. This particular box does not react until the supposed main menu of the game is opened.

By Quickstart-icon I mean a standard shortcut, my apologies but I use Finnish Windows and didn't remember the correct term in English x)

My desktop resolution was/is currently 1400x1050, and with CM, I think it's 1152x864. Can't be sure because the selection window problem. Does the bit value of colors have any influence on CM?

I've tried to come up with the original drivers many times before, when I ran into trouble with other games and applications, but haven't been able to find them anywhere. There were no ATI drivers in the installation CDs which came with the laptop. I've found some old Catalyst packages from my "archives" and I'm planning to try them out as soon as I get my 6hrs of sleep after 14h of work. You know you have to put up with certain amount of RL to sustain the virtual world, eh? ;)

But thanks a lot for your help so far, you've given me some directions already but if you have any more ideas, I'd appriciate the help!

Link to comment
Share on other sites

The problem with the Catalyst drivers that ATI distributes on their website is that they do not have support for the Radeon Mobility chipsets. Which is what forces you to use the drivers provided by the laptop manufacturer. Omega Catalysts on the other hand have their INF files modified to support the Mobile chipsets (which is all it really takes to my knowledge). So the chance is more than likely that your old Catalyst driver may not work (assuming it's something directly from ATI's website and not the laptop manufacturer).

I've used the 6.3 Catalysts with a Radeon 9600XT and CM works fine with that. So generically the Catalysts should work. However there can be differences in how well the driver works with each Radeon chip. So a 9600 series Radeon may show no problems, but a 9000 series may exhibit particular issues. The Mobility versions of the Radeon chips shouldn't be too radically different from their desktop cousins. Usually it's a difference of running at a different clock speed with different memory and possibly some additional power-saving core logic in the chip.

Anyway... the "windows checkbox" sounds awfully strange since there doesn't seem to be anything like that in the CM menus. What you may want to do is either extract the CMBB executable from the 1.03 patch and see if that makes any difference or possibly do a reinstall of CMBB (in another directory if necessary). Typically a corrupted executable would probably crash with an error, but it may be worth trying out.

The Prefs file is definitely needed as far as I'm aware. Without it CM doesn't know what resolution to run at and therefore should go through the resolution selection processs automatically. It should also do this automatically if the desktop resolution is lower than the previous run CM resolution (i.e. - if your desktop was running 1024x768 and you had CM set for 1152x864).

You may also want to double-check the shortcut to make sure it isn't trying to run CM with some weird compatibility settings. Right click on it and go to Properties at the bottom of the popup menu. Click on the Compatibility tab and in there make sure that nothing is checked. The settings in here could potentially make CM run strange or not at all.

As for color depth, you need to be running at 16-bit (High) color depth or higher (24-bit, 32-bit). CM itself runs at 16-bit color, but a higher color depth on the desktop doesn't change that, so there shouldn't be any advantage/disadvantage to running at a higher color depth.

I assume that you've already got it installed, but in case not, make sure that you have DirectX 9.0c installed (this link is to the largest 46Mb full installer). CM itself doesn't need the latest DirectX, but the latest video drivers would probably want it.

Link to comment
Share on other sites

Thank you VERY much, your information has been most helpful, though I haven't been able to make it work yet, but as I said before, now I know what to look for and try out.

I'll post my results and conclusion if I manage to get it to work. Even though this might be a very rare or even unique problem, someone might run into similar trouble later on.

Hakkaa päälle! ;)

Link to comment
Share on other sites

Ok, I managed to get the manufacturer drivers for regular 9000 series and the game seems to work allright, except for the strange checkbox I still see at startup. But that is something I can live with smile.gif I'll play now for a long while and then start to find out which newer drivers work with it.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...