Jump to content

Stuck trying to run Demo on PowerBook G3


Recommended Posts

When I start the demo, I get to the splash screen with the various national flags that says "loading graphics", there's some hard drive activity, then I hear some birds chirping and bombs in the distance, but the splash screen never goes away. The only way out is to force quit.

My machine: 1999 Apple PowerBook G3 (bronze keyboard), 400 Mhz, 192 MB of RAM, virtual memory off, built-in Rage Pro with 8 MB VRAM. I'm running MacOS 8.6.

Thanks in advance for any help!

Link to comment
Share on other sites

Well, I can't help except to say that you are not alone: I have exactly the same problem.

When running the demo on my PB G3 (a Lombard, I think), I reach the point where the demo claims to be loading 3-D gradphics, then I hear the ambient sounds (birds, distant artillery), but nothing else happens as everything has crashed at that point. Only a forced reboot brings me out of it.

My PowerBook G3 has a 333 Mhz processor with built in FPU and 64 Mb of physical RAM, 65 Mb of virtual RAM, 8Mb of video memory, and 512k of backside L2 cache.

Is this simply inadequte?

Link to comment
Share on other sites

You should be fine on a Bronze, as I play using a Wallstreet. (300 MHz, 192 MB)

I managed to cause CM to hang up like that when I foolishly tried to update the video drivers. I installed the latest set off the Apple website (ATI drivers 1.4.8) and it broke. When I switched back to all the original video stuff (1.4.6) and it worked fine. I think I once tried 1.4.8 again and it worked, so I'm not sure exactly what it was, but the drivers can be suspect.

Also, as I just discovered last night, Norton Disklight will cause you to crash out of CM. Check for extensions that install things down in the driver layer like that--Disklight is low enough so that even after BTS takes over the full screen it shows through.

A guy at work has a Bronze that I think is pretty clean, so I think I might try installing on that some time next week to see if it works (and I want to see if the graphics are better--I'm stuck with 640x480).

[This message has been edited by chrisl (edited 06-24-2000).]

Link to comment
Share on other sites

I tried the G3/G4 Cache Profiler, disabled backside cache -- same result as before (gets stuck at the "loading graphics" screen). Also tried a reduced extensions set, and each of the monitor resolutions 640x480, 800x600 and 1024x768. No luck. Help! The posts I'm reading say this is a great game, but so far I'm stuck at zero!

Link to comment
Share on other sites

I trimmed my extensions down to the point where my poor little Hal 9000 sings "Daisy Daisy" in a deep, deep voice. That's it, I'm giving up on this game. I have no problems running any number of other games. Until these guys can make their demo robust enough to run on any reasonable machine, I'm wasting my time.

Link to comment
Share on other sites

Guest Big Time Software

Dschilli,

Have you downloaded the very latest drivers (i.e. extensions) from ATI? www.atitech.ca

The ATI Rage Pro is very problematic when using old drivers. The old ones are buggy and don't like CM.

Charles

Link to comment
Share on other sites

Being at work just now (on a cruddy old PC which *will* run the demo, but with mind-boggling sloth) I'll look into the ATI driver situation when I'm back home with my PowerBook. And I'll boot with minimal extensions. However, given Dschilli's experience, I hold out little hope.

I'm not sure which versions of the drivers I have, but from searching Apple's site it seems I can only download 1.4.7 of the ATI Driver Update (if I have something different). However, their ATI Video Software Update (for the built-in Rage 128 GL) is dated to only 3 months before I purchased my PB, so it may well be that I don't have that, and that it will help.

We shall see ... Shame if it doesn't work. It looks like a cool game.

Link to comment
Share on other sites

See my post on this forum: lock up question bauhaus

I believe this is an extension conflict since I can run CM on a Powerbook G3 233MHz. I know I set the extensions to a game mode I created in Conflict Catcher in which I disabled a bunch of extensions then added them back in until it ran.

Link to comment
Share on other sites

Okay, I finally got the demo to go! It does appear to be related to the video drivers. I think the following actions were the key:

1) In Extension Mgr, disabled "ATI Video Software Update 1.0", which includes:

- ATI 3D Accelerator, v. 4.6.2

- ATI Graphics Accelerator, v. 3.9.7

- ATI Resource Manager, v. 1.2.4

2) Removed "ATI Driver Update 1.4.8" from the extensions folder. Replaced it with "ATI Driver Update 1.4.7", downloaded from Apple.

I tried (2) without (1), and (1) without (2), but neither worked. Only both together. Also in the working setup:

3) Assigned 51 MB of RAM to CM

4) Disabled backside cache

5) Virtual memory on: 192 MB physical RAM, 58 MB virtual RAM

6) Most extensions disabled, but among others I reenabled the following and CM still works:

- Quicktime 4.0.1 and 4.1.2 packages

- Microsoft OLE 2.2 package

- Microsoft Internet 5 package

- Microsoft Visual C++ 4.0b package

- Kensington Mouseworks package

- FireWire Install 2.3.3 package, and

- FireWire VST OHCI Enabler

(The last two being for my VST FireWire external drive and Newer Technologies CardBus FireWire card)

I haven't yet isolated which of items 3-6 are absolutely necessary. Setting the resolution wasn't necessary -- I started CM up with the resolution at 1024x768, and it reset it to 640x480 by itself.

The upshot seems to be that CM doesn't work with the most recent ATI driver update for PowerBook G3's, but does with the previous version.

Many thanks to all of you for your suggestions and help!

Link to comment
Share on other sites

<Q>Virtual memory on: 192 MB physical RAM, 58 MB virtual RAM</Q>

Re: VM being smaller than real Ram

I'm blanking on the technical term for it, but there is only one advantage to having VM smaller than real RAM and that is the appl takes less real RAM to run. As I recall this is due to the difference it 68K and PPC architecture. The actual amount of VM need in this case is quite small, so you can save your disk space by reducing it.

With the amount of RAM you have, you may be willing to take the small RAM hit for a moderate speed boost and free disk space by turning of VM.

Link to comment
Share on other sites

Well, if CM doesn't work with Apple's ATI Video SW Update 1.0, then that wasn't my original problem, since I'm only just now downloading it. However there was no ATI Drive Update of any version in my Extensions, and I'm downloading 1.4.7 now to see if that helps. Also, I've increased the RAM preferred by the demo to 51 Mb, as suggested, and will run with minimal extensions (though I've not got a lot of add-ons to start with).

Fingers crossed ...

Link to comment
Share on other sites

Like the previous posts, cm now crashes on stratup, except it ran fine the fist time! Nothing was changed as far as extensions go. Crashes now alternate between Type 2 and Type 12.

Is not a Powerbook specific problem as I am running a B&W G3, 350, 128

ATI extension set is as follows:

ATI 3D Accelerator v4.9.8

ATI Driver Update v1.5.3

ATI Graphics Accelerator v4.9.9

ATI MPP Manager v1.2f1

ATI Rage 128 3D Accelerator v5.8.5

ATI Resource Manager v2.5.1

ATI Video Accelerator v4.5.2

Setting the memory higher, or changing screen res has no effect.

Why should I need to disable part of my hardware - the backside cache - just to get a demo to run?

Doesn't say much for the full version.

Will not buy nor recommend to clients unless fixed.

Poorfish

Link to comment
Share on other sites

<BLOCKQUOTE>quote:</font><HR>Originally posted by poorfish:

Why should I need to disable part of my hardware - the backside cache - just to get a demo to run?

Poorfish<HR></BLOCKQUOTE>

Good quesitons. I wish I had a good answer. I posted this after running several hours of conflict catcher. That is what it came up with and appeared to work. If you read my posting re: this subject, you will see that I also don't trust it. It doesn't make sense, but it worked for me. (Note: this is on a non-native G3 system w/ an upgrade.)

The turning off a bunch of extensions, including some of the ATI extensions, is likely a better bet. My suspicion is that it is an ATI extension.

I have also noticed that my system will freeze and the MacTool's disk indicator with show disk activity. (It is reported that the Norton disklight has a problem.) It looks like the system has crashed, but then it will wake up once the disk activity has terminated. Likely some backgrond task. Here's wishing for pre-emptive multitasking.

I think it would be helpful to start posting the system configurations that work and don't work. I am going on vacation soon so I cannot collate them. Any volenteers?

Link to comment
Share on other sites

I've noticed that people sometimes forget to post what version of the Mac OS they have installed when describing their system. This is obviously a very important item to help trouble-shooting.

When trouble-shooting, less is better. You only waste time by changing ten things, and re-starting. If it works, you'll have no idea what made it work. If it doesn't work, you have no idea if the old problem is still there, or if your ten changes just created a brand new problem.

One of the first things you should always try is starting up with the Shift key held down. This disables all extensions. Extension conflicts and problems is the number one source of troubles.

Don't forget your handy OS install CD! You can boot from it, to be guaranteed a known-to-work environment.

If possible, use the Apple System Profiler to create a report of your system. This report is very handy for the people trying to trouble-shoot.

To hopefully give others some encouragement, I have been successfully enjoying the Gold Demo since the day I downloaded it. I run it on both a G3 333 "bronze" Powerbook and a B&W G3 400. I run OS 9.04 on both machines. I have never touched the Demo memory settings, have not disabled my cache, and am running the latest ATI video drivers available from Apple.

------------------

--

Toad

Ontario, Canada

Link to comment
Share on other sites

<BLOCKQUOTE>quote:</font><HR>Originally posted by poorfish:

Like the previous posts, cm now crashes on stratup, except it ran fine the fist time! Nothing was changed as far as extensions go. Crashes now alternate between Type 2 and Type 12.

<HR></BLOCKQUOTE>

I had the final running just fine, then I fixed some hard drive problems with Norton and now CM is a little weird, but works. I'm running a PB G3/300, OS 8.5. I had problems with the ATI driver update that put 1.4.8 on my machine, but 1.4.6 is ok. The weird thing is that sometimes CM crashes out when loading the 3D graphics, but then if I run it again immediately it works just fine. I don't quite understand it, but it's something weird with my machine. Both demos were fine, and 1.01 final never crashed until I fixed my HD (and yes I reinstalled).

Typing all that suggests that I ought to reinstall my video drivers...

Link to comment
Share on other sites

OK, I got the demo working. Virtual memory and backside cache are ON, but I've turned OFF the Extensions labelled "ATI 3D Accelerator", "ATI Graphics Accelerator", and "ATI Resource Manager". Instead, I downloaded and installed the Extension labelled "ATI Driver Update" (from Apple, version 1.4.7).

And everything seems to be happy. Cool game, judging by the demo smile.gif I expect I'll buy it in a month or so, once I've moved, started my new job, and earned some money. But buy it I shall. It's lots of fun, despite my not being very good at it (which is the best sign in a game, I reckon. Plenty of play in it!).

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...