Jump to content

Fog or lack there of


Recommended Posts

My problem is that there is no fog or night graphics in cmbo. I have followed the troubleshooting guide, but no help because in DirectX 7 and my video card options there is no "fog emulation table". I have tried changing screen res, hardware accerlation, and refresh rate. I have the latest driver for my video card and DX7, what else can I do?

Computer Specs:

IBM Aptiva

AMD K6 3D processor 450

SiS 530 video card 8mb

96 mb Ram

Link to comment
Share on other sites

Unfortunately... nothing. The one exception to this may be that you need to allocate more main memory to the video. I believe you can do this in the CMOS > Advanced Chipset Setup. If you set it to the maximum amount of memory (probably 8Mb), then there is a chance you may get the fog/transparency effect. But the SiS 530 chipset (which is built into your motherboard) may not support the type of transparencies that CM is using. The absence of the "fog emulation table" setting in your control panel isn't an absolute indication that fog effects aren't supported, but they may not be.

If you have the latest drivers and DirectX 7.0a and still don't get transparencies (fog effects) then the hardware won't support it (or the drivers haven't been written to support it).

If you really want the transparencies and fog, then you will have to get a dedicated video card. You will need to check your motherboard manual to see what bus types (i.e. - PCI or AGP) are available for a video card. Becareful in reading your manual however since it may describe your current built in video as AGP, when it is an AGP SLOT that you need.

There have been several recommendations on this board for video cards and it really depends on what kind of CPU you have and how much money you are willing to spend. The NVidia TNT2 based video cards are pretty solid and relatively problem free (they are however AGP cards). If you only have a PCI bus then either a Voodoo3 2000 16Mb or a TNT PCI 16Mb would be a good bet. Ask around on the board and you will get some opinions.

Link to comment
Share on other sites

CMOS or BIOS Settings. Usually when you boot up (usually when the computer is counting its memory on power up), you can press a key to get into your BIOS setup (CMOS). Usually it's the Delete key, F1/F2, F10 (for Compaqs). IBMs may use Esc or Del, I'm not sure. You may have to press the Esc key to see what key you have to press to get into setup. Among the settings there may be a listing to set the amount of memory used by the video (I'm not sure which menu it is under).

I didn't read too closely on your specs when you first posted. You mentioned that you had an 8Mb SiS 530, apparently you may already have the memory allocation for the video max'd out. Unfortunately SiS doesn't have any info on exactly what they do and don't support under DirectX (nor do hardly any of the other video chip mfg's).

DirectX 7.0a is not that different from 7.0. Most of the differences amount to game controller input (joysticks, etc.) and some other minor fixes. It might be a good idea to upgrade to it just in case it does fix your problem, but more than likely it won't.

DirectX 7.0 > 7.0a patch:

http://www.microsoft.com/downloads/release.asp?ReleaseID=17322

This is the latest SiS 530 driver for DirectX 7.0 (version 1.08). It may be the same as IBM's posted driver or it may be newer(check under Control panel > System control panel > Device Manager tab > double click Display Adapter and then double click the SiS 530 video listing under this > Driver tab > Driver File Details button > the first file highlighted will have a "File Version" info on it look to see if the last set of numbers is less than 1.08 - it may be something like 4.12.0107). One caveat about SiS's drivers though is to keep the original driver handy. They often forget to include a necessary file or set of files:

http://www.sis.com.tw/support/download/530.htm

Download all 8 files into one directory and extract them (just execute them). There should be a setup program that gets extracted - just run this.

After all of this... you may just end up buying a 16Mb PCI card. The 3dfx Voodoo3 2000/3000 should do fine (with the latest beta drivers - the "out of box" ones probably don't support transparencies very well in CM).

[This message has been edited by Schrullenhaft (edited 06-30-2000).]

Link to comment
Share on other sites

Schrullenhaft, thanks for all the help my driver number is 4.12.01.1080. So that means that it is the latest driver right? Oh well I found a good deal on a Voodoo 3 3000, I will buy it very soon. And I will get the latest drivers from 3dfx correct? Again thanks, this new card should hopefuly help the fog and night graphics, as well as overall graphic quality,I hope. Its nice to find someone with a good computer background, something hard to find a some retail stores.

Link to comment
Share on other sites

Hey just one more thing, when it comes to voodoo drivers are you sure the beta drivers are the way to go? It seem to me from the website that the WHQL certified driver are highly recomended. 1.05.00 WHQL released jan 30 2000 to be exact. "The driver numbers on the website are confusing" Because that date and driver number don't seem right,they seem to change on different pages. Anyway bottom line is beta vs. WHQL is beta stable and worth the risk?

Link to comment
Share on other sites

I have a Compaq Persario AMD k62 with 128 ram. The system is using a Rage LT Pro AGP 2x and has the same problem. Smoke and transparent buildings work. Fog = white screen. File details are MACW4.DRV file version 4.10.2456. I also do not have the fog emulation button, (or just do not know where to look), but do have the latest version of Directx. Do this mean fog is hopeless. In other simulations, fog does not appear to be a problem.

I have seen a picture of fog in a post and it looks great!!! ANY CHANCE AT ALL FOR FOG?

Link to comment
Share on other sites

I have the exact same problem no night graphics or fog, but smoke, snow, rain, transparent buildings all work.

My system is:

Gateway Pent II MMX 400 MHz, 128MB Ram

My video card is:

STB (Velocity 4400) NVIDIA 16MB

Op Sys: win 98

Link to comment
Share on other sites

<BLOCKQUOTE>quote:</font><HR>Originally posted by bat:

I have a Compaq Persario AMD k62 with 128 ram. The system is using a Rage LT Pro AGP 2x and has the same problem. Smoke and transparent buildings work. Fog = white screen. File details are MACW4.DRV file version 4.10.2456. I also do not have the fog emulation button, (or just do not know where to look), but do have the latest version of Directx. Do this mean fog is hopeless. In other simulations, fog does not appear to be a problem.

I have seen a picture of fog in a post and it looks great!!! ANY CHANCE AT ALL FOR FOG?<HR></BLOCKQUOTE>

====

Unfortunately Bat, I don't think there is a remedy for you with the Rage cards. I have two different ATI chipsets, Rage Pro Turbo and 128 Xpert. No amount of driver manipulation (old or new) allowed me to see fog on either of my machines with the rage cards. I gave up and tried a voodoo3, and it worked fine.

Link to comment
Share on other sites

<BLOCKQUOTE>quote:</font><HR>Originally posted by SuperWidgeon:

Hey just one more thing, when it comes to voodoo drivers are you sure the beta drivers are the way to go? It seem to me from the website that the WHQL certified driver are highly recomended. 1.05.00 WHQL released jan 30 2000 to be exact. "The driver numbers on the website are confusing" Because that date and driver number don't seem right,they seem to change on different pages. Anyway bottom line is beta vs. WHQL is beta stable and worth the risk?<HR></BLOCKQUOTE>

====

SuperW,

I have tried the both the beta drivers for Voodoo3 PCI and the most current WHQL (or official) drivers. I saw no difference in qraphic, smoke, or explosions, but did notice a marked slowdown in simply using the interface when using the beta drivers over the offical drivers. Just my experience, your mileage may vary.

Link to comment
Share on other sites

<BLOCKQUOTE>quote:</font><HR>Originally posted by Kazom:

I have the exact same problem no night graphics or fog, but smoke, snow, rain, transparent buildings all work.

My system is:

Gateway Pent II MMX 400 MHz, 128MB Ram

My video card is:

STB (Velocity 4400) NVIDIA 16MB

Op Sys: win 98<HR></BLOCKQUOTE>

Kazom,

Try the NVidia reference drivers instead of the STB ones. I have an STB 4400 and cured random lock-ups that way. Although I *think* I always had fog and night graphics, switching from the STB drivers to the generic reference ones has fixed the fog/night problem to yours for at least one other CM'er here (kgsan).

Link to comment
Share on other sites

  • 4 months later...

Although I don't see the gray screen others have described, I don't see any fog either even when set to weather/fog=full.

My system is a Compaq PIII 566 Mhz, 64 MB RAM, 10 GB hard disk, Intel 82810e-DC133 Graphics Controller, Intel ® 810e chipset Graphics Driver (DC133 FSB133) 4.11.01.1321.

Any suggestions?

Caralampio

Link to comment
Share on other sites

Caralampio - I'm not sure if this driver addresses any issues with fog on the i810 chipset, but it is the latest driver from Intel (which I'm not sure if it is newer than what you currently have):

Intel i810 Win9x driver:

http://support.intel.com/support/graphics/intel810/software.htm

There is a possibility that the i810 doesn't support fog-tables or fog-table emulation. If that's the case then you may want to consider a video card upgrade (though I'm guessing you may be limited to a PCI card since there may be no AGP slot on your motherboard). The fog's limitations on LOS, etc. within the game are still there, it's just that you will not see the visual representation of the fog.

[This message has been edited by Schrullenhaft (edited 11-27-2000).]

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...