Jump to content

Stuck at 800x600 now, option "Display size: desktop" doesn't work

Recommended Posts


I had my desktop at 1920x1200 and CM:SF started at that resolution with no problems. GeForce 7800GTX on Windows 2000, drivers 93.xx.

However, when I tried to fix a graphic artifact that I have seen (some "zebraing", I can post a screenshot if you like) I updated the drivers to 162.18.

Rebooting and after setting it back to 1920x1200, CM:SF will now come up only at 800x600. Selecting the "use desktop" choice doesn't work. I have since then reinstalled the drivers after desinstalling them, I have reverted the drivers back to the original version that worked, I have removed the prefs file on every try and even reinstalled CM:SF after deinstalling it. No go. I am stuckk at 800x600.

[ July 29, 2007, 12:15 PM: Message edited by: Redwolf ]

Link to comment
Share on other sites

And the "zebraing" I tried to fix by upgrading the drivers are still there, no change.

I'm completely stuck at not being able to get to the desktop resolution now.

For debugging: I noticed that when double-clicking the CMSF icon inside a 1920x1200 dekstop now there is actually a 640x480 version of the desktop coming up, visible for a second, before CMSF starts (at that resolution).


So what seems to have happened is that the driver update changed, without asking, my single-display-although-two-monitors-connected setup into a "clone display" setup and the second monitor doesn't do 1920x1200. It does, however, do 1280x1024, so that doesn't explain why it does down to 640x480.

Then, manually going back to a single 1920x1200 desktop, deleting pref and starting CMSF still comes up 640x480.

As a side note, the stupid nvidia driver update now causes the desktop preferences application to crash when you adjust quality settings (which I have to remind you is the only way to get AA/AF in CM:SF). Considering it didn't fix the issue with zebraing that's not in my liking.

[ July 28, 2007, 10:37 AM: Message edited by: Redwolf ]

Link to comment
Share on other sites

Let me just say that I am so terribly glad I've stuck with my version NVidia 94.24 drivers.

I'm playing at 1280x1024 with 2xAA/AF or 4xAA/AF (depends on the size of the map) at max texture quality with a 7950GT.

I haven't really had any zebraing problems either. The shadows can look a little odd, with some hatch marks at the upper edge, but that's it.

If you want to try the 94.24 version, I still have it and can put it up for you. I haven't any clue whether it would be better, worse or even work for whatever card(s) you have.

Link to comment
Share on other sites

Well, I'm out of a game now.

I couldn't resolve the above issue no matter what I tried. CM:SF would stay at 640x480, although all other games I started were happily using whatever resolution I had configured originally. The new drivers work for them normally (except for mentioned inability to edit the quality settings in the NVidia panel).

I then decided the problem is that I need to clean my system of NVidia drivers first before I can re-install the drivers. What happened is that the uninstall of the NVidia drivers did remove all NVidia drivers - which included my network drivers (NForce GbE). Of course the harddrive has no local copy of the NForce drivers, so it's kinda hard to bootstrap now, eh? I'm so fed up with Tamagotshi OS.

Link to comment
Share on other sites

This will be the last update from me as I'm unable to make the game work.

I have now completely nuked and reinstalled all NVidia drivers, and the graphics drivers that I installed are the ones that originally worked.

I have then switched to the single-display 1920x1200 setup. CM:SF comes up 800x600 (not 640x480 as I originally said). I deleted the prefs file. No change. I have then nuked and reinstalled CM:SF while that single-display 1920x1200 was active. I had verified that everything was completely gone in between. No change.

I started a whole bunch of other games, none of them shows even a sign of change, all use whatever resolution they were configured for before the whole mess, all of them higher than 800x600. CM:SF is the only game that insists on running at 800x600.

Unless there are some other ideas here I can't play this game. A starter for ideas would be to explain what the capabilities of the "display size.txt" file are, maybe I can use this to unhook the mess?

I can post a video showing how the resolution changes from 1920x1200 the moment you double-click the CM:SF icon if that helps.

Link to comment
Share on other sites

Redwold, i did actually include a whole section about res changing in the ReadMe file. Did you review that at all (it does appear when you install the game).

As to 32 bit color, my assumption was that everyone runs in 32 bit color anyway these days but I will amend the section below to make mention of that.


By default, the first time the game is launched, the games internal resolution is set whatever your desktop's resolution is. We have added a two ways to adjust your game resolution. From inside the game, go to the Main Menu, then select the Options panel. From there you can select the game to run at the following resolutions:

Desktop = (the game will run at whatever resolution your desktop is set to)




If you want to run the game in a resolution not listed, you can manually set this by editing the "display size.txt" file located in your game directory. Simply change the two numbers that you see in there with the width and height you wish to run the game.

ex: For 1680x1050 you would delete the two numbers in that file and replace with "1680 1050" (without quotes).

If you put in "0 0", the game will revert to using your desktop resolution.


Currently, if you change your resolution, the game will set the refresh rate to 60hz. While on LCD monitors that's the preferred rate but on older CRT monitors this low of a refresh rate may result in some screen flickering. In the near future, we will release a patch that will include the ability to set the games refresh rate manually.

Link to comment
Share on other sites

I was the one that originally had the resolution issue. I was still having it until I saw this thread.

I can confirm that in order for the in game resolution to work, you MUST have your desktop set to 32 bit color. After I did that, I was able to set resolution without an issue. Of course, you need to restart the game after you change the resolution.

AA, and AF you need to set from your desktop as well if you want those.

...hope this helps

Link to comment
Share on other sites

I have verified three times (three reinstalls) that 16 bit color is the default that NVidia drivers, both new ones and 93.xx have after installing or even after updating drivers.

I'm afraid you need to handle that a little more gracefully.

Madmatt, as I mentioned I did edit the "display size.txt" file as you mentioned, but it does not work that way. If you have 16 bit color it won't go to 1920x1200 even if you put it into that file.

Insofar there is nothing in the readme that helps with this problem.

Link to comment
Share on other sites

I highly recommend that Charles start asking the display for sizes of either color depth. If the user is running 1920x1200 at 16 bit and the game is only using 32 bit, there still no reason not to try 1920x1200.

Or you can make the "desktop size.txt" mechanism work in the case that there's a 16 bit display.

Failing that, you need at least an error message. I don't think an entry in the readme will do. Remember that 16 bits is the default for NVidia drivers.

Link to comment
Share on other sites

Originally posted by serval:

Running CMSF 1680x1050 32bit working alright

But when changing desktop to 16bit CMSF goes down to 1024x768.

Odd. Glad its solved anyway smile.gif

This was the case for me as well. I had my desktop on 16 bit, and didn't notice. Changing it to 32 bit allowed me to correct the resolution, and greatly improved performance and graphics.
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...