Jump to content

CMBB, CMAK vs Windows 7 and nVidia


Recommended Posts

I began my wargaming hobby well over a decade ago with CMBO. I dug out my original disks to enjoy these great games again but I can't get them to run on my newer system. Ideas & help appreciated.

First, my rig - Dell XPS L521x, Windows 7 Pro, Core i7@220Ghz, GeForce GT640M, 16g of ram. I have the latest nVidia drivers (334.89). My system also has an Intel HD Graphics 4000 on-board card and the system manages the 2 GPUs with Optimus. I'm running DirectX 11.

Second, what happens. I've installed the original games, for example, CMAK and patched up to 1.03. When executed, I get flashing black screens as the program attempts to find a resolution. After a minute or so of it trying resultions, I get the "failed to initialize Direct3D" error.

My native resolution is 1920x1080. I've set the resolution to match what should work for CMAK with the same result.

I've checked "run as administrator" .. same result

I've attempted to choose a GPU for the program, both Intel and nVidia with the same results.

I've created a profile for CMAK in the nVidia control panel with the same results.

I've tried XP compatibility mode but no joy.

I've run DxDiag and have confirmed that all DirectX Features are enabled in both 32-bit and 64-bit modes.

I've also downloaded the latest CMBB and CMAK demos (supposedly running the 1.04 Vista patch) and get the exact same behavior and error.

Any ideas?


Link to comment
Share on other sites

It looks like you have tried the necessary steps ('Run as admin, Nvidia program profile, XP compatibility mode, etc.). You can see nothing intelligible in the "flashing black screens", is that correct ? If you can see something legible, you may want to hit the 'Enter' key to select it and see if that helps (though the menu screen and the game will appear in a similar display state as your resolution selection screen appeared in). The "failed to initialize Direct3D" error is normal if no resolution is selected during the resolution selection process (since it can't 'loop' back).

Typically the largest resolution that the CMx1 games support is 1600 x 1200, though it does actually support a much higher resolution than that from what I've heard (2304 x ?). For most users the 1600 x 1200 will be the max. None of the, now common, widescreen resolutions are supported. So everything you will be offered is typically of the '4:3' aspect ratio type resolutions, which I assume will work on your laptop.

Link to comment
Share on other sites

Thanks for the comments.

You're right that there's nothing on the flashing blank screens ... I tried hitting enter and clicking the mouse button hoping to select a resolution but it didn't work.

I wonder, if someone sent me a pref file with a resolution, it might skip the resolution selection process that seems to be tripping me up. Is a pref file keyed to a specific copy of CMx1 or could someone send me one to place in the folder tricking the game to go to the menu?

Just trying to think outside of the box.

Anyone else successfully running CMx1 on a modern nvidia card? What drivers are you using?

Link to comment
Share on other sites

Tchoup PM sent with a dropbox link for you. Hope this will get you going.

I have run both CMBB and CMAK on my Cyberpower Workstation, AMD 8150 FX eight core, GeForce GTX 650 Ti, 16 GB DDR3 RAM, Win 7 64bit OS.

I have to set my monitor to run in 4:3 aspect ratio to prevent stretching of the graphics. Running in 4:3 will give you two black bands on both sides of your monitor. If you don't mind stretching of the graphics (it's not that bad) then stick to the resolution you pick without adjusting your monitor.

Another issue that takes away from some of the immersion value of the CMx1 series is that fog effects will not work, I think it has something to do with Win 7 or something I can't remember.

Link to comment
Share on other sites

Thanks Blazing for sharing the prefs file.

But I cracked the issue.

I use a Targus docking station for my laptop to connect to multiple displays via a usb connection. This set-up uses something called DisplayLink drivers and core software. I stumbled across some complaints about displaylink preventing older games from displaying full-screen. I deleted the displaylink driver and viola!

I'm now running CMAK at 1400x1050, 60hz.

The DisplayLink issue is known but google turns up nothing of it in combination with CMx1. Check out search results

Link to comment
Share on other sites

In regards to Mods and user made scenarios... I assume you are aware of these sites:

For the older CMx1 series and the new CMx2 series, Mods: http://cmmods.greenasjade.net/

Scenarios for CMBO, CMBB and CMAK (& CMETO): http://the-scenario-depot.com/index.html



Then of course to get another "free" game out of CMAK, there is this mod that modifies CMAK to CMETO:


As well, at the greenasjade mod site that I provided above (first link), as long as you have signed up at the site already, these two links (below) from that web site will direct you to downloads made by RobO that provide a campaign layer for CMAK and CMBB. It is called ROQC or Robert Olsen's Quick Campaign generator. It uses Excel to automate mostly everything (no paperwork) to carry on a campaign with a core force of your choosing.

CMAK version: http://cmmods.greenasjade.net/mods?author_id=20&game_type=2

CMBB version: http://cmmods.greenasjade.net/mods?author_id=20&game_type=3


Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...