Jump to content

TOW:3 .exe does not launch game, demo worked fine


Recommended Posts

I tried the demo of Theater of War 3 yesterday, liked the game, and then bought and downloaded the full version. It installs fine, and then when I click on the .exe on the desktop, the hard drive kicks in and the mouse cursor "waits," but then goes back to normal and the game does not launch. I can see that "Korea.exe" is working in the background, but there is no game going, and no "korea.bin" which I believe is supposed to launch after "korea.exe" is launched.

I applied the latest hotfix patch, tried to run the game as administrator, disabled firewall from McAfee for it (I really don't want to uninstall McAfee if I don't need to, especially as I see that another forum user had the same problem, and uninstalling McAfee didn't seem to help) and I don't have any other security/ anti spyware programs installed. I have uninstalled/ re installed everything several times, using Ccleaner to clean the registry between re installing.

I tried also running it on just one core (setting the affinity to just cpu 0)

I'm using a Toshiba Qosmio x505 gaming laptop with Intel Core i7 Q740 @1.7 GHz

4 gigs ram, Nvidia GeForce GTS 360M 2 gigs ram

direct x 11

OS is windows 7 home premium 64 bit

Link to comment
Share on other sites

The primary difference between the demo and the full version would be the copy-protection software. The demo has a subset of this (it enforces the 1 hour of play). I'm not sure why the full version would have a problem when the demo didn't.

The copy-protection system used for TOW3 and the latest games from Battlefront typically should have fewer issues with security software (including Windows' DEP). TOW3 originally needed the Hotfix to address an issue with the constant requests to activate the license key (and using up an activation each time). The "Run as administrator" addresses that issue and the Hotfix supposedly should make 'run as admin' unnecessary, but that isn't always the case unfortunately.

With the demo running, it would seem that the DirectX 9.0c files are up-to-date (the installer typically installs the necessary updates).

Have you gotten as far as activating the license on the full version or have you never gotten even that far ?

From what I can find out it does NOT appear that your laptop (X505-Q890) uses the 'Optimus' technology where it utilizes an Intel integrated video and the Nvidia GPU. That technology can sometimes have issues where a game launches with the Intel integrated video instead of the Nvidia GPU.

The 'Korea.exe' file should launch the 'AutoUpdater', but the 'Korea.bin' file will not be loaded until you click the 'Play' button in the AutoUpdater. When you get to TOW3's main menu both 'Korea.exe' and 'Korea.bin' should be loaded up in memory.

You may want to try loading up with as little as possible being loaded up by Windows and see if TOW3 will run that way. Go to the Start/Windows Menu > 'Search programs and files' box at the bottom > type in (without quotes) 'msconfig' > press the 'Enter' key or double-click on the found file name. This will launch the System Configuration utility. go to the 'Startup' tab and click on the 'Disable all' button. Click 'Apply', 'OK' and then reboot the computer. This will prevent a bunch of services from running at boot, including part of your security software (though it may still interfere). You may want to disable McAfee as much as possible BEFORE making changes to the Startup tab.

Link to comment
Share on other sites

I was never able to get to the window which lets me enter the reg key. After installing the game and clicking on the .exe on my desktop, the whole screen blinks black for about half a second, the mouse cursor idles, and then my hard drive kicks up and then quiets down but nothing happens. Also none of the .exe's inside the game folder work either such as the editor.

I play dozens of modern games on this and have never had problems launching one before.

I disabled all the startup processes and programs like you mentioned, and even when no background processes are going on, it still does not work. Even uninstalling McAffee did not solve this, it is exactly the same whether or not McAffee is installed.

Link to comment
Share on other sites

  • 2 weeks later...

I just tested TOW 3 on a Windows 7 64-bit installation and it worked fine. The only issue was licensing, where the game would continue to request a license and give an error when you submitted the license key for online activation (typically should be addressed with the 'hotfix').

This machine has a Core 2 Duo, Intel P35 chipset, an Nvidia GeForce GTX 275, 4GB of RAM. Windows 7 was updated to Service Pack 1 and has the latest Windows updates applied. It runs the free version of Avira 2012, which had its 'real-time protection' disabled for the installation (since it identifies a few too many files with its heuristics). With the anti-virus still disabled, the game ran and licensed (when run with "Run as administrator"). The installation was to the '\Program Files (x86)' directory.

With the licensing dialog box not coming up that seems really problematic. The game doesn't need to load the 'korea.bin' file for the license activation process (it doesn't get loaded until AFTER the 'autoupdate' is run and the 'Play' button is pressed). The full version should initially come up with a dialog box that looks just like the demo version's box before the autoupdate. Clicking the play button should bring up the license activation dialog box that will allow you to select 'manual' or 'online' activation methods.

Try uninstalling the TOW 3 Demo completely and see if that helps in any manner. I was able to perform the above installation with the Demo installed, but maybe that may not work in your particular case. Interestingly (though it doesn't have a direct impact on TOW 3), this computer requires that DEP be 'enabled' and exceptions set for eLicense games.

Link to comment
Share on other sites

  • Create New...