Jump to content

CMAK Booting Game Problem


Recommended Posts

Hi Guys!

Had been playing CMAK for several weeks after having the screen rez problem and plain old crashing to desktop after trying to load game. Then, all of a sudden, the game would crash again and I hadn't done anything to the computer, no new games, nuthin. So I offloaded and reloaded the game and still same result. I took Matt's advice and copied the install file from the HD to the game file and reinstalled. Nuthin. Offloaded game, reloaded it, checked the NVIDIA site and downloaded driver for my GForce4. Even downloaded the Refresh Utility (but don't know what to do with it and am reading up on it now). At least now I get to the Screen Resolution Error message (eventhough my resolution is much higher than the game requires). Nuthin. I have Windows XP,seem to have room for the game. At my absolute wits end. No CMBB or CMAK now for two weeks. I'm cryin. Please help! Thanks in Advance!

[ January 26, 2004, 05:35 PM: Message edited by: Kiltie Lad ]

Link to comment
Share on other sites

What's the "Screen Resolution Error Message" ? Is this a DirectX error ? I assume that this pops up when 640x480 isn't selected and CM/DirectX has run out of resolutions to offer for selection. How long does it take for this error to come up and do you see anything else before this error comes up ?

This seems to suggest that CM can't detect your videocard's Direct3D capability. Which GeForce 4 do you have and what driver version did you install ? Did you uninstall the previous version first ? Do you have any video 'tweaking' programs loaded up (PowerStrip, Rivatuner, etc.) ? Which Windows version are you running and what version of DirectX is installed ?

If you go to the Start menu > Run > type in dxdiag > Display tab > what is the state of the three 'DirectX Features' ('Disabled' will be a button if they're enabled) ? Can you pass the Direct3D Test ?

Link to comment
Share on other sites

Windows XP

Dell Inspiron 8200

DirectX9, no problems found with Diagnostic

Error message: hear music, Screen Rez minimum is 680x800 (something like that); I'm set at 1400x1050. It takes a minute or so for it to come up. Must pass DirectX test, as I don't see that message. I'm tryig to load CM on my PC and I do get that message (eventhough I have the Gforce8- brand new video card)

GForce4 MX is on this Dell.

I'm not sure where to drop the driver I downloaded from the Nvidia site. It should have found it on it's own, yes? I have a folder for Nvidia on the HD and that's where the Diagnostic and Nasty File Remover program went. I did not Uninstall anything from Nvidia, but not sure the new driver is present. I have a computer guru neighbor who will be able to look over the computer and act on any advice you give. Thanks for doing this. I know remote advice ain't easy!

Link to comment
Share on other sites

I assume that your Dell Inspiron 8200 has a GeForce 4 440 Go, which is equivalent to the GeForce 4 MX 440. However the 'reference' NVidia drivers that you download from their website does not include support for the Go series. They claim (as does every manufacturer of laptop graphics) that you need to contact your system vendor for driver updates. Unforunately Dell the latest driver offering from Dell for the GeForce 4 440 Go is the 42.58 driver, which will undoubtedly have performance problems with CM (and many other games).

The bottom of this thread points to a website for updating the Go series drivers. The

http://www.geocities.com/madtoast/

website offers a "How to Install" page under the 'Articles' section on the left hand side which should work with your Dell. Upgrading to the 52.16 or later drivers could/should improve your video performance.

Before upgrading you'll want to run the uninstaller and go back to a generic SVGA driver ('VGASave' under XP) before installing anything new. With a modified INF file from this site in addition to the the video drivers suggested for download (or you can get them from Guru 3D) you should get a system that works just a little better.

Now for your exact problem. Apparently you're able to select a resolution then, which you say is 800x600. The DirectX error I was referring to was when you went below this resolution (640x480) and 'run out' of them. Your original desktop resolution should only be a reference point to start from for CM.

I assume that you've been able to get by the resolution selection screens and that you have seen the resolution listed in a box in the middle of the screen, correct ? Now the problem is that you can't see any of the 2D screens I assume, such as the 'Battlefront.com' logo (as seen at the top of the forum) or the main splash screen, etc., just a black screen, but you can hear the music, is that correct ? If you do an Alt-Tab and then re-maximize the game, does this refresh the screen or does it remain black ? Can you see your mouse ? If so click anywhere on the screen (particularly the lower half where some buttons may be) and see if the screen refreshes.

With the GeForce family the 'black screen' can be related to antialiasing being turned on. Turning it off can definitely help with this problem. Also you may want to make sure that you have XP fully updated with patches. One patch in the past (WM_TIMER security update) caused some 'black screen' problems (removing the patch worked for some people). Microsoft has since updated this patch for Win 2K and XP, which may have addressed this particular problem.

Link to comment
Share on other sites

Well. When I bought the Dell I asked them for the Gforce card and it was mailed installed that way. The card is, in fact, a Geforce 4 440 GO. It handled all the CM games with no problem. I haven't changed anything about the computer, but as I said all of a sudden the game started crashing. I will have to get my buddy over here to do the things you suggested because I don't feel confident in my computer capabilities to do it myself.

To answer some of your questions:

When I boot the game from the desktop icon all of the icons get HUGE. My resolution is so tight now that the icons are tiny and take up only about 1/3 of the screen. Games like "Call of Duty" run great. The Battlefront logo doesn't come up now, but it did before and was HUGE. Then the game crashed to desktop. Now I get the message about the minimum screen resolution without even getting the Battlefront logo, then game crashes.

I guess I just don't understand how the graphics card can support a game like "Call of Duty," which I did add after CMAK and may be causing the problem, and not support CM. CM must be having the difficulty recognizing the card, not the computer recognizing the card. Is there anything I can do with the Nvidia Refresh Utility that Matt suggested? The utility shows 1280x1024 @60Hz, although my Control Panel shows 1400x1050. Each sees the card as the Geforce 4 440 GO.

I'll see if I can get help to do the things you suggest, but if you have any other thoughts, please let me know. Thanks very much for your help. I've always been impressed by the CM staff and the community. Feel very comfortable here for the last, what, 4 years? Thanks again!

Shawn

Link to comment
Share on other sites

I believe Call of Duty utilizes the OpenGL graphics API rather than DirectX, which is what CM uses.

I'm guessing that you've actually set CM to run at 640x480 rather than the required 800x600. Unfortunately the DirectX resolution selection routines can't be written to exclude the 640x480 selection, so it is still offered. Running at 640x480 will give you a resolution error in CM. I suggest deleting the CMAK Prefs file and selecting your resolution again.

When I boot the game from the desktop icon all of the icons get HUGE.

This is normal from what I can tell. Your laptop's LCD display has a native resolution that works best for it. Everything appears sharp and crisp at this resolution. When you go to a lower resolution everything will get larger and somewhat blurrier or somewhat 'chewed up' looking. This is called 'scaling'. Some laptops avoid this by actually shrinking the display size (so that you're running in a smaller box on the display) to maintain the native resolution. However few laptops do this now.

What you're seeing here is that the desktop is changing resolution before the game is fully launched, which is probably fine.

My resolution is so tight now that the icons are tiny and take up only about 1/3 of the screen.

I'm not sure what you mean here. I assume by tight to mean sharp and possibly small. I can only guess that you're running at your LCD's native resolution. 1400x1050 or 1600x1200 is the maximum resolution of your display (Dell's documentation on this isn't quite clear) and I'm not sure what the 'native resolution' is since Dell doesn't specify it.

Did your problem only start after installing Call of Duty or was that game installed awhile back and you didn't have problems with CMAK immediately after installing it ? I can't exactly imagine why the installation of one game would affect the other, but it is a minor possibility.

Ideally, when you select resolutions in CM it should, upon launching CM, black out the screen and have a simple text box with the currently attempted resolution in the middle of it (and possibly other text listing the refresh rate and/or the videocard being used). This process will start at your current desktop resolution or something close to it. CM will read the Direct3D capable resolutions that your video driver lists as being available. I'm not sure if your 1400x1050 is among those resolutions. Anyway, CM may attempt a higher vertical refresh rate than what you're currently running on your desktop (at the same resolution). On your laptop however, I'm not sure it will do this since your laptop may be limited to 60Hz refresh rate. CM will attempt lower refresh rates until it reaches 60Hz at that resolution. It will then try the next lower resolution (defined by the video driver) at the highest refresh rate available (again, according to the driver). In your case, different refresh rates may not be available, so CM will attempt the next lower resolution if the currently displayed one isn't selected (or visible) - either automatically within 5-10 seconds or if you press the 'skip' button on the screen.

I don't think that you'll need the NVidia Refresh Utility since your display may be limited to 60Hz anyway. The intent of that utility is to enable beyond 60Hz refresh rates in games. A bug of sorts was introduced in Win2K/XP that games to limit themselves to 60Hz with the video drivers installed for those OSes. The Refresh Utility allows you to force a higher refresh rate.

I suggest that you delete the CMAK Prefs in the directory that has the CMAK executable. Next set your resolution to something more standard, such as 1280x1024 or 1024x768, just in case there is something about the driver's support for 3D at the particular resolution you're currently running your desktop at. With this done, launch CMAK again and hopefully you'll see the resolution selection screens. Select 800x600 as a minimum or something higher. CM will keep this resolution each time you launch it despite your desktop resolution setting (though it may change your desktop resolution temporarily at launch - but possibly requiring a reboot to get it back to what it was before). You can set your desktop resolution back to what you want and keep it there. If you select a resolution lower that what you've set CMAK for, then the resolution selection process will probably kick in again under the assumption that your display may be incapable of running the resolution CMAK has been set for. This will only happen if you leave your desktop set for a lower resolution and then launch CMAK while still set at this lower resolution.

Link to comment
Share on other sites

Thank you for taking so much time with me.

Changed rez to 1280 and then 1024 and still crash to Desktop. The screen looks more like normal now and the desktop icons are not pinhead size anymore.

To answer the CM/COD question. I had all of the CM games running fine, loaded COD, games still ran fine. At some point I did encounter difficulties with CM and had to play from safe mode. I even reloaded the game after copying the install from the CD as Matt suggested. All ran fine for weeks. Then the game simply started crashing. I did have to install COD several times as it was having poblems too, but for several weeks both ran fine til CM started dying. I'm wondering if my problem is indicative of something larger with this Dell.

For some reason I started getting a "Shell_Notify Icon" failure message at boot up. A gazillion of these little boxes would pop up on desktop if I deleted the first one. Our IT guy at work suggested reloading Windows XP, which I did. Still the failure message and then I had to select between two Microsoft Editions (although I used the same windows disc I got with the Dell). If I wasn't fast enough to choose the nondefault Edition, the computer wouldn't boot. My buddy changed this so that doesn't happen. I told him I thought I was running two versions of Windows at the same time, for my HD or RAM is so full, I can only have COD as the only game on the HD along with limited other programs. At one time I had all three CMs, COD, Medieval Art of War, and Red BAron all on the HD at the same time. When I installed CMAK this time I had to dump everything except COD. I don't think there is a way to insure that I don't have two operating systems and I've dumped everything I can to create disc space. I don't have art programs and extensive collection of pictures or music. But something is eating this computer alive.

So, perhaps despite all of your good advice and even this latest solution which I thought would be the ticket, this computer may have to be totally scoured and reloaded. What a pain.

Thanks again. Hope to get my buddy over soon to really spend some time. I bought Tweakie, his favorite file killer, so I'm ready to let him loose with that. Thanks, still trying, still reading the forum, and still hoping I can get back with all my CM buddies. We miss each other.

Link to comment
Share on other sites

Microsoft has this info about the Shell_Notifyicon Fail error, though it may not be applicable to you since it is specific to the UMAX Vistascanner software program. This thread also mentions the same problem (though also for a scanner and Win2K).

It's a bit funny, all this error is indicating is that a message has been sent to the system to add, modify, or delete an icon from the taskbar status area, a relatively simple little operation, and it's failing - producing your horde of windows. If the above MS Knowledgebase article seems inapplicable to you, then go in and remove any programs from your StartUp folder. The next thing to try would be to uninstall any programs that launch something automatically (anti-virus, a whole variety of utlities, etc.). If that doesn't work then you'll probably need to do a clean install (which means format the hard drive during the install process and not just reinstalling over the current copy).

[ January 29, 2004, 02:24 PM: Message edited by: Schrullenhaft ]

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...