Jump to content

Infamous Runtime error #3 (trap)


Recommended Posts

I'm making this post almost 3 years after the last post here. I have been trying on and off for almost 2 months now to get this game and its demo working. I just recently bought and downloaded the full game from steam because i thought it might fix the, or make it easier to fix the run time error thing. It usually takes me awhile to try and get a game to work if it is not working on my PC but, it has never taken this long or have I ever had to do so much. This is getting ridiculous! :mad:

I have read through this thread multiple times and have looked at others on steam and elsewhere. I have only found 2 good answers to fix this, the one here, made by Petsi, and one on Steam and they are practically the same besides the fact the guy on steam expanded atioglxx.dl_ through a DOS box and i have tried to do that too but i can't figure out how to.

I have tried to do what was said on here and i have done it through catalyst 8.7 for 32 bit but i stopped it because I seemed to have forgot I had a 64 bit Laptop (I found a list of graphic cards on laptops that will not run this game and apparently mine should be able to run it(I have an Asus K53e)). So i have tried to also do it through catalyst 8.9 and 10.4 and expanded and threw the atioglxx.dll into the ToW directory and still it refuses to work. I have gone into the ToWsetup and made sure the game was in my proper resolution and that the graphics where as far down as they could go but that hasn't changed anything. I'm also running everything as administrator and have tried to run the game under different compatibility modes (cause that fixed Red Alert 2 I'd think it could maybe help ToW) and even tried to run the game demo in a virtual box to see if it was just some weird setting on my PC wasn't letting ToW run and still no luck.

I have no idea what else to do except slam my head against my desk. Maybe I went wrong somewhere, But i can't recall everything i have done cause i have been fighting with this for so long.

Is it possible we could get step by step instructions to teach us how to fix this issue? When I read how to fix it I Googled every step and how to do it to make sure I knew what I was doing and I had to figure out how to expand atioglxx.dl_ to atioglxx.dll.

The major thing that I didn't quite understand was putting atioglxx.dll into ToW.exe. Most of the time it refused to go into ToW.exe so i tried to do it through the .exe making/editing thing that comes with my computer and i got the file in there but it still wouldn't work.

I just bought this game and I try to be fairly conservative with my money so this game refusing to work has made me royally pissed off is the nicest way I can put it. I really wonder why after about 5 years the developers of this game haven't released something to fix this issue. I am not necessarily mad at them as I have watched a lot of play through of all the ToW games, but I'm trying to hold myself back so I don't spoil it for myself, and i have looked through the website for it and looked at reviews for it and even though the reviews are not the greatest this game still looks really good and I even played the demo of ToW3 and thought it was really cool and fun.

It just make me mad that I feel so close to playing this game but yet so far. I just want to go and play with the tanks and try to recreate battles from real life and fiction I like and play through the campaigns and I think its ridiculous that i have tried this much and haven't made a bit of progress. I really would appreciate some help on being able to understand and fix this issue better.

Please excuse any bad grammar and what not as I'm very mad right now and trying to reread over and think about what i have said and this issue is too much right now. I need some time to calm down and get away from this before i can try to work on it again.

Any help is appreciated.

Tl:Dr I have tried to make Tow work in every way i know how and it still gives me the same runtime error#3 (trap) stuff. I just want to see a more in depth, step-by-step, way to fix this, please. :(

Link to post
Share on other sites


judging by the info on Asus website, this particular laptop has only integrated graphics (Intel HD 3000). ToW wasn't designed to run on Intel graphics and this chip even didn't exist when the game was released.

On a desktop you could get a low end or cheap middle end video card (nVidia or Ati) and play the game, but its impossible on a laptop.

It's interesting that ToW3 demo worked for you on the same integrated chip, it shouldn't :) ToW2 and later ones had their rendered routines rewritten from OpenGL to Direct3D to enhance compatibility, that's why it works, but it is not guaranteed on integrated graphics.

So I think the ToW1 doesn't run on Intel HD 3000 integrated chip because of the lack of OpenGL support. If there are some unofficial OpenGL drivers for Intel HD 3000 (I have no idea if they exist) you could try them.

Link to post
Share on other sites

I still think it's weird it won't run. That info is pretty helpful. I did manage to get the old Combat missions, ToW2 Kursk, (it kept crashing so I had to go mess with a setting I couldn't change in-game to make it stop :/ ) and I think I know what I have to do to get Combat Mission Italy working...

Just seems weird to me that this game wont work but I can get others from this developer to work. I think the OpenGL thing is dumb and I'm still surprised there isn't like a patch to fix this or a compatibility mode kind of thing. One of the reasons I love this Laptop is even though it isn't very powerful it has been able to run everything I want and I can play some old Intel only games on it but now I have found something that wont support the Intel stuff.

I am really enjoying this developers games (Especially Combat Mission Beyond overlord right now, I may have to buy the Combat Mission for Android). I think I may spend some more time looking at how to get ToW working even though it sounds kind of hopeless, but I think I might be borrowing my step-brothers old PC to play this.

Link to post
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...