Jump to content

Sound playing at half-speed after upgrade to Ubuntu Edgy 6.10

Toby Haynes

Recommended Posts

Everything was fine ... until I upgraded to the latest Ubuntu release. The sound is now playing back at half-speed - it's an octave lower than it should be. That makes the whole game feel .v.e.r.y. .s.l.o.w...

Now Dropteam was the first thing I tested that had sound after the upgrade. It also appears to be the only app I have that has this issue although I have plenty more to check before calling it the only victim. Doom-3, QuodLibet (music player using GStreamer), the desktop sound effects all appear to be fine.

Looking at the output in the DropTeam.log file, I see the following:

</font><blockquote>code:</font><hr /><pre style="font-size:x-small; font-family: monospace;"> SOUNDMANAGER: Using default capture device

SOUNDMANAGER: pCaptureDevice = 0x85744d8

SOUNDMANAGER: Error after opening capture device


SOUNDMANAGER: Playing DropTeam.ogg as ../data/sound/DropTeam.ogg

SOUND MANAGER: Allocated 54 voices</pre>

Link to comment
Share on other sites

Some hacking around switching libraries around and ... whoa! A fix!

For those of you who also run Ubuntu AMD64, I give you the following recipe. I have a 32bit chroot environment installed as well as the 64bit, so I always options when faced with 32bit binaries.

I moved the libopenal.so* libraries out of DropTeam/lib into a safe place. I then copied the 32bit version of libopenal.so into DropTeam/lib and created symbolic links in that directory to it to satisfy the requirements of the SpaceVikings binary:

</font><blockquote>code:</font><hr /><pre style="font-size:x-small; font-family: monospace;">cd wherever/you/installed/DropTeam

cp /chroot/usr/lib/libopenal.so lib/

cd lib/

ln -s libopenal.so libopenal.so.0

ln -s libopenal.so libopenal.so.1</pre>

Link to comment
Share on other sites

  • Create New...