Jump to content

CM still crashing!


Recommended Posts

Ever since installing my copy of CM way back in August 2000 I have been plagued by a consistent fault somewhere in either the game or my PC that results in CM locking up at some point during the playback portion of the game.

I have made efforts to trace the fault, although have as of yet been unsuccessful, I have recently reformatted the hard drive in a vain effort to solve the fault, and installed only the essential software - yet still the game crashes. I am now running the latest version of CM 1.12, but the fault has persisted from version 1.03 (or which ever version comes on the CD). Further in attempts to locate the fault I have removed all non-essential hardware, updated drivers religiously and followed much of the advise posted on this forum (although since starting Uni I have not been constantly checking for potential solutions).

There does not appear to be any set pattern to this problem, although as I said it always seems to occur during the playback portion of a game turn. Sometimes I can play the game all the way through a scenario without a single problem, but more often than not the game will cause the machine to lock up and die. This can occur within the first go, the last go, or any go in between – it seems to be totally random.

The nature of the lock up is such that it renders the machine completely unusable, only the reset button will restore it. On screen the mouse pointer has frozen, as has the ingame action. The sound effects also freeze, repeating constantly until I reset the machine.

It does not seem to matter which scenario I am attempting to play, be it a preset historical mission provided with the game or one generated randomly by the computer. Of all the games I have played in CM I have lost probably up to 75% to crashes, the Germans don’t even get a look in!

Saving games after each turn also fails to alleviate the problem as the saved file seems to become corrupt i.e. on the options menu on the title screen it is displayed in white, not the usual orangey colour, there is also no further information other than the filename, for instance the two identities of the sides involved in the battle (other than it stating that US forces are against US forces!?). Upon trying to open the saved game the game proceeds to do nothing. I have attempted to avoid this by saving the game after each turn twice, in different files in the hope that only one of the files will be lost, this does not happen and indeed both files become corrupted. The auto-save file is also behaves in the same manner.

It is a shame that such a fantastic game should be beset with such problems; any advice that anyone could offer to help would be much appreciated!

- I am using Windows 2000 Professional (Build 2195) with SP-1 installed with Microsoft DirectX 8.0

- My machine is one I have built myself, containing the following components:

CORE COMPONENTS

AMD Athlon 800MHz (Slot 1) CPU

Gigabyte 71XE (BIOS 29/02/2000)

256Mb RAM, (2x 128Mb 100MHz DIMMs)

STORAGE

Adaptec 2940U2/U2W PCI SCSI Controller

Main Hard Drive (C smile.gif: IBM DGHS09V SCSI device

Secondary Hard Drive: IBM DTLA-307030 IDE device

Iomega Zip-100 External SCSI device

Pioneer DVD-ROM DVD-105 IDE device

Plextor CD-ROM PX-40TS SCSI device

Yamaha CRW8824S SCSI device

GRAPHICS CARD:

Creative CT6971 (AGP – 128Mb Aperture Size)

Processor: GeForce DDR

Memory 32Mb

BIOS: Version 2.10.4.02.04

Driver: Creative Labs 5.0.2105-01.379

OpenGL: Version 1.1.5

Display Mode: 1152 x 864 x 16-bit High Colour (85Hz)

SOUND CARD

Creative Sound Blaster Live (Driver: Creative 5.12.1.3101)

ADDITIONAL HARDWARE

Microsoft IntelliMouse Optical (USB) (Driver: Microsoft 3.20.0.484)

Hauppauge WinTV PCI multimedia card (Driver: Hauppauge 3.6.18160.0)

Link to comment
Share on other sites

Guest wwb_99

Well, I don't know win2k too well, but have you tried:

1) DX 8.0a

2) Creative's Video Drivers suck. Go for NVidias, but I am not sure what the best version is for win2k. Try the version on the website first, then look elsewhere.

3) Does it exhibit odd behavior in any other games, etc.?

4) What chipset is the MoBo? Also, how many watts is the power supply. Athalons really need 300 watt power supplies to be stable.

WWB

------------------

Before battle, my digital soldiers turn to me and say,

Ave, Caesar! Morituri te salutamus.

Link to comment
Share on other sites

Thanks for the response.

1. I will try DirectX 8.0a and see if it makes a difference, although the problem occurred with DirectX 7.0 and whatever variants there were of that (not sure there were any, but if there were I no doubt tried them)!

2. I did try to install Nvidia’s drivers, but they ended up crashing the whole computer on reboot following installation, so I quickly uninstalled them again! I will try once more; there are probably different versions around now that may be more successful.

3. Microsoft Combat Flight Simulator has recently started exhibiting what appears to be similar behaviour although I’ve not really spent any time investigating that issue. For a while Windows itself was crashing in a similar manner, but this was fixed by installing Service Pack 1. I don’t really get the time to play many other games, those I do however run without problem, as does all other software installed.

4. The motherboard has the AMD-750 chipset, and the case is an InWin A500, a recommended AMD Athlon case, with a 300W ATX 2.01 compliant PSU. I’ve also fitted two case fans to keep the processor cool. As have I arranged the PCI boards to allow maximum airflow around the cooler fan on the GeForce processor.

I have just managed to play one scenario all the way through without any fault, such is the nature of this problem, one minute it works as it is supposed to, the next it will crash every time I try to play! With that in mind it is difficult to determine whether or not the fault is solved, and if it is, what solved it.

Any ideas concerning the reason why the saved games should be being corrupted? I could live with the game crashing, annoying though that might be, so long as I could recover it and pick up from where I saved it.

Link to comment
Share on other sites

What are you using for the heatsink on your Athlon ?

I know that there were some problems with the GeForces and the AMD 750 chipset (I think it was regarding FastWrites or something of that nature). NVidia patched the drivers back and forth a couple of times. What AGP multiplier are you using (1X or 2X) and do you have Sidebanding enabled ?

Are every one of your Saved Game files corrupt ? What drive is CM on ?

What is the BIOS version of your Adaptec controller ? There is a fairly new BIOS for the card (2.57.xx - I can't recall the exact number), but I don't know if it really addresses any problems that you're running into.

Do you know if your system is sharing any IRQs ? Is your PCI bus running at 33Mhz (or thereabouts) ? If it is running any faster it could cause problems with the SCSI card.

I wasn't able to find any mentions of firmware updates for your SCSI hard drive (I guess IBM isn't into doing that).

Are you currently using your mouse in the USB mode or are you using via PS/2 ? Have you tried it as a PS/2 mouse ?

Link to comment
Share on other sites

Thanks Schrullenhaft,

I was not aware there were many options so far as heatsinks are concerned, it’s one designed for the Athlon (up to 1GHz) just the normal arrangement of metallic fins (large) with a standard CPU fan whacked on top, as a precaution I have located a much larger secondary case fan a short distance away providing a boost to the airflow over the chip. Originally there was another fan located at the rear end of the case (behind the processor) drawing the air out, unfortunately that broke, not that it’s of much consequence CM was keen to crash even then!

Every one of my saved games is corrupted, although having said that I’m not sure there ever have been any saved games associated with other battles in the folder at the same time. CM is installed on drive C, the SCSI hard drive, although installing it on the IDE drive made little difference when I last tried it.

The AGP multiplier is set to 2X, I have changed this in the past, in fact, I think I did so after reading your advice on a similar posting.

I can find no reference to Sidebanding anywhere, what is it and where might it be?

I have just looked on Nvidia’s site for their drivers, however they look remarkably similar to the ones I tried before, the ones that resulted in the blank screen. Are there any others lurking elsewhere?

I’m not overly sure of the speed of my PCI bus although I would expect it to be at about 33Mhz, is there anyway to check it without looking at the jumper settings?

IBM doesn’t seem too keen on updating firmware, well for either of my drives anyway. I had a spate of updating firmware versions on most of my hardware a few months ago; at the same time I updated the BIOS on the Adaptec card, which is 2.57.2. I also believe that I currently have the default Windows drivers installed for this device, I have been using the Adaptec drivers in the past, but again they made little difference.

I used to use a PS/2 InteliMouse before upgrading to the USB one. I before that I used a serial one! Still nothing new, game crashed.

I investigated IRQ’s a while back, again following up a similar posting, and discovered the sound card to be sharing with the graphics card. I attempted to fix this by shuffling the cards around on the mainboard, removing devices etc. This I recall did absolutely nothing – they remained assigned to the same IRQ. I have just checked through Device Manager, and discovered quite a number of devices sharing the same IRQ – namely the graphics card, the sound card, the USB controller, the TV card and the SCSI card!? Not sure what’s going on there, I don’t think they were like that when I last checked – I’ve added bits since then!

I’m not the most technically minded person in the world, but surely there must be something consistent here causing the crash to occur. Why is it that whilst on some days I can play a scenario through to its conclusion without fault, yet on another day on the same scenario, I cannot get beyond the first turn? I know there is a high degree of variation during each game, but surely the mechanics of the game are the same or at least similar. Whatever the trigger to this fault is it is clearly something subtle enough not to occur every time, yet severe enough to total the system when it does…only a computer!

Link to comment
Share on other sites

You'd definitely want to sort out your IRQs somehow. It's quite a bit harder with Windows 2000. With most of the PNP OS's you have to remove the device drivers and registry settings and then have the system redetect them. Windows often tries to keep the same settings when it finds something has changed. Windows 2000 uses ACPI to determine the settings for PCI devices. You could possibly disable ACPI in your CMOS/BIOS setup along with PNP OS (or whatever it may be called). What you want is to have Windows use the BIOS's settings for the PCI devices rather than having Windows determine what they should be.

In terms of determining how your BIOS will assign IRQs you'll probably need to look at your motherboard manual and see if it tells you which IRQs are shared among which PCI/AGP slots. Often the first PCI slot next to the AGP slot will share an IRQ (and sometimes even the second PCI slot will share the same IRQ). Usually there are only 4 IRQs to be shared among the AGP and PCI devices (this includes USB and on-board sound, if it existed on your motherboard). For CM I would suggest that your sound card and video card don't share the same IRQ. I'd also suggest that the USB controller not share an IRQ with either the video or sound (mice can generate a lot of interrupts to the system in order to "update" their position). The USB controller is going to share an IRQ with a particular PCI/AGP slot and this can't be changed.

In order to change your IRQ allotment in Windows 2000 you're going to need to:

1. Determine how IRQs are shared on your motherboard. Without this info, further efforts will be as futile and frustrating as your previous effort.

2. Delete the "offending" (the ones that need to have their IRQs changed) devices in the Device Manager. You may have to make modifications to the Registry in order to get rid of the device completely.

3. Shutdown your system. Move the cards to different slots as necessary. Some BIOSs allow for changing the IRQ assignment via the BIOS/CMOS setup, but most do not. Again you don't want your sound, video and USB to share IRQs between each other (they can share with other devices). If possible try to give your SCSI controller its own IRQ.

4. Power on the computer and go into the BIOS/CMOS setup. In here disable ACPI and PNP OS. Either/both of these should prevent Windows from assigning IRQs that differ from the BIOS/CMOS. If it is available you may also want to check your PNP settings for IRQs and PCI assignments.

5. During boot most PCs will give you a listing of how the BIOS/CMOS assigned the IRQs for the PCI devices (and some of them even tell you the ISA PNP device settings). You may want to pause the screen here (usually after memory has been counted and the computer is about to boot) and examine the IRQ assignments to see if everything has been setup the way you desire. If not, I'd suggest rebooting (before Windows starts to boot up) and changing your settings around again to see if you can get a favorable setup.

6. Once the BIOS/CMOS IRQ assignments seem correct, let Windows finish booting. You may need your driver diskettes/CDs to install the drivers (or the directories where they're installed).

7. Hopefully everything is recognized and working once this has been finished. With different IRQ assignments you may have fewer lockups, but this is only one possibility.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...