Jump to content

Type 2 Error on Execution of Demo


Recommended Posts

I cannot seem to be able to run the Demo on my PowerMac 9500/120 (upgraded with a G3/366MHz). It clears the screen like it is about to start and then my desktop reappears and there is an error dialog saying a Type 2 Error has occurred. I usually have associated this with not enough memory, but my machine has 144MB and I allocated 50MB to the demo, and I am not running anything else. I suppose I can try doubling the memory allocated to it.

Thanks for your help.

Ian

Link to comment
Share on other sites

I can't remember much from my Mac support days.... so, uh.. these will be pretty generic attempts at a solution.

What OS are you running ? If you're running something earlier than 9.0x you will probably need to install Game/Soundsprockets if you haven't already (though I wouldn't imagine that would be causing the "type 2" error). What display adapter do you have; are you just running off of the built-in video ?

You may want to reduce the number of extensions and control panels you are loading up to see if this helps any. I would initially disable down to the bare minimum necessary for your hardware, etc. (scsi, video & sound, etc.).

You MAY have a corrupt installation. You might need to delete CM and reinstall. As a last resort it may be necessary to re-download the file.

Link to comment
Share on other sites

I am running Mac-OS 8.6.1 and have installed GameSprockets 1.7.4 which contains SoundSprockets 1.7.1. I am using VillageTronics MacPicasso 540 with the 3D Overdrive (a 3D Graphics accelerator). I have redownloaded at least twice. I will try running with fewer extensions, to see if that helps.

Thanks

Ian

Link to comment
Share on other sites

What drivers do you have for the 3D card? Try running without those first.

I have noticed the same problem if 3DfxGlideLib2.x is present in the extensions folder.

[This message has been edited by G4A (edited 06-16-2000).]

Link to comment
Share on other sites

Sounds like G4A has a point. Skimming Villagetronic's website seems to indicate that the MP 540 + 3D Overdrive supports Glide-based games (it's probably a 3dfx chip). You probably have the Glide libraries in your extensions folder (they come with the 3D Overdrive).

CM is a RAVE based game. It seems as if Villagetronic is in the process of combinig their drivers, but I don't know if they've finished or not. You will probably want the "Village RAVE" in your extensions folder (or possibly the "VT 3D RAVE Accelerator"). Villagetronic seems to have a beta GLIDE driver up, but I don't know how well it works. You will only need it if you want to run GLIDE-based games.

But look for the GLIDE library extension G4A mentioned and disable it.

Link to comment
Share on other sites

Actually, it's more complicated than that. If I just disable the glide libs, I get very bad pixelated graphics. If i start with glide libs, let CM crash, disable the glide libs, and then start CM again, I get better looking and smoother graphics. confused.gif Hopefully this is a known bug that has been fixed in the patch.

Link to comment
Share on other sites

Looks like the 3DfxGlideLib2.x extension was the problem. Once I disabled it, and set my screen resolution to 640X480 everything worked fine. If I had the monitor at anything else other than 640x480 it would not be able to resync. Thanks for all your help.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...