Jump to content

Direct X issues

Recommended Posts


i recently purchased SC v1.06 and loaded it but an error comes up when i try to play.

i have 1.4GhzP4, 512mb ram, Window XP Home w all the recommended patches, ATi Radeon 7500 vid card, Sound Blaster Live sound card w/ latest driver, and recently updated to the latest Direct X 9.

Error when trying to launch game is:

'Direct x launch error' 'could not launch SC in Direct x mode as it appears that the file 'dx7vb.dll' is not registered on your system'

options given are:

1)'register file by running start>run>regsvr32 dx7vb.dll'

2)Change the line 'directx=1' to 'directx=0'in your sc.ini file to run in non-directx mode

i tried option 1 which the system said was successful but the same error occurred the next time i tried to launch sc

i tried reloading the game (in a different location programs\sc vs programs\games\sc) which still did not work

i located the area to edit the sc.ini file but am hesitant to do so as the game probably won't be as enjoyable without directx

i noted that you have a v1.07 patch, do you think this may work?

i also looked through the forum history and did not see any exactly related issues

any input would be great


[ August 23, 2004, 06:58 AM: Message edited by: ccrider ]

Link to comment
Share on other sites

Thanks for the quick response

i have upgraded and was successful and did indeed try running in non-Dx. the error stopped coming up but when i clicked the SC shortcut the monitor screen flashed but the game did not start.

then i noticed, when i try to start the game, that it was running under PROCESSES not APPLICATIONS as it should. all i get is a flicker or black flash on the screen when i try to launch

I also updated my ATI Driver to the latest Catalyst Driver in hopes that this may be a factor... without success

i also tried running the game in Win 98 compatablity mode as i saw on one post

and, i have uninstalled and reinstalled several times with the v1.07 patch

i also tried runnning it on a friends computer which has an xp platform but the very latest in video and audio and it loaded and ran perfectly!

why would the game run under processes rather that apps? anything else to try...maybe a different sound and/or video card?

i saw another post about this so i'll check that out, but any other advice?

Thank you

[ August 23, 2004, 06:55 AM: Message edited by: ccrider ]

Link to comment
Share on other sites

This is indeed a strange error. Sorry to hear about the continued trouble, and although I would never suggest having to upgrade your components (simply to run SC) it does seem that either something is amiss on your system, or that unfortunately SC just does not want to run on your computer.

Also, I'm not sure at all why it would not appear in APPLICATIONS... perhaps you have access to another system that might work without having to set it to run without DirectX?


Link to comment
Share on other sites

  • 3 weeks later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...