Jump to content

Note to self: SFSExtractor and Win7 64

Recommended Posts

Last time I ran TOW was 4 yrs ago on winXP where extractor worked great. Now with win7 64 it just wouldn't run, with a "cannot load rts.dll" error. Took me a bloody 72 hours to get unstuck...

1. make sure the files of the extractor are directly inside MissionEditor folder.


..\Theatre of War\MissionEditor\SFSExtractor.exe

is correct;

..\Theatre of War\MissionEditor\{another folder name}\SFSExtractor.exe


2. Gotta turn off data execution prevention for the extractor to work. start menu->all programs->accessories->command prompt->right click run as admin, type: "bcdedit.exe /set {current} nx AlwaysOff" (without ")

for it to take effect, must reboot.

(to turn DEP back on, same process as above but type: "bcdedit.exe /set {current} nx OptIn" (without "). Maybe could've just used the DEP dialog box to add sfsextractor as exception, but ain't rebooting my rig again..)

I'm not sure it's like this on every win7 64 puter but hope it helps if anyone has similar problems... especially since this forum section is mostly dead nowadays.

Link to comment
Share on other sites

  • Create New...