Jump to content

Sound not working

Recommended Posts

Well, took a little hiatus after the sound suddenly quit a few months ago. Would like to get back to playing, but I re installed and it still doesn't work. I went on line and purchased CMSF again, and it still doesn't work. Game runs fine, just doesn't have sound.

Clean re installs.

Sound option is on.

Any ideas?

Link to comment
Share on other sites

What sound card/chip do you have ? Have you already cycled through the sound option a couple of times (to see if it 'unsticks' in some manner) ? Do you have any mods installed, especially sound mods ?

None of the patches should make a difference for sound to my knowledge. Which patch are you on at the moment (1.32 being the latest/last) ?

It's possible that an update to your sound driver MAY help in this situation (even though you hear sound in other applications).

Link to comment
Share on other sites

So you get no sound the entire time you launch CMSF (from the intro to the 3D battlefield) ? You have already tried 'Alt-S' in game and have seen the 'Sound Off' and 'Sound On' labels change with your keystrokes, correct ? From the 'Options' menu in the main menu, 'Sound' is set to 'On', correct ?

Have you enabled and disabled your 'Realtek HD Audio' adapter within the Device Manager ? On occasion this may help 'reset' an audio adapter so that it is seen properly.

If necessary, you may want to completely uninstall your Realtek audio driver (from the 'Programs and Features' control panel), reboot and then reinstall the latest driver.

Link to comment
Share on other sites

Yes, CMBN and CMSF share a core engine (though it has been modified quite a bit for CMBN).

The only thing I can suggest at this point is to uninstall your audio drivers and reinstall them (rebooting in between uninstalling and reinstalling). Hopefully CMSF will pick up the audio with the drivers being reinstalled.

I don't know what sound API the CMx2 family uses, but I do NOT believe that it is DirectX's DirectSound. Most likely a cross-platform open source API, but I don't know which one.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...