Jump to content
Sign in to follow this  
Kammak

Problems on Win Vista 32bit

Recommended Posts

MajorH,

I used to be active on your mailing list a while back, and played Tacopsv4 nonstop on Win98, NT, and XP without issue.

I installed it recently on a Win Vista 32bit machine, and am having some real issues which I think are sound related. For the first time ever, ever, I have had Tacops v4 stop responding and been forced to not only end the process, but then reboot afterwards as there seems to be some nasty memory leak associated with playing the sounds during the game.

I've had nothing but excellent performance from Tacops v4 for years, so this was quite a shock. I patched to the latest version right after install, 4.0.6 AH, but have not been able to play more than three battles consecutively without issue.

I admit I haven't pin down exactly what is wrong, but the memory usage will usually spike after some sound file is attempted to play, and then the game stops responding, it takes the system a good forty plus seconds to shut it down, but then I have a huge memory usage leftover from the sound system software (I forget the exact process but its obviously related to the sound drivers).

Any history of this issue with other folks? If you want specs and whatever I can provide, but wanted to touch base with you first and see if this is a known thing.

Thanks in advance,

Kevin (Kammak)

Share this post


Link to post
Share on other sites

Are there any command line options or hidden doohickeys that will let me play without any sounds at all? I deleted all the wav files but I'm guessing the game sounds are either in the .exe or some other resource file, right?

This issue is pretty bad - play several times consecutively and the system becomes unstable from memory usage and then locks up the sound system.

I hate to give up on Tacops, so any option that just disables the game from playing any sound effects would be much appreciated.

Share this post


Link to post
Share on other sites

Sound can be disabled completely via the OS sound controls, however the Event Viewer logs would probably be more useful to look at. It'll show detailed error information including error codes. Also, check for running processes, there may be unintended things running ( i.e viruses, etc..). There are some things you can pick up that will attempt to run programs over a network connection ( whether your connected or not ) like audio or video files. There are various tools to use, Software Explorer in Defender ships with Vista and will do the job. An app called Process Explorer will give a more detailed view.This is a free download from Microsoft. Audio drivers should also be looked at. Vista had an early history of driver issues. I have been running Tacops for a year while on Vista without major problems.

Try the audio driver first, it's the easiest thing to do. I recently had a microphone problem with a new head set and the driver update fixed it immediatley. Sorry I didn't mention it first. Hope this helps. I hope you're happily blasting OPFOR soon!!

Best wishes, Sprocket62

Share this post


Link to post
Share on other sites

Thanks for responding Sprocket62.

RE: Sound can be disabled through OS - that doesn't address the issue though which is caused by Tacops trying to play audio files - I was asking for a way to disable Tacops from even trying to play them, as that will stop the memory issue.

RE: Other processes, viruses - its clearly Tacops - I've played it several times now with the Task Manager process viewer side-by-side, and can watch the memory usage increase with each and every sound Tacops fires.

Turning on click sounds slows down the issue, but Tacops still plays several sound files even with click sounds, so its a difference of playing four games instead of three before the system becomes unstable....

RE: Sound drivers - I admit could be the problem, but as I have no issues with anything else, both modern and classic games other than Tacops, I won't be touching the sound drivers anytime soon. I've played Tacops to death in years prior, and mostly reinstalled it for nostalgia.

Share this post


Link to post
Share on other sites

Just for sh*ts and giggles I had Vista look for audio driver updates, and I am running the latest and greatest available for my sound card. The culprit is the Windows audio system - audiodg.exe - from what I've read, all the sound requests go through that program for DRM purposes, and that is what appears to have the memory leak associated with Tacops playing sounds.

Again, a down and dirty fix would be an option to disable all sounds in Tacops - so that it doesn't even try to play any audio. If you can provide this I would be eternally grateful MajorH.

Kevin

Share this post


Link to post
Share on other sites

Sorry that I took so long to notice and reply. I'm on a walkabout. I won't be back to my studio for a couple of weeks more.

Yours is the first report of a problem with Win Vista 32bit.

Try the OS compatibility experiments below first and let me know what happens. Two possible workarounds are mentioned later in this post.

= = = = = =

OS Compatibility Settings

From the Windows desktop, navigate to and open the TacOps folder. It is likely to be at the root level of your primary hard drive rather than in the Programs folder. If Vista hid it somewhere else then do a file search for "TacOps4.exe".

Right click on the file named TacOps4.exe and select Properties from the pop up menu.

When the Properties window appears, click on the Compatibility tab.

Check mark the OS Compatibility box, and then experiment with the various OS compatibility settings - starting with "Windows 98/Me".

= = = = = = =

I don't have a Vista machine with me so the instructions above are based on what I see when I right click on an exe file on an old Windows XP notebook. Hopefully Vista has a similar option.

> Are there any command line options or hidden doohickeys

> that will let me play without any sounds at all?

Not that I recall. The "click sound" option is there but you said that didn't fix the problem.

Try this as a workaround. Select the TacOps Options/Preferences menu item and un check the items named "Startup Screens" and "Bugle Alert". That will stop the playing of the one time startup music and a bugle sound that is played at the beginning of each orders phase.

> I deleted all the wav files but I'm guessing the game sounds are either in the .exe

> or some other resource file, right?

The game sound effects (weapons, explosions, etc) are all compiled into the program file, the exe file.

> plays several times consecutively and the system becomes unstable from memory usage and then locks up the sound system

Try this as a workaround. Don't start a new game by using the TacOps "New Game" menu item. At the end of each game, quit TacOps and then restart the game for the next session. This should do a better job of clearing all memory that Windows may think is being used by the TacOps program.

Share this post


Link to post
Share on other sites

Your problem with audiodg.exe got me curious. I did a little digging and this issue has been around since the release of Vista and appears to have passed on to Windows 7 as well. It can affect anything that plays sound, not just games. It doesn't seem to be universal enough for anyone to address it. However, there is one thing you can try, it's easy to do and undo. Right click on the speaker icon in the notification area ( lower right of the screen if you have it there ). Select "Playback Devices". Select "Speakers and Headphones". Click on the Advanced tab. Uncheck the 2 options in the Exclusive Mode section. It will stop a program from gaining complete control of the audio process. It's a shot in the dark. I am not experiencing the problem that your having so i'm not sure if it will work. I made the changes on my laptop with no ill affects.

Best wishes, happy hunting

Sprocket62

Share this post


Link to post
Share on other sites

I'm not sure if it is included in the regular updates. I do manual updates, usually the security updates only. What Microsoft thinks needs updating and what I think needs updating don't always coincide. I'll take a look and see if an auto update will include the fix.

Share this post


Link to post
Share on other sites

In my recent bug hunt for the solution to this issue I have been unable to determine if it is or going to be part of a general auto-update. People have still had issues as recently as May. Most have resigned themselves to stopping and restarting the sevice. Check the create date of audiodg.exe. If it is newer than March 2010 then you have it. Otherwise, as the Major said, apply only if you have the problem. Keep in mind, this affects programs other than Tacops, so keep it in your general troubleshooting toolbox.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...