Jump to content

XP and Intel740 problem


BN FDO

Recommended Posts

Though my regular screen is 1152x864, 16 bit color, combat mission only wants to come up a max of 640 x 480 at 80 hz. Any ideas why? I haven't had any other problems with the card.

Not quite true. I never got the card it working in win95, but it installed nicely in XP. The card is unsupport (discontinued) now, and the only drivers available came with XP.

Link to comment
Share on other sites

Here's something I lifted from Intel's support about the i740 graphics chip:

<blockquote>quote:</font><hr>The Intel740™ graphics accelerator provides resolution support from 640x480 at 8-, 16-, or 24-bit color to 1600x1200 at 8-bit color (4/8MB cards only) for 2D applications. 3D applications have support for resolutions from 640x480 to 800x600 with 16-bit color for the 2/4/8MB versions.

8MB cards support resolutions to 1024x768 with 16-bit color for 3D applications. An additional resolution of 1152x864 with 16-bit color is available with 8MB cards...<hr></blockquote>

It seems that CMBO should be able to go to 1024 x 768 in 16-bit color with your 8Mb i740. I'm not sure why CM isn't seeing this unless there is something funky with the XP drivers for the i740.

As Panzer Leader said earlier, deleting the Prefs file should make CM go through the resolution selection process again, starting with the resolution that you're currently running at. However your current resolution isn't supported for 3D gaming by the i740, so it should start at the next lower resolution (1024 x 768). Maybe you should reduce your current desktop resolution (temporarily) before launching CM after deleting the Prefs file. Maybe this will aid in the DirectX resolution detection.

What settings do you have available for the i740 with the XP drivers (the 'special' tabs you may see when you click the Advanced button in the Settings tab of the Display control panel) ?

Link to comment
Share on other sites

I tried moving down to 1024x768, but no joy. I also applied a BIOS update, but no change. In the list modes screen I have everthing from 640x480, 256 color, 60 hz to 1280x1024, 85hz.

I'm wondering if it's just a funky driver. It could be an oddity with directx 8.1, too, for xp. Ah, well.

Link to comment
Share on other sites

So let me just reiterate here...

You reduced your desktop resolution (temporarily) to 1024x768, then deleted the CM Prefs file (it doesn't matter which order, as long as BOTH were done before launching CM) and then you launched CM. However you still only get 640x480 with a refresh rate of 80Hz (though subsequent listings will probably have some lower refresh rates at 640x480 before giving you the DirectX error signaling the end of the resolution selection process).

I have an i740 based card (a Diamond card I believe) I can try out sometime in the near future with XP (on a VIA chipset) and I'll see if I duplicate the same problems.

As you already know Intel halted development on this chipset a little while back (before XP or the betas for it came out). This means that Microsoft took the latest applicable drivers and adapted them (with as little effort as possible, I'd assume) for use in XP. It's possible that these drivers have their DirectX 3D modes limited to 640x480. Does the info for your display card list the correct amount of memory for it (8Mb I assume - found at Display control panel > Settings tab > Advanced... button > Display Adapter tab) ?

Ironically the i740 is directly related to the video cores of the i810/815 Northbridge chipsets. I believe that the biggest difference between them is the memory management/access (since the 800 series cores use UMA most of the time). Otherwise I'd guess that most of the 3D functionality would be the same.

Link to comment
Share on other sites

Yup, the settings say it's an 8 MB card. I also just tried running it in compatibility mode (2000, and 98/me, 95), and with the check box for Disable visual themes. No joy. I think I'm just going to have to wait on Microsoft either patching the driver, or DirectX 8.1.

Thanks for all the help!

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...