Jump to content

Can't run 1.03, openplay.dll not found


Ted
 Share

Recommended Posts

I patched up to 1.03 from 1.01.

At the end it asks if you want to launch 1.03 and I get an "Appliction failed to start because OpenPlay.dll not found..."

I click on the CMAK icon on my desktop and 1.01 is still there and runs fine.

I'm using windows xp.

Any ideas?

Link to comment
Share on other sites

OK, same thing's happening to me, but I can't seem to fix it.

here's what happened.

I installed and it asked for open dll program. I then read this thread and went in and deleted the new file. Then I went to open a PBEM turn that had been upgraded to V1.03 and the screen came up saying that this was a different version. Also, the version number at the bottom right of the startup screen says V1.02.

Now, I had renamed my exe. file so I could still play against my opponents who hadn't upgraded yet. Could that have done anything? And what exactly does deleting the new folder that the patch installs do? I don't remember ever having to do that in the past. Why doesn't the patch install directly into the old version thereby upgrading it?

Link to comment
Share on other sites

For my PC with XP

I double click the patch file icon. An installer program pops up and finds the first of my 4 CMAK installs. I browse to the correct one or type in the location, like c:\Combat Mission Afrika Korp and it sends everthing where it is supposed to go. The exe file is overwritten, bmps and wav go to their folders, readme is there with 1.01 and 1.02.

Link to comment
Share on other sites

Yeah. When I get home tonight, I'll drag the file over to the computer and try to install from there. But i don't remember ever having to do this before and I've always burned the various patches to CD at work because all I've got at home is a puny 56k modem and downloading several megs is too time consuming.

BTW I'm running XP also.

If this aint the prob, then I don't know what is.

Link to comment
Share on other sites

OK, I dragged the file onto my desk top and tried to install from there. Same thing happened. I hit finish to launch CMAK and am told the open dll file is not found. The desk top icon is still V1.02.

Besides the old CMAK folder on my hard drive, there's a new CMAK folder that holds an icon that's 9.26 mb in size, a bmp folder holding 88 bmps and a wav folder, holding 1 wav file. There are also two unins000 icons.

Always in the past, the files were installed directly into the existing CMAK folder.

Now, I renamed my exe file to V1.02, so I'd have both versions so I could update PBEM games, but I've always done that and never had a problem.

What's happening?

Once again, I'm on XP.

Link to comment
Share on other sites

When the installer program opens up you first agree to blah blah, then it should ask and show you where to install the patch. That location is to be your main CMAK folder as in my example above. You installed the patch to your desktop and it created a folder for the items in the patch. Rather the try to paste these into your CMAK folder, try the installer again.

Link to comment
Share on other sites

Nope. I browsed until I located the original CMAK folder and selected it. Then when I run install, it installes a new folder within the original CMAK folder. There it sits right alongside the original BMP folder, Quick Battle Maps folder, Scenarios folder, etc. But it's not patched into the game. Do I have a corrupt download?

And what if I just add the BMP and WAV files to their respective folders? I mean that will take care of the textures changes and such, but that won't turn my 1.02 into a 1.03. I still won't be able to play PBEMs against others who've updated, right?

Link to comment
Share on other sites

Don´t browse-and-select.

Check before you hit install in that moment:

it creates a

C:/program archives//battlefront/CMAK/new folder

in that line

so, you delete that new folder and simply let

C:/program archives/battlefront/CMAK/

and then install.

I explained myself badly up-before, but that is

what I mean.

Try this and inform.

Link to comment
Share on other sites

The installer should never create a "new" folder, at least not the installer that I made. But you can just as easily just copy whatever is IN this "new" folder into your CMAK one and it will overwrite all those old files with the correct ones.

Anything in "new" BMP folder goes into your old one, Anything in the "new" WAV folder goes into the old one. And then overwrite your old CMAK executable with the new one. You could also rename your old CMAK executable file instead of overwriting it.

That should be it.

Madmatt

Link to comment
Share on other sites

OK, so I'll copy the BMPs and the WAV files into the existing folders. Now, I'm not really computer savvy... Explain to me about "Overwriting the exe file"? I renamed the old file CMAK v1.02, so that I can still play with both versions, so I've done that, but there IS no file that specifically says "exe". There is a file with the CMAK icon that says "CM Afrika Korps V1.02...Application...9,461 KB".

Is that it?

I know, I know... I have to eat all my meals with a spoon because if I use a fork I might hurt myself.

Life is hard when you're stupid.

Link to comment
Share on other sites

You probably don't have 'extensions' visible in your Explorer File Manager, so programs won't show their .exe extension that tells the OS that this is a program. If you want to see the extensions to each file type, highlight your hard drive within File Manager and go to the Tools menu > Folder Options... > View tab > down the list uncheck 'Hide extensions for known file types'. Click Apply and you should see the .exe extension now (if you really wanted to).

'Overwriting' is just replacing one file with another file of the same name. The OS won't allow two files with the same name and thus the previous file will be 'overwritten' by the new one. The old file will cease to exist and only the new file will be recognized.

If you've done as you've explained with moving the files, you should be ready to go. You can make a shortcut to each file in case you need to play some old PBEMs.

Link to comment
Share on other sites

  • 1 year later...

Sorry to ressurect this old thread but I'm a computer a dummy (I now realise).

Where am I supposed to tell the patch to install?

Wherever I put it, I just get the OpenPlay etc error message...

If I delete the "New Folder" how can I do the install again without ending up with the same problem?

My head hurts...

Link to comment
Share on other sites

Please ignore my previous post.

I appear to have cracked it.

But I'm not entirely sure how...

Must have been all those mince pies but suffice to say that it is now v1.03.

But I've got loads of "New Folders" on my hard drive. I'd better delete them at some point but you know how you don't want to touch something when it's actually working?

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...