Jump to content

Activation Error


Nevada
 Share

Recommended Posts

Moon i've just clicked on the Builder.exe and the Options.exe files and they are doing exactly the same thing as well, get the Play or Buy window then asking for activation if you click on Play. Only by running as admin are they both running. By the way UAC is at the default setting (fresh install of windows only few days ago)

Link to comment
Share on other sites

Thats the only thing that worked for me yes. Indeed, almost moved a few units as well. North Korean 1st Armored Brigade was about to put some hurt down on I Corps down in Pusan. Very nice indeed.

mrsoul, try this, find the games shortcut on your desktop and put the shortcut under RUN AS ADMINISTRATOR and hit APPLY. This should start you okay.

ScreenHunter_01Mar232342.jpg

thanks Nevada, but that is exactly what i do but it still gives me that buy or play mode and we know what happens after that.

Link to comment
Share on other sites

Moon i've just turned UAC off and rebooted comp, the game starts normally then, no need to run as admin. So even though i've installed game to C:\Games\Battlefront Dir some files must be being installed to program files or windows dir possibly thats causing the game not to start when UAC is turned on, unless we run it as admin that is. Same goes for the Builder.exe and Config.exe too.

Link to comment
Share on other sites

Bit odd that you cant get yours running mrsoul, Nevada and me got it running in the end with the admin thing (seems to be a probem somewhere with game or activation program, with win7 anyway) Only other thing i can think of is whether you have an anti-virus or firewall program thats still stopping game running even though you have tried running as admin. I only have the default win7 firewall, i dont use anti-virus progs at all.

Link to comment
Share on other sites

(seems to be a probem somewhere with game or activation program, with win7 anyway)

The problem you and Nevada ran into is probably a bug in the installer which isn't setting all the correct permissions during installation. This creates a problem for storing your license state. I am not sure if mrsoul has the same issue, or something else entirely.

Link to comment
Share on other sites

just seems UAC and the Game dont get on too well

I understand, and thanks for that! I'm just trying to clarify that the problem is with the installer and UAC, not the game. Looks like some last minute bug in the installer, we'll fix it, and Run as admin nor other UAC issues will be a thing of the past.

Link to comment
Share on other sites

well i got it working and my license is activated thanks for your help Moon and others.

Now to feast my eyes on the candy Battlefront has given us.

"War is a terrible thing but god help me i love so"

this game looks sweet!

Link to comment
Share on other sites

That's good to hear, mrsoul. What did you do to get it working?

i did like you said and went to the game file and checked run as admin instead of right clicking on the exe icon it went to the update screen then launched.

thanks again Moon.:)

Link to comment
Share on other sites

Help, anyone, having a "invalid serial number issue & i'm getting a (not responding) on my Tow 3 activation box, but it comes on the "not responding" only after i hit the button to activate my tow 3 activation number it , says not responding beside the tow 3 Korea & the serial number invalid comes up after that, real weird never seen this on a battle front game before, i'm running a alien-ware alx-area 51 6 core CPU & dual ATI -5970 vid cards, with latest drivers, can anyone give me a idea what to do please? i also put a support ticket in also, i tried running as admin also, in the game compatability on the tow 3 icon as well, but since uac & win 7 dont like battlefront games i put tow 3 to d:/ program files/battle ground/.......... instead of c:/program files(86x) ..... I have done this with all my CMSF & Theatre of war 1,2 & now 3 games with no problems, just driving me crazy & I also have wiped & reinstalled 2 times the tow 3 game

Link to comment
Share on other sites

Hi guys,

alright, we have been able to identify the problem. It has to do with the unusual behavior of the installer, which is launching the game activation while the installer is still running. This has created an unexpected permissions conflict.

The solution is as explained above for now to simply make sure that after installation, you set the corresponding exe files to Run as admin. The procedure is explained in our Knowledgebase: http://www.battlefront.com/helpdesk/index.php?_m=knowledgebase&_a=viewarticle&kbarticleid=203

You do not need to activate more than once, either. Simply make the correct file settings after the initial install, and you won't be prompted for activation a second time.

This workaround will get you guys up and running. We are now preparing a patch to fix this behavior, and also update the full installers.

Sorry about this. This is an unusual error related to the specifics of the installer which somehow wasn't caught during testing and must have crept in at last second :-(

Martin

Link to comment
Share on other sites

Not a problem, the fix coming at the wee hours of the morning was more surprising, geez you guys ever sleep? :D Battlefront also reset my activations to just 1 which was awesome by the way thank you. The temporary fix is not really unusual to be honest for this day. I recall having to use the compatibility mode quite often during the transition from Windows 98 to Windows XP and most recently with Windows XP to Windows 7. It just never dawned on me to use it this time, I think its almost second nature to do just that whenever you have an issue in todays multi OS environment.

The title itself is exceptional, I just wanted to peak at the new terrain, well a few hours later................ that was one long peak. Its very nice to see the Korean Conflict done its dues finally. So very few titles have offered some insight on this particular time in history. Falklands would be a nice change as well *coff coff* *nudge nudge*. I think Ive been WWII'd out although the earlier TOW titles were exceptional in their own right. Its just nice to have something different for a change.

Jim

Link to comment
Share on other sites

OK, we have released a Hotfix that will solve this issue. Even if you have the workaround in place right now, you should download the hotfix if you had problems with licensing, and rung it. After that you can remove the "Run as admin" flags.

Download here:

http://www.battlefront.com/index.php?option=com_versions&Itemid=317#Theatre of War 3 Korea

Details here:

http://www.battlefront.com/helpdesk/index.php?_m=knowledgebase&_a=viewarticle&kbarticleid=203

Link to comment
Share on other sites

I am not sure why it would ask you that since rebooting isn't normally required after installation.

Moon,

I can confirm that the installation program asked me to reboot exactly like Nevada mentionned previously. I had also the same "Play or Buy" screen after rebooting, and had to enter the license key. However, I had no problem activating the license and playing the game. I simply assumed that as usual, I needed to start ToW3 with administrator rights, I did just that and evrerything worked fine.

I'm assuming that the Tow3 installer and/or the game itself needs administrator rights, as it's what I did for both and encountered no problems.

Link to comment
Share on other sites

Hi Knokke,

actually, neither the game nor our new activation system should require administrator rights to play. If you run the Hotfix posted at www.battlefront.com/helpdesk, then you will be able to remove the Run as admin flags, and the game will still work as intended.

By the way: We have just enabled download only, mail only, and download & mail purchases (aka "official release") ar www.battlefront.com/store. The full version download installer on the cloud network has been updated to already include the hotfix, so there is no need to run it separately if you are only purchasing/downloading now (when you install you will notice that it runs as the last step of the game installation).

Martin

Link to comment
Share on other sites

I'm getting a 'Server License Corrupt' message. I installed the game, it said it couldn't find the activation license thing. I canceled outta that, then saw the hotfix and ran it. Now it says "The license project on the server is corrupt."

Not sure what's happening, and the game isn't showing up in any of my installed program lists to uninstall it.

Link to comment
Share on other sites

 Share

×
×
  • Create New...