Jump to content

CMSF not loading, win 7 64 bit


Recommended Posts

"CM Shock Force.exe has stopped working" - immediately after clicking on the "Launch Combat Mission..." icon.

Details:

Problem signature:

Problem Event Name: APPCRASH

Application Name: CM Shock Force.exe

Application Version: 0.0.0.0

Application Timestamp: 4af14c9e

Fault Module Name: CM Shock Force.exe

Fault Module Version: 0.0.0.0

Fault Module Timestamp: 4af14c9e

Exception Code: c0000005

Exception Offset: 002f2ab7

OS Version: 6.1.7600.2.0.0.256.1

Locale ID: 4105

Additional Information 1: 0a9e

Additional Information 2: 0a9e372d3b4ad19135b953a78882e789

Additional Information 3: 0a9e

Additional Information 4: 0a9e372d3b4ad19135b953a78882e789

I haven't played for a while, perhaps since the upgrade from vista to 7, interested in any help.

While the "details" look like a CMSF problem, not graphics, FYI I'm running ATI Radeon 4850 with 10.11 Catalyst.

Link to post
Share on other sites

Schrullenhaft is an outstanding forum member when it comes to resolving these issues. I'm sure he'll be along shortly.

I cannot solve your problem, but I am posting to let you know that my CMSF running on Windows 7/64 runs without any issues. It's not a compatibility problem with the OS. (Nor am I running it under XP mode.) There must be some other software interfering with the game executable. The immediately obvious would be an antivirus/firewall which doesn't like CMSF.

Sorry for not pointing you to a definitive solution, but W7/64 and CMSF do work.

Good luck!

Ken

Link to post
Share on other sites

Was CMSF installed and licensed when you performed the upgrade from Vista to Windows 7 ? Upgrades can cause problems to eLicense games, though I would normally expect it to ask to activate again as the most common problem. However the registry changes that can be made, among other things, can basically screw up an eLicense protected game.

One thing to check is your DEP (Data Execution Prevention) settings. While not necessary for everyone, occasionally we find it necessary for some users. Our Knowledgebase article on DEP should hopefully provide the details you need to set this and see if it a solution or not.

As c3k and Moon mentioned, you may need to check the security software you have installed. We've run into a number of problems with certain security programs and eLicense. Among them are ZoneAlarm, F-Secure and Spyware Doctor and others.

Double-check that the eLicense software is actually running. Go to Start/Windows menu > Control Panel > Administrative Tools > Services. In here look for the 'LicCtrl Service' and see if the 'Status' column says 'Started' or it is 'blank'. Right-click on the name of this service and either select 'Start' if it is not on or select 'Stop'. If you have stopped the service, then right-click again and select 'Start'. Hopefully the 'Status' column should come up with 'Started'.

The compatibility mode of 'Windows XP SP3' typically is NOT needed, however it has worked for some customers (mysteriously). As you've already found out, it did not make a difference for this error.

If none of this works, then attempt to unlicense CMSF (hopefully there's a shortcut for this in your Start Menu). If you have one or more modules installed, then the unlicense dialog box will actually be for one of those modules. If the license dialog box DOES come up, attempt to unlicense that module and see if you're successful. If you are, then try to run CMSF again and hopefully you'll be prompted to license the game and maybe it will work. If you get an 'error 11' on your attempt to license the game, then you need to open up a open up a ticket with the Helpdesk to get your license key reset (you'll probably want to provide all of your license keys for each eLicense Battlefront game you have).

Link to post
Share on other sites

Thanks everyone - I've tried, I think, all of the suggestions here

date	action

22-Nov	tried xp compatibility; administrator; no go.  Left Administrator on.

23-Nov	disable firewall, a/v, defender;  no go, re-enabled them.

23-Nov	check LicCtrl Service, it's running, so no change here.

23-Nov	DEP per Schrullenhaft's suggestions; no change.

23-Nov	unlicence / relicence; uninstall / reboot / reinstall; no change.

I use Comodo A/V, Firewall and "defence" - disabled all as above.

So... any new ideas?

Link to post
Share on other sites

If you get the problem in the demo, then this indicates something else entirely than the usual issues with licensing (because the demo does not use licensing). As such, the DEP settings or DEP or firewalls will not solve the issue most likely, because they are not the problem. Seems to me to be some kind of hardware of driver problem (most likely), or (less likely) installation issue (wrong path), or incompatible mods or hotkeys.txt file.

Link to post
Share on other sites

Are you sure that the installation went into the correct directory then? The installer tries to anticipate the correct path to install to but it's not 100% failsafe, especially if you changed the default path or if you have a different version of CMSF (not from Battlefront). Have a look at how the files are arranged in your CMSF folder.

Link to post
Share on other sites
  • 3 weeks later...

I had the same problem. After installing the patch nothing worked.

Now I found the following solution:

Delete the Preferences - PFC- File in the CMF-Folder.

When I started the game all worked fine and the game created

an new Preferences - PFC -File. No problem in the Tutorial campaign till now....:)

Hope this helps you, too.

Link to post
Share on other sites

Dear Ladies and Gentlemen,

I have checked and read all troubleshooting instructions that were provided by your e-mails, in your troubleshooting guides and in the battlefront forum by your administrators "Moon" and "Schrullenhaft".

Nothing helped.

I turned off my Norton Antivirus, even uninstalled it - no effect.

I tried different User Access Control variants as suggested (UAC settings) - no effect.

When I add the "Shork Force.exe", the "Marines.exe" and the "runservice.exe" manually as exceptions to the DEP settings, the LicCtrl is on "automatic" and could not be started by right mouseclick menu then leftclick. And I get and error message when trying to start the game.

Are there no exceptions added to the DEP settings, the LicCtrl Service status is always on "started", no error message appears when I click on the CMSF.exe Icon - but the game just does nothing.

The CMSF DEMO 1.30 ran for a while, but now it has stopped functioning too.

When I installed the CMSF+Marines Bundle on a second Windows 7 PC, I received a system message saying that CMSF has violated the AERO graphic settings (this is the windows 7 standard design) and that these settings will be reset after the programme CMSF has been closed. There the game was only displayed in about one third of the screen (left upper corner).

I'm not a computer specialist but from my experience now with CMSF and the CMSF Demo after one week of attempt and error I suppose that it is a graphic problem.

First, when the Demo ran but the full version didn't, I thought it must be an eLicense matter, but now as the Demo doesn't work either after I have reinstalled my Norton Antivirus I suppose that the PC does not execute your programme because windows 7 thinks that it does something to the settings

or is a threat to the system.

With my Windows 7 PC I'm using an ATI Radeon HD 5450 graphic card, with resolution settings 2560 x 1600 (recommended by the system for the 30 inch screen) but in CMSF there are only four graphic setting options, three that I can't remember exactly but were much lower and one called "desktop".

Maybe this is the reason.

I hope with my "observational research" I could help you a little and I hope to hear from you again when you fixed it.

Thank you in advance and best regards

Shorker

Link to post
Share on other sites

Were a bit mystified as to why the program will work one day and then the next will refuse to start, especially when all of the DEP settings are in place and supposedly nothing has been changed.

The problem with the game launching is typically due to eLicense. If you can run the Demo with no problems, but the full version refuses to start, that typically indicates that the system is having a problem with eLicense. Almost all issues with our games not running are due to either DEP or security software blocking the fully functionality of eLicense. If you have problems with the Demo running, then that indicates something else is wrong with the system (but there still may be an issue with the security software/DEP settings).

The 'desktop' resolution is what your desktop is currently set to and is usually the recommended setting for most users. In your case that means that CMSF should run at 2560 x 1600 at whatever refresh rate you're currently running at. The other resolutions are some common ones that are explicitly listed, but you can also edit the 'display size.txt' file in the CMSF with a custom resolution that will get listed/defaulted. This file can list only one resolution in this format: horizontal, vertical, refresh rate. For example (without quotes in the actual file) "1024 768 60". This is 1024 x 768 at 60Hz.

I'm not sure why you're getting the "CMSF has violated the AERO graphic settings. These settings will be reset after the program CMSF has been closed." I'm also unsure why the demo would suddenly start displaying this error message after working fine initially. I would not think that this error would prevent the game from running, just warn you that it may affect the Aero interface if you were to switch back to the desktop while the game is running. CMSF is an OpenGL game that takes over the entire screen and it doesn't use the Aero interface for any of its screens (hence a part of the reason why you may get this error). The error message MAY be generated from a setting in the 'Compatibility' tab that you have made. I can't recall exactly which one may be responsible, but the settings in the 'Compatibility' tab that may affect this would be under the 'Settings' section: 'Disable visual themes', 'Disable desktop composition' and 'Disable display scaling on high DPI settings'.

I'm confused when you say "the LicCtrl is on "automatic" and could not be started by right mouseclick menu then leftclick". Does the 'Status' column say 'Started' in the Services control panel for the 'LicCtrl Service' ? If you right-click and select 'Stop', watch the Status column go blank and then right-click again and select 'Start', are you getting an error message at this point ?

Link to post
Share on other sites
  • 3 months later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...