Jump to content

Laptop problem!


Recommended Posts

I have a thinkpad i 1400 series that is

433Mhz,192MB of ram running win98 and has a

ATI rage mobility-m 3D 4MB video card. I put

in combat mission and then directX 7.0 and

every time it gets to the map it freezes the

laptop and I have to restart the laptop.

don't know what to do. HELP!

Link to comment
Share on other sites

Do the freezes happen immediately or do you attempt to scroll around on the 3D map before you get the lockup ? If you have time try to disable sound in CM with the Shift-S keystroke and see if this makes a difference.

I don't know if updating the drivers or BIOS may help with your situation or not, but it may be worth a try. You'll need to identify your machine's full 'type' designation in order to download the correct files.

IBM Thinkpad i series downloads:

http://www.pc.ibm.com/qtechinfo/MIGR-488QAL.html?lang=en_US&page=brand&brand=IBM+ThinkPad&doctype=Downloadable+files&subtype=Cat#Video

I'd also suggest making sure that you don't have anything else running in the background (Ctrl-Alt-Del should give you a list of apps you can close down). Turn off any power saving settings in the control panels and in the BIOS. You may also want to try a lower resolution by deleting the CM Prefs file in the C:\PROGRAM FILES\CMBO directory. This will force you to go through the resolution selection process again.

Link to comment
Share on other sites

Well I disabled sound like you said but a second after i did, it froze. I took off sleep manager,realplay,and ezicon from the Ctrl,Alt delete thing but I still left on Atiptaxx, Ati2cwxx,Ati2plxx,and of course I left on explorer and systry. Those three (Ati) things I don't know what they are. And I turned off any power saving features and I upgraded to the newest video drivers from IBM I did'nt erase the resolution file for CM but I know it's runing at 800x600 and my screen res is set at 1024x768 at 16bit high color. and I have a Lan Pc card installed I

don't know if that makes a differance. But it's still locking up.

Link to comment
Share on other sites

You may need to go into your CMOS/BIOS setup and find a setting called AGP Aperture or Graphics Aperture. Reduce this setting as far as possible. If this setting is even adjustable it may not go down very far, 32 & 16Mb seem to be common limits.

The next thing I would suggest is that your run the DirectX control applet. From Run type in C:\PROGRAM FILES\DIRECTX\SETUP\DXDIAG. This will launch the control applet for DirectX. Go to the Display tab > DirectX Features section > click the Disable button for AGP Texture Acceleration (if this isn't permanently disabled already). OK these settings and possibly reboot if required. If this doesn't help then go back to the DirectX control applet again and this time disable the Direct3D Accleration. After this you'll probably need to delete your CM Prefs file since you'll no longer be using your video chip's 3D capabilities (the CPU will be performing those computations). This will be quite a bit slower, but it may allow CM to run on your ThinkPad.

Link to comment
Share on other sites

The laptop bios does'nt have a AGP setting so

I went to the directX program and disabled

AGP support and it locked up. Then went and disabled 3D acceleration all together and

erased the CM prefs file and ran it in software mode at 640x480 and it worked.

Of course it's really slow. I think CM does not like my laptop video card because I put in Rainbow 6 to test the video card and it ran it just fine.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...