Jump to content

Version 1.01.5192 Available


Recommended Posts

Changed in 1.01.5192

- Added a 'free technology' option to the game-setup window. This allows all players to start higher up the technology tree.

- Fixed a problem with game-replay where unit visibility circles appear on the map even though the unit hasn't been built yet.

- Fixed a bug with units dropping their orders. This would sometimes occur with units who were following city-rally points.

- Fixed a crash in the unitset editor

- Fixed a crash that happens on the world-map with AI players

- Fixed a crash that occurs in the AI

- Added a Rules Validator to the rules editor, to catch problems with a unitset

- (Server-side) Fixed bug uploading files to the server

If you pay close attention to the updater, you can figure out what I've been working on. It's not available yet, though, because I'm not done with it. (No, it's not rivers.)

Link to post
Share on other sites

Hi There,

The update worked OK for me, but I have one small nit with the update.

The way the units at the start of a turn "jump" to thier new positions (as of the end of the turn), and then "snap" back to do the move in the replay is a little annoying. I don't remember them doing it before (or at least not as noticable).

Kevin

Link to post
Share on other sites

Took 2 tries before I could get the uppdate. It said "server not available" on the first try. I trieds agains immediately and it worked, so something is up with the server,....maybe its really busy today or something.

As for the updater and what Brit is working on,...I saw some text fly bybefore it went to updating the EOS.exe,...but it was so fast I couldnt read a single word of it.

Link to post
Share on other sites

How odd. I always test updates as soon as I put them up. It worked for me fine when I tried it earlier, but it doesn't work for me now. Will look into it.

Update: I tried again (five minutes later) to figure out what's going wrong, and suddenly it works fine again. I tried three more times, and it worked fine every time.

Link to post
Share on other sites
Hi There,

The update worked OK for me, but I have one small nit with the update.

The way the units at the start of a turn "jump" to thier new positions (as of the end of the turn), and then "snap" back to do the move in the replay is a little annoying. I don't remember them doing it before (or at least not as noticable).

Hm. You're right. The new 'jumping' behavior was a result of another fix I made in this update. I've tracked down and fixed this new bug. This will be fixed in the next update.

Link to post
Share on other sites

Another bug is the coastal movement. I started a new game last night, moved a TR with a couple of AR to another island, and the AR couldn't navigate from the TR to the city. This happens sporadically with different units. In the game I sent you I had it was with a TR and you mentioned a problem with an ai artillery unit.

Link to post
Share on other sites
×
×
  • Create New...