Jump to content

Schrullenhaft, help with 640x480, please...


dh1988
 Share

Recommended Posts

I have recently installed CMBB and having trouble getting started because the entire screen is not showing up on my monitor. Specifically, the Global Info Panel does not appear entirely on the screen, I am missing the right most portion of the screen, including several of the camera keys and the Go key.

I have tried deleting the Combat Mission BB Prefs file but when is comes time to select display it is only giving me the 640x480 screen as a resolution choice but at several "hz" speeds. No other resolutions are an option. I have also tried changing my system display from 1024x768 to 640x480 but the right part of the screen is still missing.

I have scoured the postings for listings related to this problem and I came across your reply to one of them. Any help you can give would be very appreciated.

Thanks...

Link to comment
Share on other sites

You have to be running at 800x600 or greater before you restart CMBB after deleting the Prefs file. The resolution selection process will start at your current desktop resolution (but at a possibly higher refresh rate) and work down from there. The 640x480 resolutions aren't valid. If that's all you're offered, then I'm not sure what is going on. If you can see the 3D screen, then I'd guess that you have hardware rendering working (I don't know if CMBB will show a 'software rendering' option during the resolution selection process at 640x480).

Link to comment
Share on other sites

Schrullenhaft,

for what its worth, i've run cmbo on a notebook at 640x480 in software mode - so it's possible

but it's also not playable - way too slow

dh1988,

that vid card should be able to work - although the driver you listed isn't really what i had in mind - but no matter

have you tried what Schrullenhaft suggested?

because until you get it off of 640x480 everything is not going to fit on the screen - at this point it might even be worthwhile to delete cmbb entirely and do a fresh install - and when you fire it up again, make sure the desktop resolution you're running before you enter the game for the 1st time is at least 800x600 - or even better, set your desktop rez at whatever you want to run the game at and then start it- that way it will be the 1st option the game offers you the 1st time you run it

Link to comment
Share on other sites

easy target,

Thanks for the help. Yes I have tried what Schrullenhaft has suggested and it has not worked. The only resolution option it is giving me is 640x480. I have also wiped it off my system and did a re-install and the same thing has happened, only 640x480 as an option at different Hz speeds. I have sent a message to CDV 3 days ago but have gotten no reply. After 4 days of trying to get this to work I'm ready to take it back to CompUSA. If you can think of anything else that might solve this problem let me know and appreciate the help you and Schrullenhaft have provided.

Link to comment
Share on other sites

hmm, that's a pity

hell, if wiping it off the drive and reinstalling didn't work i'm not sure what else to suggest at this point

if the offending copy is CDV, i'm thinking at this point you might want to consider returning it and purchasing it straight from the source itself

Link to comment
Share on other sites

dh1998,

Go to your start menu and select the run option, then enter 'dxdiag.exe' and hit the enter key. You should see a DirectX diagnostic tool. Select the Display tab. In the lower section of the screen you will see a DirectX Features area where you will have a DirectDraw Acceleration, Direct3D Acceleration and AGP Texture Acceleration each followed by whether they are enabled or not. All three of these should be selectable. If any of these are grayed out or you cannot run the Test command buttons then you need to reinstall DirectX.

Link to comment
Share on other sites

Brooktrout,

I ran Diagdx and two of the areas were grayed out, Direct 3d Acceleration and AGP Texture Acceleration. I downloaded DirectX 9.0 from Msoft but the two areas remain grayed out. I'm not real technical so I was wondering if my video card (listed above) would support the technology. I think it would, maybe the drivers?

If I could also ask, if those two areas are grayed out, if that the cause of the problem of not seeing the entire Info panel on the screen?

Thanks again for the help.

Link to comment
Share on other sites

dh1998, I believe that your problem with DirectX is the reason that you are only allowed to choose the 640x480 resolution when selecting your prefs. That happened to me in the past and I had seen where Schrullenhaft had posted something about this in the past. I ended up reinstalling DirectX and still the problem persisted. I had to uninstall DirectX, reboot and then reinstall DirectX followed by my video card drivers to fix the problem.

Link to comment
Share on other sites

The reason you're limited to 640x480 is because of the lack of 'Direct 3D Acceleration'. CMBB is running in 'software rendering mode' which really doesn't work since it only supports 640x480.

Your videocard based on the NVidia TNT w/16Mb of video memory should work with CMBB. I've tested CMBB on NVidia chips such as the Riva 128ZX with 8Mb and they've worked. However, I have seen certain TNT cards (specifically the NV4 - which isn't indicated by the driver you listed earlier) that aren't supported by some versions of the NVidia Detonators. I beleive some of the newer versions started supporting this chip again, but there was a lapse in the past (somewhere after the early 29.xx's)

I don't know of any easy way to actually remove DirectX since Microsoft doesn't allow its uninstallation. You would have to have had an uninstaller program working in the background during DirectX's install in order to cleanly and easily uninstall whatever previous version of DirectX you had installed. DirectX 9 is somewhat overkill with your installation, but you should be able to leave it as is in this regard.

The 'AGP Texture Accleration' may be grayed out if your card is PCI, which is a possibility.

Which version of Windows are you running ? I've been assuming that it is either Windows 98 or ME.

You need to find out which driver you have. Assuming you're running Win9x/ME go to the Control Panel > System control panel > Device Manager tab > double-click on the 'Display adapters' listing > double-click on the video device that shows here. If you have a yellow circle with an exclamation mark in it, then something is wrong. Click on the Drivers tab > near the top you will be given some info on the driver manufacturer and the date of the driver. Click on the 'Driver Files Details' button and highlight any of the files that end with '.DRV' these will usually be the primary files that will indicate the driver version. When a filename is highlighted above, info will be displayed below relating to that particular file. The File Version info is what we need here.

What I'm guessing here is that you may need to reinstall the video drivers. It's possible, for some reason, that they aren't properly installed and you're not seeing full DirectX support. More than likely you'll need to uninstall the video drivers, delete some files (that the uninstall may not get) and reinstall your video temporarily as a 'SVGA PCI' adapter. Once Windows sees your video card as a standard VGA adapter (which limits the resolution and color depth) then you could reinstall some newer video drivers. I'll probalby need to explain this step-by-step for you later. For now, try to provide the info that I've requested and we'll go from there.

Link to comment
Share on other sites

Schrullenhaft and brooktrout,

Thank you both for your help. I ended up going out to Nvidia's website and updated the drivers on the video card. This "unfroze" the Direct 3D Acceleration and AGP Texture Acceleration tabs and I have successfully installed CMBB and completed my first battle. Thanks again for your help.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...