Jump to content

CMSF Now not working


Recommended Posts

Had to do a system rebuild about 3 weeks ago...had CMSF installed and running with Marines and British addons (though I didn't try the Marines and British addons at the time)

But now when I try to run the game from the shortcut, I gate an error saying.

"CM Shock Force.exe - Application Error"

"The application was unable to start correctly (0xc0000005). Click OK to close the application"

Now it was working. Last time I played and saved was teh TaskForce Thunder campaign on the 11/11/2009 and I have 4 saves (the last one being for that date) but I haven't played it since.

Now when I start the game (not load a game...start CMSF from the shortcut), I get the above error.

When I checked the Event Viewer for the application error, it says this

"

Faulting application name: CM Shock Force.exe, version: 0.0.0.0, time stamp: 0x4a5f4b57

Faulting module name: elicen40.dll, version: 4.0.0.0, time stamp: 0x3d86b216

Exception code: 0xc0000005

Fault offset: 0x00025001

Faulting process id: 0xc30

Faulting application start time: 0x01ca6e105ec2fd6e

Faulting application path: D:\Games\Combat Mission Shock Force\CM Shock Force.exe

Faulting module path: D:\Games\Combat Mission Shock Force\elicen40.dll

Report Id: 9cf736be-da03-11de-b90a-002354280315

"

any ideas pls?

Sorry

Running

Windows 7 Home Premium 64bit

Intel Core 2 Quad Q8200 2.33Ghz

4GB DDR2 Ram

nVidia GeForce 8800GT 512MB

Link to comment
Share on other sites

Yes, your Windows security settings are preventing the game from launching. This could be either:

- UAC (user access control). You need to set the Properties of the game executables to "run as admin)

- your anti-virus/firewall program. You may have to set exceptions to leave the game alone (exclude folders and or exe files)

- (rare) DEP (data execution prevention. We have a couple of articles about this in our Knowledge Base at www.battlefront.com/helpdesk

Link to comment
Share on other sites

It's seems elicense is the problem.

But it's not immediately clear to me why, as I can't really tell what you did with your CMSF installation. Seems like you may have copied the CMSF folder to a safe location and copied back when you were done building the system. If that is the case all the files are in place except that e-license is no longer properly activated.

Link to comment
Share on other sites

It's not failing... it's being made to fail by one of the security settings I mentioned above. You HAVE to be running with full admin rights (at least for the very first time you launch the game). Another thing you can try is to disable your firewall (but for some, you need to read their manual how to disable them properly).

Link to comment
Share on other sites

Moon

I've added CM Shock Force.exe to the DEP list...now I don't get an error, but it doesn't run.

It loads in the Task Manager, but loads about 3MB into memory, sits there for exactly 1 minute (tried it several times)

Tried running with Windows Firewall off (the only firewall I have)...still sits there for a minute and then unloads

As I said, the LicCtrl service doesn't want to start - don't know if that's got anything to do with it

Link to comment
Share on other sites

When I try to run the game now, an event is logged in the Event Log (surprisingly :-))

It says

The description for Event ID 0 from source LicCtrlService cannot be found. Either the component that raises this event is not installed on your local computer or the installation is corrupted. You can install or repair the component on the local computer.

If the event originated on another computer, the display information had to be saved with the event.

The following information was included with the event:

LicCtrlService error: 998

LoadLibrary failed.

Link to comment
Share on other sites

You don't mention the most important thing I asked twice: are you running with full administrator rights? Please right-click on the CM Shock Force.exe, select Properties, and make sure you have it set to "Run as admin". To go sure, do the same for any Module.exe files you have in the Modules folder.

Or switch off UAC under Windows Vista or 7.

If it's still being blocked, then it's the Anti-virus software. Check your AV software docs for how to set exceptions, and exclude CMSF. Ideally, you can exclude the entire directory. *May* have to exclude runservice.exe from your C:\Windows folder, too.

Martin

Link to comment
Share on other sites

Yes I am running as Administrator

Yes UAC is off

I've tried running with anti virus off

Yes RunService is in the expected location

I've uninstalled now and will try to reinstall...but I notice the LicCtrl service is still listed in the list of services and it's still not running (should this not be uninstalled with the app?)

If the LicCtrl service isn't running, is there any point to me reinstalling? Seems this is an integral file, but not running.

If it is worth reinstalling, what is the procedure?

GG Download of CMSF

install Patch 1.10 all inclusive

Install Marines module

Install Marines patch 120

Install British Forces

Install 1.21 patch?

Link to comment
Share on other sites

Install base game, then marines module, then british module, then 1.21 patch. You do not need the in-between steps of patching.

If UAC is off then there is no option to "Run as admin". So it can't be both. Shut down UAC, shut down your AV, reboot your PC and check if the service is running.

LicCtrl is not uninstalled together with the games. You can manually uninstall it, there is an article on how to do it in our Knowledgebase. You know, you could try that, and when you reinstall the games, it will be re-installed, too. It may "remove" any persistant blocks by your security stuff. Or, in fact, if it is somehow corrupt, it will repair that, too.

BTW, I am suspecting your Anti-virus program. That's what it usually boils down to if people have weird issues like yours. Some AV programs "appear" to be off, but they aren't, and keep blocking stuff, and you need to reboot *without* them in order to really shut them off. (I wish AV makers would tell people more about the stuff they're installing)

Link to comment
Share on other sites

The LicCtrl Service IS the 'Runservice.exe' program. Do you have any other Battlefront programs on your computer that use eLicense ? What is the file size for your 'Runservice.exe', is it 2,560 bytes in size (not "on disk" size) ?

What anti-virus software are you running on your system ? We've seen some very annoying problems with Zone Alarm and its associated utitlies (the "Forcefield" browser protection bar). It's possible that you may need to uninstall your anti-virus/firewall/internet-security application in order to get CMSF working with eLicense (and installing after CMSF is licensed and working).

If your anti-virus program has some 'heuristic scanning' you may want to disable them since those scans/lockdowns could definitely interfere with eLicense.

What's "GG Download of CMSF" ? Is that Gamer's Gate ? That version doesn't use eLicense (to my knowledge). However once you install the Marines module, your CMSF executable will be come an eLicensed version (using the Marines module license key at that point). If you're installing the 1.10 patch, is it the Gamersgate version ?

Link to comment
Share on other sites

RunService.exe is 2,560

I'm running Avast, but as I said, I'd turned it off. I do not have Zonealarm installed (only Windows Firewall as stated above)

Don't know about the heuristic scanning...as I said, I turned the anti virus software off. Besides, it was installed when I last ran the game on 11th November.

GG is Gamersgate. Don't know about the patch - can't tell. It's from Battlefront.com it says, but comes up with a battlefront AND Gamersgate logo.

Just tried and uninstall and reinstall. The game fired up with Vanilla CMSF. It also fired up with patched 1.10 CMSF. As soon as I installed the Marines module, the game does not want to play. So the problem lies with the eLicence service.

Seeing as you uninstall DOES NOT uninstall the elicence feature, is there a way I can manually do this so it reinstalls? The service is not starting...I don't know what else you might think is blocking it if I've tried running it with Firewall and anti virus on AND all exe files added to DEP list?

Link to comment
Share on other sites

Glad to hear it's working. Here you have proof that DEP is highly buggy on some CPUs (it's a CPU hardware function). Why it would trigger Marines and not the others (which are identical) will always remain the mistery of hardware manufacturers :) (luckily, newer PCs we're seeing rarely seem to have this problem anymore, it was most prevalent when DEP was newly introduced a couple of year ago)

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...