Jump to content

New update seems to be more unstable.


MagicKoji
 Share

Recommended Posts

With the original release of the Demo... I never had a crash or a lock up... now playing it with the update, for the last 4 hours and I've had 3 lock ups... where I had to go and kill the proccess for the game. it always happen when a production is done menu pops up... usually around 100 rounds in.

also, at times when I try to save the game... it gives me a can't save message and leaves a pop up window with a timer on it up... that never goes away.

other than those things... I really like the game. :)

Koji

Link to comment
Share on other sites

With the original release of the Demo... I never had a crash or a lock up... now playing it with the update, for the last 4 hours and I've had 3 lock ups... where I had to go and kill the proccess for the game. it always happen when a production is done menu pops up... usually around 100 rounds in.

I'll look into it. I can't think of anything that was done that would increase the game's instability. There's always the possibility that these lockups happened to be clustered after the update happened. Either way, it's something that needs fixing.

also, at times when I try to save the game... it gives me a can't save message and leaves a pop up window with a timer on it up... that never goes away.

other than those things... I really like the game. :)

Koji

Does it give you those errors when the autosave happens too? You may need to right-click and and set the game to "Run as administrator". Or shut off UAC (User Access Control) under Vista. You are running under Vista, right? I think only people with Vista have reported save-game problems.

Link to comment
Share on other sites

I had these same issues in the first release with saving games (this is not new). It was inconsistent when it happened and I was not able to repeat it such that I could provide specific feedback to Brit. I believe this is a bug. Brit if you have any mechanism we can help debug this with let us know. Such as turning on logging or something like that.

Link to comment
Share on other sites

In the updated version:

1. my city names are in black and I can't read them; I have looked for a way to change the color, but didn't find one; if there is a way and I didn't find it, then sorry and forget this problem; and,

2. the messages that appear in the upper left corner of the tactical/strategic map are pixelated and I can not read them at all.

Here is my dxdiag file and I'm not sure if you need a saved game and I'm not sure how to load a saved game onto this forum.

Link to comment
Share on other sites

I'll look into it. I can't think of anything that was done that would increase the game's instability. There's always the possibility that these lockups happened to be clustered after the update happened. Either way, it's something that needs fixing.

Does it give you those errors when the autosave happens too? You may need to right-click and and set the game to "Run as administrator". Or shut off UAC (User Access Control) under Vista. You are running under Vista, right? I think only people with Vista have reported save-game problems.

Nope. The autosaves works perfectly... it's just when I try to save it manually that it gives me the error. But it doesn't do it everytime... it's kind of random. And I do run as administrator and have UAC off. My OS is Vista Business x64.

Koji

Link to comment
Share on other sites

In the updated version:

1. my city names are in black and I can't read them; I have looked for a way to change the color, but didn't find one; if there is a way and I didn't find it, then sorry and forget this problem; and,

2. the messages that appear in the upper left corner of the tactical/strategic map are pixelated and I can not read them at all.

Hmm, strange. My only guess right now is that it's related to the color depth of your graphics card. Right click your desktop background, go to "Properties". This should give you a "Display Properties" window. Go over to the "Settings" tab. Are you running at 16-bit, 24-bit, or 32-bit color quality? My guess is that you might be running at 16-bit or less. If so, let me know, and I'll fix the code so other people can run at 16-bit and it will look okay.

Link to comment
Share on other sites

Nope. The autosaves works perfectly... it's just when I try to save it manually that it gives me the error. But it doesn't do it everytime... it's kind of random. And I do run as administrator and have UAC off. My OS is Vista Business x64.

Koji

Ok. I'll look into it.

Link to comment
Share on other sites

also after playing 253 rounds I'm getting an out of memory error. I'm was playing against 3 ai's. 1 novice, 1 veteran, and 1 elite. The only one left was me and the Elite one... Then after I submitted a turn. I got an out of memory error, I also tried to save it, and it also gave me an out of memory error.

Link to comment
Share on other sites

Yes, the last 30 or so turns where really slow compared to how the game started out. Also I've notice, if you don't delcare war on a AI... it will not attack you at all. Even the Veteran AI. So for 20 rounds I just accepted their peace purposal, and rebuilt my stuff. Then I attacked... then 5 rounds later... out of memory.

Koji

Link to comment
Share on other sites

i too started a game with an elite, veteran and novice; (allthough at this point, i can't remember who was assigned where and i can't find anywhere in the game where it describes the assignment). i was glad about not worring about battles at the first of the game, trying to expand the economy. i ran into what i think is the elite on an island. he took the north city, i took the south city and my tank3 just beat out his tank4 for a pot of gold. i was expecting a fight for the island, nope. about this time the vet declared war on me. now this seem to be over an island city that i owned, but the attack was beaten off. then couple turns later, the novice declared war on me. i had only seen a couple of resources and no cities of the novice, so this was somewhat of a surprize, until one of my boarder resources was captured. couple of turns later, the elite declared war on the vet. the very next turn, the vet sued peace with me (i took it). so i beat down the novice, until with 1 city left, the novice sued for peace (i granted, want to see what he does). in those roughly 80 turns, the vet, twice, sent a message that he was glad we were 'still at peace". it was very amusing to me.

however, through those turns, i was constantly doing overflights on both of there territories, to see what they were both up too, as well as what they might do about it, (might have triggered the vet messages?). the elite ai should now be aware that i have large forces at his border, around his resources and paratroopers sitting outside of one of his undefended citys. plan is to do as much damage, then turn on the vet.

other ai notes: both have fairly large navies (4 battleships each) and large ground forces (same with novices, only it was smaller). NONE of the ai have an airforce. only in the last few turns have i seen 1 level1 fighter for each of them. with the number of rocket launchers i have seen on both sides (i have none), i am assuming they may be going for nucs'. but, in about 20 turns, i'll have a nuc bomber:eek:.

Link to comment
Share on other sites

should add. also have another game on a laptop. that one had only the elite ai. ate up almost 2/3 of the map, uncovered about 80% (is there a report somewhere that say's how much has been uncoverd?) and was about to declare war when it did.

this elite ai, also has NO airforce.

Link to comment
Share on other sites

 Share

×
×
  • Create New...