Jump to content

Linux Installation

Dean Fellabaum

Recommended Posts

Wow. I bought DropTeam as a sort of exercise to learn Linux better. Obviously I still have a lot to learn.

I have moved all of the InstallData file to a folder on my machine called DropTeamSetup, and decompressed LinuxBinaries.zip.bz2.

NOW WHAT? Nothing will run, and there are no instructions that I can find.

If I try to run LinuxInstall I get this error:

dean@dean-desktop:~/Desktop/DropTeamSetup$ ./runLinuxInstall

./InstallData/bin/LinuxInstall: error while loading shared libraries: libaa.so.1: wrong ELF class: ELFCLASS64

Link to post
Share on other sites

Well, crap!

Yes, I run a 64-bit machine, with 64-bit Ubuntu v8.04 LTS.

What the %#$#& is an "ELF class"?

Am I screwed? I'm currently struggling with trying to run TacOps in Wine, too. I think the 64-bit thing is generally causing a lot of my problems.

No offense, Yossarian, but you gave one of the standard extremely frustratings answer that we newbies encounter when dealing with you Linux gurus: "install it."

Well, no kidding!

That doesn't help, because as I explained in my first post I can't even get it installed, and usually I can at least manage that. So how do you install it?

And please do not tell me to RTFM! I already RTFM, and there is no M on this: no decent installation instructions were included. (And, frankly, all Linux M are utterly unintelligible to a newbie, anyway, so I generally dismiss anyone who says RTFM as an insecure and puerile boob who is trying to impress people with how smart he is.)

Sometimes we neophytes just need a hand.

For the record: I do have the driver installed for my Nvidia 8800, and I do use bash.

Link to post
Share on other sites

Be cool, I wish I was a geek ;O)

Don´t read the manual !!!! :o) , it´s hopelessly out of date by now anyway.

I was in your situation a while back. I´m not a linux pro, but after much experimentation I managed to get DT running. My somewhat short post sums up the main problems I ran into.

64 bit is the big issue here. It isn´t impossible to run DT on 64bit linux, you need the right 32 bit libraries to do so. There is a post somewhere by Toby Haynes detailing how to do that.

In my personal opinion (formed by dredging trhough linux forums for hours on end) 64 bit isn´t worth it. Whatever you do you´ll inevitably be running into problems using 64 bit linux unless you are a pro. As I understand it, there is no genuine advantage of using 64 bit except for being able to use more than 4GB RAM.

No idea what ELF class is.

One other problem I ran into was that when you download files in windows and move them to linux you often have to give yourself permission to use them. you do this using the chown command. chown --h gives you all the info needed how to use it.

One cool thing about dropteam ( and probably all other games/programs) in linux is that that once it´s up and running, just backup your dropteam folder. should you ever reinstall your PC or get anew machine, just copy the DT folder back into your home folder, no "installing" required.

Link to post
Share on other sites

Ubuntu and Debian do not provide useful 32 bit environments on 64 bit installations. Pisses me off, too. The one thing Fedora gets right.

You either have to learn how to run a 32 bit chroot (google) or you can work towards using stuff from a 32 bit tree via $PATH, $LD_LIBRARY_PATH and and all that jazz.

Link to post
Share on other sites
  • 3 weeks later...


To summarize: Yes, I'm screwed. The 64-bit thing is killing me, and Redwolf is WAY over my head, when he starts talking about $PATH and other godlike functions. Thanks for trying. I'll be there some day, with "some day" defined as "some decade", but my real life prohibits my spending an awful lot of time messing around with my computer right now.

You know, I started with Fedora when I was first getting into this Linux thing, and I eventually switched to Ubuntu because it was so popular and I figured that it would be easier to get support for it, find packages in .deb format, etc. Do you think Fedora is better for a neophyte?

One thing that REALLY annoys me about Ubuntu is the whole "there is no root account" thing. Sure, sounds like a decent idea, but sometimes it makes it bloody cumbersome to move files around, etc. For one thing it just CAN'T BE DONE in the GUI- you MUST use command line. This is a serious failing, in my opinion, given the stated goal of making a Linux distro for "everyman." (This is sort of the same permissions problem Yossarian mentioned.)

Sorry I vented at you, by the way, Yossarian. But the next time some stuck-up 16-year-old in Helsinki tells me to RTFM I'm going to ping him, hunt him down, and kneecap the little prick. I generally don't ask for help unless I'm stuck, which means I have read as much as I can find. But, as I said, the manuals are usually unintelligible, and sometimes it can be hard to find previous posts about your problem on the forums, etc. The nice thing about Linux is that there is a very helpful community available. I figure that if someone can walk me through a few of these problems that I'll learn a lot, and need less help in the future. That's the whole reason I bought DropTeam- I figured that if I could get some relatively graphics-intense tactical game working that I'd learn tons. But I guess my 64-bit machine sunk that.

Is this why I can't get Warsow working either? Does anyone know a decent game that WILL work in 64-bit? Scorched 3D has gotten a little old...

Thanks, again, everyone.

Link to post
Share on other sites

Well, it's not *impossible* to get DT working on 64-bit ubuntu- I was doing pretty well with 64 bit back in 7.10, but later on it got shaky. I did a custom install 32 bit later on for more support, but I'll try installing DT on 64-bit and tell you how it goes if it'd help, it'd be fun to try.

Link to post
Share on other sites

Not fair.

You want to run 32 bit apps? Install a 32 bit OS, unless you really know things well enough yourself.

Debian and Ubuntu have lousy 32 bit integration in their 64 bit versions but they do not hide this fact. You are supposed to run them as pure 64 bit installs.

Link to post
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...