Jump to content

Shock Force 'Stops Working'

Recommended Posts

Trying Paradox CM Shock Force on an upgraded home computer. Now CM crashes on startup saying CM has 'stopped working'. I've downloaded the 1.11 demo & it does the same so I suppose its not a securom problem & not fixable by just buying Marines.

All software & drivers patched to newest versions. CM reinstalled.


Vista business 32 bit

Athlon 5000 dual core

4Gb ram

ATi 4670 512kb

I tried all the compatibility & run as administrator settings. My other paradox copy works fine on my less powerful vista basic pc & so I am now stuck for a solution Event viewer log is not too helpful - nothing saying CM hates my graphics card or similar. Any suggestions/known issues?

Link to comment
Share on other sites

What's the exact error you get when the 1.11 Demo doesn't work ? Does this happen immediately upon launching CMSF or does it occur once you try to start a game from the main menu (i.e. - you can get to the main menu without crashing) ?

Not that it may make much of a difference here, but do you have Service Pack 1 installed for your Vista OS ? If this Vista DVD is a recent purchase (OEM ?), then it most likely has SP1 slip-streamed into it.

Link to comment
Share on other sites

It's a clean install of 32 bit vista business rather than an upgrade. Not OEM.

SP1 has been installed.

On starting CM the cd icon appears within a second or so, and then within a second or two of that a grey box 10 cm by 5 cm appears saying that CM shock force.exe has stopped working. Below that it says windows is looking for a solution. Within about 5 seconds of that a message appears saying that windows will close the program and notify me if a solutionis available.

I never get a sniff of the loading screen, music or anything like that.

Link to comment
Share on other sites

Swapped my Asus graphics EAH 4670 card out & used the Nvida option.

Problem solved in as much as CM no longer crashes.

Unfortunately my Nvida solution is very slow.

I guess I'll drop a note to Asus & ATi & start going back though various driver iterations.

Thank you for your assistance.

Link to comment
Share on other sites

It seems that it's not my EAH4670 card that CM does not like after all.

Oh no, it's Asus' OSD application that CM Shock Force hates.

OSD is an on the fly overclocking gizmo. Uninstall it & everything is ok.

Now if only I had not installed Catalyst 8.12, deinstalled Catalyst 8.12 installed Catalyst 8.2, deinstalled Catalyst 8.2, deinstalled the steam that I did not want that came with 8.2, reinstalled 8.12, switched on & off the relevant ASDS service, disabled & enabled the asus devices, installed open gl extension checker, ..... etc, etc.

My thanks to a Rocketman thread from 2006 that clued me in a bit.

Bye for now

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...