Jump to content

Screen Resolution


Guest harry_flashman
 Share

Recommended Posts

Guest harry_flashman

Hello there

I recently installed CM on my Win 2000 Pro machine. I have installed the latest video drivers from Microsoft and DirectX 8.1

When I start the game, the screen resolution flips from 1280x1024 to something horrible around 640x480 to play the game. Is there any way of telling it what resolution to play at?

Link to comment
Share on other sites

I seem to remember that you can delete the "pref" file from the CMBO directory. Then the next time you start the game it goes through the video settings set-up routine.

All your saved preferences; sound, gamma level, etc. will have to be tweaked once you get the game going though it's no problem to do it.

Link to comment
Share on other sites

What video card are you using and are the drivers directly from Microsoft's Windows Update site ?

There's a possiblity that CMBO isn't seeing your video card as being 3D capable. The 'horrible 640x480' is an indication that CM is running in software rendering mode, which maxes out at 640x480 under Windows. There may be some settings in DirectX that aren't utilizing the 3D hardware capabilities of your video card.

Go to Start Menu > Run > type 'C:\PROGRAM FILES\DIRECTX\SETUP\DXDIAG' and run this. The DirectX Diagnostic will load up and you should then go to the Display tab. In here there'll will be 3 buttons under the DirectX Features section that affect your video cards capabilities under DirectX. If any of them are 'disabled' then the Enable button will be raised. Try out the 'Test DirectDraw' and 'Test Direct3D' and see how your video card responds. Any warning message in the box below about 'the file xxxxx is not digitally signed...' you can ignore. There really isn't anything truly importand about a driver being unsigned (though if you got the driver from Microsoft it should typically be a WHQL certified and this message won't appear).

Link to comment
Share on other sites

Guest harry_flashman

Aha! Thanks for your help. In fact you were both right. Before I had installed the latest drivers for my video card, I had run the game. These drivers were very out of date - and as you say, several of the directx features were disabled. When I ran the game it saw that I had a naff video setup and saved these things in the Pref file. After I updated, I needed to delete this file so it would have another stab at detecting the video settings, and voila!

Cheers chaps.

Link to comment
Share on other sites

Hello all

I need help. I have a Pent 3 P866 with 512 ram and Hercules 45000

graphics card with 64 ram. Im using XP OS. Been to all the combat mission sites and followed their advice to download latest drivers for card and XP. Also have direct 8.1 which comes with XP.

Start the game and try in 1024 760 but when I click the "Go" button in the game the images along the edges of the game start swirling.

Tried all other settings but only works in 640 480.

Can anyone out there please help me?

Thanks

Ken Spencer

Link to comment
Share on other sites

Exactly which driver version do you have ? The Hercules Prophet 4500 is based on the Kyro II, which does work with CM with a few problems (texture transparencies and some combinations of 3D settings with FSAA). There shouldn't be any resolution limitation problems with this card that I know of.

I'd suggest using the Default settings (3D) for your card and see how it looks for you. Go to Start Menu > Settings > Control Panel > Display control panel (in Classic View) > Settings tab > Advanced.. button > 3D Optimization tab > select the Direct3D tab and click on the Default radio button selection. CM should work fine with these settings.

The following thread has some more details on some of the settings I tried:

Kyro Problem thread

Link to comment
Share on other sites

  • 11 months later...

I suggest uninstalling your Kyro drivers, including any 'tweaker' software for the video. Install your video card as a 'Standard PCI SVGA' adapter on the next boot. DirectX 8.1 should be fine for the Kyros; you can upgrade to 9.0 if you feel like it (I believe the latest drivers have support for this version).

You may want to be careful as to which version of the Kyro drivers you install. I haven't personally tried out the latest drivers, so I don't know what kind of problems that they have (which should mostly be similiar to earlier versions). The 15.0084 drivers seem to be OK as far as I'm aware (they do have problems, but they do work).

Kill any and all programs and utilities that are running in the background, including anti-virus software, firewalls, etc. Preferably the less software running during software installation the better - all kinds of crap can interfere (some of which you may not be able to 'stop' - an uninstallation becomes necessary to actually unload the program).

Install the appropriate set of motherboard chipset drivers for your motherboard. This may be VIA, SiS, ALi or Intel. The important portion of this software is some AGP-related drivers that can help with some video cards. You may also want to check any motherboard BIOS updates (though they don't often affect video cards).

For the Kyros you can also reduce your AGP settings in the motherboard CMOS/BIOS setup. The Kyro II's don't use anything beyond AGP 2X (possibly 1X). Ironically the Kyro I's can utilize or work with higher AGP transfer rates. Some motherboard BIOS's don't have any or very few AGP settings.

Next install your choice of the Kyro drivers and reboot after they finish installing. Then run DXDIAG (from Run on the Start Menu). On the Display tab the DirectX settings will show that 'AGP Texture Acceleration' is disabled (because the Kyro's don't use AGP Texturing). Try the DirectX tests (Direct3D being the more important one here). Generally these should pass.

Next make sure that your monitor definition is appropriate for your monitor. If you can find an exact model use it, otherwise the 'Plug and Play' model should work. The 'Default Monitor' definition may not work very well and can cause some problems.

Set your desktop resolution and refresh rate to something you can work with. Delete the CM Prefs file and then go through the resolution selection process. If you're still only being offered 640x480 (which won't work with CMBB), then you have some sort of DirectX error that is going on with your system. Possibly reinstalling your version of DirectX may help with this, but more often it is an indication that something is wrong with your video subsystem drivers (videocard or monitor definition).

Link to comment
Share on other sites

Well, I would like to thank Schrullenhaft very much for his help there.

My 4500 card is now on speaking terms with CMBB and CMBO and very smooth it is too.

What I did :

Re-installed windows2000 (needed doing)

Installed the 15.0084 KYRO drivers

Installed direct-x 8.1

Installed the manufacturers drivers for my monitor

Installed CMBO/CMBB

Doing it as a clean install is probably what did it, the amount of accumulated cr@p on my PC doesn't bear thinking about.

Once again, a big thank you!

Now... time to blow up some bad-guys.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...