Jump to content

ATI - Vista - OpenGL Drivers error

Recommended Posts


After activating the license I am having a problem starting the game. The exact error I am getting is: "Could not initialze OpenGL graphics. Please update your OpenGL drivers."

I have an HP nx9420 laptop with an ATI mobility x1600 card, running 32bit Vista. ATI do not offer drivers for this card, and send you to HP to DL drivers. HP's drivers are the same as what I already have installed.

I would really appreciate help on this.


[ July 28, 2007, 07:35 AM: Message edited by: Yair Iny ]

Link to comment
Share on other sites

  • Replies 52
  • Created
  • Last Reply

Top Posters In This Topic

There seems to be something wrong with the OpenGL support. I wouldn't imagine that ATI/AMD would rip out OpenGL code from their Mobility drivers that they provide to OEMs.

You can check out the OpenGL support in your current drivers with this tool: Realtech VR OpenGL Extensions viewer. It will give you a little more info and you can run a test similar to the DirectX Diagnostic (spinning cube).

Eventually you may want to check out the DH Mobility Modder Tool. Read through the info here and utilize this to run a more up-to-date Catalyst driver with your Mobility Radeon X1600. Before you do this, make sure you have a copy of your current driver on your system just in case something doesn't work.

Link to comment
Share on other sites

Originally posted by Battlefront.com:

Hello Yair,

I have the same exact ATI card in my laptop (that the game was made on ;) ) running XP Service Pack 2. I have no problems at all, so I am thinking this has to do with the Vista drivers.

We'll see what we can do to help you figure out this problem!


im haveing the same problem, although im runing a intel graphics chip 256mb card, tryed installing the newer drivers and it mabe my display screen go black on restart.. i couldent do nothing.. i hear windows start and everything but its a black screen.. pissed me off royaly.. i had to re install windows couldent do anything. contacted intel and there customer support is a joke.. im clueless.
Link to comment
Share on other sites

Yair and Tarball,

The best suggestion I have for you at the moment is to start fiddiling around with the many options that Catalyst provides. Start by turning off a as many of the special options as you can. Anything that is performance related, turn down to the lowest setting. What we would like to do is at least get the game running first. Then we can narrow down what specific ATI feature is causing the problem and then we can work around that specifically.

Yair, what is the Catalyst version number on your laptop?


Link to comment
Share on other sites

I should mention that, when I get the crash, the in-game cursor switches to the windows cursor. Someone else mentioned this behavior and it is replicable - each and everytime the game crashes on account of a problem with atioglxx.dll the "in game" mouse freezes and the "windows" mouse shows up.

Link to comment
Share on other sites

New forum member here and pre-ordered a few days ago and downloaded the game this afternoon. Battlefront version 1.01

Download successful

Install successful

Running successful (of sorts explanation follows)

Although I can load the game and get into a mission (don't appear to have any gfx anomalies) as soon as I select a waypoint or the mission starts running the game crashes with Windows error reporting an issue with atioglx2.dll

My System specs:

AMD ATHLON™ 64 X2 6000

MOBO - ASUS M2R32-MVP: Express 3200, DUAL DDR II, S-ATA II, 2 PCI

WinXP SP2 fully updated

512MB RADEON HD 2900XT PCI Express running 7.7 Cat drivers (latest release, same error happened on 7.6 drivers)

Sound Blaster® X-Fi™ Xtreme Audio 7.1 (onboard sound is disabled through bios)

Latest Direct X

Desktop running at 1280x1024 32bit colour and have also tried 1024x768 but still same error.

Drivers are upto date for everything and i've also installed the AMD Dual Core Processor optimisation and the WinXP Hotfix - done previously and done again to make sure.

Very frustrating but I have faith you guys will sort this. Games looks wicked so far, just a pity I can only enjoy it for about 5 secs each time!

[ July 27, 2007, 01:46 PM: Message edited by: Vipes34uk ]

Link to comment
Share on other sites

I'll pitch in here...Running Windows Vista Ultimate 32bits. ATI X1900xt, 2 gig ram and a AMD 64bit x2 4200 processor. Same thing for me. I can start the game and give some orders then after about 30 seconds the game freezes and the windowscursor appears and i have to ctrl-alt-delete out of the game. Tried every ati driver from 7.1 and upwards and no change, fiddled with the settings in the controlpanel with no luck. Tried the dualcore-optimizer and no change. Reinstalled directX and no change.

Installed the game on my girlfriends computer. Pentium 4, 2,2gig, 1024mb ram, ATI 800 videocard and also Vista Ultimate and got the exact same problems there.

Im going to drink myself to sleep now and dont work yourselves to death fixing this.


Link to comment
Share on other sites

This exactly same error happens to me, after only 1-2 minutes in game it freezes and windows cursor appears on the screen and CMSF stops responding. I tried this with 7.4 and 7.7 Catalyst, both having the same problem.

I might also add that when I select units with mouse the game halts for 1-2seconds or often stops responding&throws to desktop with the error

My specs are;

Motherboard: 4CoreDual-VSTA chipset VIA PT880 Ultra

Processor: Intel Core 2 Duo E4400 @ 2.9ghz

Memory: 2048MB RAM

Video Card: Radeon X800XT PE 256MB

Sound Card: 7.1 CH Windows® Vista™ Premium Level HD Audio (ALC888 Audio Codec)

Operating System: Windows Vista™ Ultimate 32bit

[ July 27, 2007, 02:31 PM: Message edited by: Niskalaukaus ]

Link to comment
Share on other sites

1. 1.01 (Battle front downloaded)

2. Intel Core 2 1.83Ghz T5600 on Thinkpad T60

3. ATI Mobility Radeon X1300, Catalyst Version 7.1

4. 2Gb Windows Vista Business

6. If a unit is selected without issuing a command, then upon the selection of the next few units, game crashes:

Error message in the debugger is:

Unhandled exception at 0x0288fb09 in CM Shock Force.exe: 0xC0000005: Access violation writing location 0x00000045.

Associated file is atioglxx.dll

Exact assembly code that causes the problem is:

0288FB09 mov dword ptr [esi+44h],eax

if upon every unit selection, a command is issued, no crash. but if i stop issuing command (say this is selection x), usually crash happens at selection x+1, but always within selection x+4

i've set the affinity of the game to only one of the two CPUs, same exact problem persists.

Link to comment
Share on other sites

I also have this problem:

When I select a unit at the mission starts running the game crashes with Windows error reporting an issue with atioglx2.dll

CMSF Battlefront direct download v. 1.01

My PC:

Windows Vista Home Premium 32

Intel Dual Core E6600

Motherboard Asus P5B

2 Gb RAM

Ati Radeon 1950 Pro 256, Catalyst 7.7

SoundMAX Integrated Digital HD Audio

[ July 27, 2007, 04:07 PM: Message edited by: Scrat ]

Link to comment
Share on other sites

Crashing also when selecting units.

Core 2 2.13ghz

ATI x1950pro with latest drivers.


Vista Basic

Battlefront download 1.01

Thanks in advance.


I just found out that in maximum settings i have excellent performance and no crashes for a full round but...

it always crashes to desktop as soon has i left click a unit.

Tryed to swap the USB mouse with a ps2 mouse, no change.

[ July 27, 2007, 06:07 PM: Message edited by: MikoyanPT ]

Link to comment
Share on other sites

Hi, new to the forum, I have an AMD 64 3700+, ATI X850, 3 Gigs of ram, 180 gigs of hd. Vista home 64 bit. No probs with TOW and others. I had no problems downloading and installing, I start the training mission in the campaign and all is fine, as soon as i click on a unit it locks up. I downloaded the latest ATI drivers, dx drivers etc... Kept the game settings at default. No luck. any help would be appreciated.


Link to comment
Share on other sites

Hi Steve,

Sorry, I missed your question re the ATI Catalyst version.

The version info is:

Driver Packaging Version

CATALYST® Control Center Version 2.0.2519.38216

In terms of the 3D options, I have set everything to the lowest possible:

AA: let app decide

AF: let app decide

Catalyst A.I: disabled

Mipmap level: performance

OpenGL settings:

Triple Buffering: off

Force 24-bit z-buffer: off


Link to comment
Share on other sites


Latest update is as follows: following Schrullenhaft's advice, I managed to get the Catalyst 7.7 drivers on my laptop, and now the game finally starts. Apparently the HP version of the drivers WAS stripped of OpenGL support. Unfortunately, as soon as I give a unit an order the game crashes. So now my problem looks more like Tarball's.


Link to comment
Share on other sites

Battlefront, since you've combined my original problem thread into this one, could you change the title?

This problem seems to be more related to those of us clicking on the game map than actually starting up the game. What we all seem to have in common is ATI OpenGL drivers not getting along with the game.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...