Jump to content

Very long load up times on TCP/IP


Recommended Posts

Hi guys

I'm running an iMac with a broadband connection.

I've been trying to host a TCP/IP game after getting fed up with the AI.

The problem is I get the Quick battle ready, post my IP no, the opponent connects on the TCP/IP and I find myself on the SETUP PHASE.

A message says TCP/IP:connected.Waiting for opponent to load scenario.

Fine. I seem to be doing everything right. I position my forces and then wait, and wait and wait... for over half an hour. Still with no success. I cannot get out of the SETUP PHASE.

Does it usually take this long for the opponent to load up?

I also notice there is no GO! button on the SETUP PHASE. Is this normal?

I've read Madmatt's Internet Play Instructions at least 3 times. No firewalls or anything like that are installed. Everything to the letter.

Where am I still going wrong?

Thanks

Link to comment
Share on other sites

I was going to look at this last night, but I didn't get to it. I'll load up CMBO tonight and take a look. I'm under the impression that you SHOULD see a GO button. If not, then you're not 'finishing' your setup (and thus it isn't getting sent to your opponent). What does your opponent see on his side ? Do they get an eventual disconnect message at some point ?

On a Mac I'm not sure if you need to copy some of the TCP/IP-related files to the system folder or not. The absent GO button is definitely a problem in my mind. You may want to delete your Prefs file and reselect your resolution to see if that has any effect (which I doubt it will).

Again, I'll double-check this tonight, but I'm fairly certain that your missing GO button is the issue.

Link to comment
Share on other sites

Dear Shrullenhaft

Thanks for the tip about the missing GO! button.

I went back through the README on the V1.12 patch.

It says drop the Combat Mission file, the OpenPlay Modules (folder) and the OpenPlayLib file into the Combat Mission folder.

This I did to the letter. Couldn't be easier.

I then see there is a Open Modules folder in the Combat Mission folder and click on it to open the folder.

There are 3 files inside: TCP-IP,OpenPlayLib, Appletalk.

I click on TCP-IP.

Immediately, a message pops out and says:

"Library - This file adds functionality to your computer. To add this file's functionality to your computer, place the file in the Extensions folder, or drop it on your closed System Folder icon"

OK, seems clear enough to me.

I first drop the TCP-IP file into the Extensions folder.

I open CMBO and randomly pick out a battle for TCP-IP play. I make sure the modem is running.

As soon as I enter a password for the Allied player, I get the following message:

"Error:Cannot open connection on TCP/IP network"

Frustrated! OK, not the end of the world. I try the same operation but move the TCP-IP file to the System Folder (I don't what the reference to "closed" is).

I open up CMBO for a TCP-IP game and I still get the same error message.

I move the TCP-IP file back into the Open Play Modules folder within the Combat Mission folder where it originally was.

I open CMBO for a TCP-IP game and it opens up OK to the message that it is waiting for the opponent to connect and that my IP is now this number.

All I have to do at this stage is simply wait for the opponent to type in my IP number and make the connection.

In my 2 previous attempts, the opponent has connected but the there is a very long load up time and there is no GO! button at SETUP PHASE.

Any Mac users out there?

So what's going on?

Where am I still going wrong?

Help!

Thanks

Link to comment
Share on other sites

What is your opponent seeing ? If they connect, they should get a download of the scenario so that they can start the Setup phase too. If they're not seeing anything something is wrong with the connection.

Can you install an un-modded CMBO and see if it makes a difference ? Do you have any other problems with CM in solitaire play ?

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...