Jump to content

Probs with new Geforce4 MX 440


Recommended Posts

Hi guys!

My first time here in the Tech Forum IIRC.

So here's for me coming out.

My previous faithlful VidCard died on me, or rather on my Dad, and I just bought the Geforce4 MX 440.

It's rather uber cool for all my needs considering I'm upgrading from a Geforce256 DDR.

My probs is the following, whenever I now launch CM, or after an Alt+A, I'm presented with a BLACK screen.

What I have to do is to Alt+Tab to the desktop (Windows Millenium) and get back to the SAME black screen.

Only after that the first click anywhere on the screen gets me the menu.

I'm running 28.32

Any idea?

Help?

Mom?

Feedback and pointers would be appreciated.

[ April 24, 2002, 09:31 AM: Message edited by: PawBroon ]

Link to comment
Share on other sites

I'm not sure why you're experiencing the problems that you're seeing. Sometimes strange things happen with driver updates, especially if the driver comes from different sources (Reference compared to OEM, etc.).

I'd suggest uninstalling both your current 28.32 driver and any vestiges of your previous driver. Also remove any NVidia related .INFs in the C:\WINDOWS\INF (\OTHER ?) directory and also delete any NV*.* files in the C:\WINDOWS\SYSTEM or SYSTEM32 directories. With this done when you reboot Windows ME may identify the video card or not (I can't remember if WinME can recognize the GeForce family or not). Finish that installation, whether it be SVGA or a NVidia driver.

Next update or reinstall DirectX 8.1. Then reinstall (after rebooting from the DirectX installation) the 28.32 or later drivers. Hopefully this will work for you and may correct your problem.

Link to comment
Share on other sites

Hello all. I am having what I think is the same problem on my PC. I have an Athlon XP 1.7Ghz/512 mb ram and onboard nVidia GE 2. Win2k, CM v1.12

I did the install (fresh system, nothing to uninstall) the driver upgrade and when CM runs, it's beautiful. It's just that every 2nd or 3rd time I start my PC and run CM, I get the movie and then at the first menu screen ("play game", "create scenario", etc...) I get a black screen with clusters of letters dead center top and bottom. i think the letter clusters are the combined text from the buttons that should be on that page, but I'm not 100% sure.

The only way I've found to solve this is to Alt-F4 CM, delete the Prefs file and restart CM. (I choose 1024x768 x 70hz). CM v1.12 runs fine thereafter; until I restart.

All of that is annoying, for sure, but what worries me is that Alt-F4 is not killing CM...rather I have to go in to Task Manager to End Process...when I do I see that the memory allotted to CM is usually 24 Megs and climbing. Does anyone know of a memory leak in CM v1.12?

thanks folks!

Link to comment
Share on other sites

Have you tried disabling the QuickTime movie to see if it makes any difference in the regularity of your problem ? Do you have to Alt-F4 to get out of CM when the display corrupts or can you Alt-Q to quit it first ? Which specific drivers are you running and are you using any tweakers/overclocker utilities with it ?

What version of DirectX are you running with Win2K (it comes with 7.x I believe) ?

Link to comment
Share on other sites

  • 2 weeks later...

Hi all,

I want to bump this topic since I am having the same problem.

Having just upgraded from a GeForce 2 to a GeForce 4 Ti4400, using 28.32 drivers, I'm getting a black screen when CM starts. It's necessary to "esc" (minimize) CM and then re-maximize it in order to see the opening menu.

In the game, the graphics look good. However, when I finish a turn and hit "Go" the game hangs on a frozen screen. It's necessary to ctrl-alt-del and reboot after that.

Any solutions, or should I just go back to earlier drivers?

Thanks.

Link to comment
Share on other sites

I don't know why the GeForce 4 MX should be any different from the GeForce 2 series since they are similar in many respects (other than a better memory management core in the 4MX).

As I suggested earlier in this thread. You may want to uninstall all NVidia/GeForce drivers (including manually removing drivers and .INF files) and temporarily install either the default GeForce driver (XP) or a SVGA driver (9x/ME/2000). Once this is set, then I would recommend reinstalling DirectX 8.1 (but not if you're running WindowsXP, which doesn't have an unique installer for it since 8.1 comes built in). Once this is done and you've rebooted then install the 28.32 drivers.

[ May 12, 2002, 08:36 PM: Message edited by: Schrullenhaft ]

Link to comment
Share on other sites

Originally posted by Schrullenhaft:

Have you tried disabling the QuickTime movie to see if it makes any difference in the regularity of your problem ? Do you have to Alt-F4 to get out of CM when the display corrupts or can you Alt-Q to quit it first ? Which specific drivers are you running and are you using any tweakers/overclocker utilities with it ?

What version of DirectX are you running with Win2K (it comes with 7.x I believe) ?

Answers:

I have DirectX 8 I think. I know I had to install a new DirectX with Flight Simulator 2002.

Disabling the movie didn't help.

I didn't try Alt-Q. I did try the minimize-maximize trick to no avail.

I "fixed" my problem by setting the resolution to 60hz. It's not as sharp (but my eyes are old), but I don't have this problem anymore. It runs fine, everytime.

I was mostly concerned with the memory usage spiraling out of control. CM never takes 25 megs.

Link to comment
Share on other sites

I believe the problem stems from anti-aliasing. If you turn it off, there shouldn't be any problems. The game doesn't look quite as good, but the faster card allows you to run it at a substantially higher resolution thus reducing the need for anti-aliasing in the first place.

That has been my solution.

Geforce 4 w/28.32 drivers

Link to comment
Share on other sites

Interesting...

Though I haven't experienced it myself, the NVidia Detonator drivers (and drivers for some other video cards too) have a well known problem maintaining anything other than 60Hz in some games or desktop resolutions running under Windows 2000 or XP. I've noticed that NVidia tends to play around with some of the available refresh rates, with some of the official drivers supporting fewer refresh rates than some of the betas.

If changing to 60Hz fixes your problem, then I would suggest downloading an even newer driver that has been 'patched' to address the 'refresh rate problem'. There are two options here, one is a program called RefreshLock and another is getting a Beta driver that has been patched to fix the refresh rate problem. You can get the drivers from Guru 3D (Videocard drivers > NVIDIA detonator drivers > get the RefreshLock program or the latest patched detonator for Win2K/XP, which is 29.20, a beta driver that is newer than the latest official driver from NVidia).

I don't know if this will fix your problem, but it may. It also may not be worth messing with since you have a solution at the moment, but it is possible that this may allow you to run at a higher refresh rate.

Another point is that the 'default' setting for FSAA in the drivers is to have the 'application control FSAA' which in CM's case means that it is off. If users who aren't having problems haven't manually changed this setting then FSAA could be a possible culprit here. I'm not sure why that would be the case since FSAA works with the latest official drivers on the GeForce 2 & 3 series (albeit at a significant performance hit).

[ May 14, 2002, 09:08 PM: Message edited by: Schrullenhaft ]

Link to comment
Share on other sites

I had the same problem, GF4600Ti and blank black screen at CM startup (28.90 Det drivers). I had the antialiasing set to Quincunx for IL2 Sturmovik. As soon as I set the antialiasing to x4 the CM problem went away, started up properly. Put it back to Quincunx, blank startup screen.

Try x4 AA manual setting.

Link to comment
Share on other sites

Woot!!

It works.

When on Quincunx, I not only had the black screen but couldn't Alt+Tab out of CM to Photoshop properly.

And what was more aggravating in a strict MODs & MODers sense, it wouldn't let me take screenshots at all with Print Screen and had to do it via Hypersnap.

Now on 4x FSAA or on Default I'm back in the business.

Thanks to all who helped and thanks to Nvidia for making terrific products with weird drivers.

:D

Link to comment
Share on other sites

Be aware that 'application controls antialiasing' means that FSAA is OFF. There may be some programs that will control a card's antialiasing features, but a vast majority of them don't.

It looks like Quincux and possibly 2X may be problematic. Interestingly Quincux FSAA didn't come about until the GeForce 3 series (and can't be used by lesser video cards). The GeForce 4 MX is actually closer to the features of a GeForce 2 than a 3 or 4 series card (though I believe that they have the improved memory system architecture of the GeForce 4's).

[ May 15, 2002, 01:10 PM: Message edited by: Schrullenhaft ]

Link to comment
Share on other sites

  • 2 weeks later...

I normally hate it when people bash others' choices in hardware, etc., but....

Take you MX card back! I've been doing a bunch of reading up on the latest cards, and the "experts" agree that for gamers, the choice (in nVidia stuff anyway) is one of the Ti cards. I even saw one guy (Kyle Bennett of HardOCP.com) say, and I quote, "Make sure an MX card doesn't end up in your box at all costs" CPU Power User magazine, May issue.

The MX, it seems, is all about the marketing game. It is no more than a suped-up GeForce2 card, while the GF4 Ti is more the equivalent of having two "pimped-out" GF 3 cards on board. Also, the Ti card is based on the latest nvidia chip, while the MX is not, and it is not a true DX8 chip!

Bottom line, nvidia is taking alot of crap for the GF4 MX board. I would especially avoid it if you do any high-demand gaming, i.e., FPS and such.

Again, don't mean to offend. Just trying to put out some info that I've come across...

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...