Jump to content

Macintosh freezes!


Recommended Posts

I've been having some random freezes on my B&W G3/400 w/ 320MB of RAM and the original Rage 128 16MB under 9.2.2. I'm using the version 6.3.9 of the Rage 128 3D accelerator (don't know if that matters. Is there anything newer?) and the latest OpenGL (1.2.4). I'm using lots of high res textures but I have 120MB allocated to CM.

The game seems to play alright but the most part (actually I'm not sure the fog is working now that I think about it) but occasionally the game will hang. The sound continues playing but the cursor disappears and nothing responds. I try to force quit and then the game freezes completly (sound stops) but still doesn't quit. I have to restart. It works fine for the most part but this is annoying. Any suggestions?

Also I'm thinking of upgrading to the Radeon 7000. Are there any problems with that card?

Link to comment
Share on other sites

In the Troubleshooting section of the manual it specifically state:

"MacOS 9 (including 9.04) on a G3 or G4 machine appears to cause random system lockups in some cases. Solution: Disable the backside casche. This can be done using the G3/G4 Cache Profiler from Powerlogix http://www.powerlogix.com"

I also found that disabling speculative access helped me. Try one (backside cache/speculative access) and then the other.

Link to comment
Share on other sites

I've had the same problem on my iMac, as have many Mac users, at least based on previous posts to this effect. The problem seems intermittent and unpredictable, and in my experience disabling the cache really didn't seem to matter.

What does seem to matter, although it may be purely superstition, is saving periodically. My freeze ups occur almost exclusively while either watching a movie and changing views rapidly, or just as I'm about to hit GO.

I have a suspicion that the problem somehow involves memory, but can't really pinpoint it (and don't have the technical skills to do so). I can go long stretches without any freezes, and then will have two or three in rapid succession.

All in all, it's annoying, but not a major hassle.

Link to comment
Share on other sites

Disabling the cache is really a "if all else fails" measure, it'll cause a significant slowdown in overall performance.

I have the "random freeze" happening ... hmm... maybe every two months. Only happens with CM. Old Mac upgaded to G3 and OS 9.04.

Radeon 7000. I wonder if that was the "slow radeon". There is one Radeon model around that's not really up to much (in 3D performance), forgot which one but could be just that. In that case the "old Radeon" would be a better choise.

Link to comment
Share on other sites

Ya I know the Radeon 7000 is the 'slow radeon'.

The older Radeon is better but it's hard to find and more expensive.

Looking at the IMG review shows that the Radeon 2001 is really better at higher resolutions then the 7000 (because the Radeon 7000 has no TCL). However the 7000 runs at a higher clock speed the then Radeon 2001 (183Mhz vs. 166 Mhz). I'm running a 15in moniter that can't go high then 1024 x 768 and I'm sure the card is limited by the CPU as well.

http://imgmagazine.com/reviews/view.php?ID=232&Page=3

And I think I've decided I can put up with those freezes because I'm sure disabling the cache will make those turns calculate slower.

What I'm really wondering is are there any issues with CM and newer ATI cards?

[ May 13, 2002, 05:59 PM: Message edited by: Colin ]

Link to comment
Share on other sites

Typically, as far as I'm aware, there are no problems with any of the ATI cards & drivers for OS 9.x (as far as CMBO is concerned). Your fog should work if everything is installed correctly.

Most of the driver problems on the Mac seem to center principally around the NVidia-based cards. I'm not sure if this has been completely cleared up yet (the'sky' textures are visible with the latest drivers).

Link to comment
Share on other sites

I bought an iMac G4 in Febuary and I've played CM solid since (everyday). This computer has never locked up once. My other iMac 400 DV SE locked up with the cache off and on, quite a bit.

Maybe it is the ATI card.

I have no graphics problems at all. Except I can't push as many mods in one of the graphics files because it corrupts all the text in the game. Other than that it runs smooth and fully rendered. I'm blessed with no lock-ups.

Cheers

Link to comment
Share on other sites

You should at least try disabling the speculative access, if you don't disable the backside cache. My B&W G3 runs rock solid now. Of course I also had a CD-ROM problem, where accessing the CD-ROM would eventually cause a freeze.

I solved this problem first by using a third-party CD-Rom driver from CharisMac. Then by updating the drivers using the latest Disk-burn drivers from Apple.

Link to comment
Share on other sites

I tried disabling the backside cache and, if anything, it caused more problems than it solved.

I generally crash when scrolling around on the screen, but I've found that disabling sound during the orders phase seems to help.

[ May 15, 2002, 02:33 AM: Message edited by: CMplayer ]

Link to comment
Share on other sites

A very irritating thing is that if it crashes during a TCP/IP, sometimes the autosave doesn't allow one or the other player to put in any orders at all. In many cases one guy's orders are lost, and he is forced to just hit go. Woops. In addition, the previously played turn gets recalculated, which is very frustrating.

In TCP I am in the habit of manually saving every turn, for this reason. But there is even a problem with this, which I wish BTS would address. It's not possible to save until after hitting 'done'. That's bad. Most freezes occur while watching the movie. So if it was possible to save the latest calculated result, while still in the movie watching phase, then these freeze-ups wouldn't impact gameplay, except to be an annoyance. As it is now they can ruin a game.

[ May 15, 2002, 02:32 AM: Message edited by: CMplayer ]

Link to comment
Share on other sites

I found i had the odd freezeup with tons of mods. I did a re-install at one point and have ended up with just two mods, the gridded grass/terrain, and the British bagpipe charge sound. Ever since then, no lockups whatsoever.

Fate

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...