Jump to content

why cant I host a tcp/ip game?


Recommended Posts

I cant host a tcp\ip game. :confused: I know there must be some setting somewhere I need to change, but I dont know what to do.

I am using a ADSL connection and Windows 2000 professional OS.

I would love to host but cant.

Help me please.

John

:(

[ November 04, 2002, 06:00 AM: Message edited by: JP Jones ]

Link to comment
Share on other sites

How is your firewall settings? That's the first thing that comes into my mind.

Had the same problem, because my firewall was set to High security. Lowering this to medium and it allowed me to host and to connect to other host's.

Have you also given an permission for firewall to let CMBO connect to internet?

Link to comment
Share on other sites

Yeah, that would be me. Having some difficulties here. I'm able to connect to other's games, but not host.

JP--Here's what I've done, which should've worked for me but didn't, perhaps if you give it a shot it'll work for you.

First, identify what your modem is really all about. If it has some type of monitoring software that was installed during setup, open it up and check it out. You're looking for security, aka firewall, settings. Mine has a list of popular applications and the different settings for them, including port, protocol, and IP. From what Redwolf has been telling me, my setup is just plain screwy because the IP that is reported by the monitoring program is the same all over the board, when there should be a different IP for the router and a different one for my computer proper. What you need to look for is whether the modem/router is forwarding through port 7023 and to your comps IP. Enable pass-through or forwarding for port 7023, the one used by the game. I also put my comp into DMZ, which basically means that my comp is acting as if it were sitting directly in front of the broadband connection coming into the house, with nothing in front of it (eg: firewall). I've done all of this and still no luck, hopefully it'll work for you smile.gif

Link to comment
Share on other sites

The .34 address is indicated everywhere. Each app listed as pass-through enabled and it's corresponding port lists the .34 add as it's pub IP.

My comp's TCP/IP control panel lists the .34 add as the computer's pub IP.

The network map in the router software lists my comp as having the .34 IP.

There's only one other IP listed ANYWHERE, and that's the router's IP.

I've opened every window, explored every "advanced option" offered by the software.

Zilch.

Link to comment
Share on other sites

Is it possible that I have to get the router software to first recognize the fact that the application using port 7023 is a host application?

Example:

In the window listing which applications and their ports are pass-through enabled, there are 5 columns of info

App Name

Protocol Used (TCP or UDP)

App Type

Port

Public IP

Most App's already listed have the 'App Type' field defined, eg. Half-Life is defined as "DirectPlay Host".

I had to manually define TacOps, entering the protocol used and the port number, but not the App Type, no field for that.

Is it possible that the router software is just too stupid to realize that I want that app to host and that it needs to know this before it allows anything to happen?

Link to comment
Share on other sites

Ok, I'm a little late to the party, but I might have something to contribute.

In order to host a game when behind a firewall, you'll have to do the following:

1) Get your router's IP address. That is the IP address that everyone else on the Net has to use in order to connect to your computer, regardless of what your computer's IP address is. You can usually get the IP from the router's configuration screen, but if not, this site will tell you what your router's IP is: http://www.whatismyip.com/

2) Give your IP to your buddy who wants to join the game you're hosting. smile.gif This is the IP he needs to give to CM.

3) Set your router to forward all packets addressed to port 7023 to your machine's local IP address (it's probably still 192.168.1.34). You may need to reboot the router after this change. Read the instructions carefully.

Link to comment
Share on other sites

Yeah, that was basically the biggest problem I was having. Here's what I did last night, and it apparently worked. First I took my comp OUT of DMZ. My Comp's address went from

66.124.196.100 to 192.168.1.34

Then I pointed my browser to ipchicken.com (Same thing as whatismyip.com)

This told me that my ip, visible to the internet, was still 66.124.196.100

I then went to www.pcflank.com, they offer port scanning and other security services. Again my IP as seen by the internet was reported as 66.124.196.100

So, I start the game and logon to the network.

I initiated an Advanced port scan, specifying port 7023 to be scanned. It was reported as open.

I quit the game, rescanned, port 7023 closed

I restarted the game, rescanned, port 7023 open

Here's how I understand what happened:

Putting my comp into DMZ gave it the same IP as the router, but nothing was being forwarded to 7023 because there wasn't a different IP specified to be forwarded to. Taking the comp out of DMZ, gave it a different IP, but the routers IP stayed the same, telling the router where to forward info from 7023 to.

I think that's it. I'm probably missing something in the explanation. Hope some of this helps you JP.

Link to comment
Share on other sites

Hmmm... good news. I don't really know what the DMZ option normally does. I wouldn't think it would give you a second IP, unless your ISP allowed that, and I don't think it would work if it had the same IP as the router. I thought that DMZ just removes all protections for your computer, so basically anyone can get to it. Don't know how it affects the comp's IP though.

Link to comment
Share on other sites

That's pretty much correct. Putting my comp in DMZ gave the router the impression that my comp was sitting right next to it, directly on top of the connection into my house. The router gave my comp the same IP that it has, in essence 'sharing' the IP w/ my comp.

BUT, that doesn't work for what I wanted, to host an application, because although port 7023 was opened, the router saw no need to forward anything to my comp. As far as the router was concerned, my comp was getting everything it was.

What needed to happen, was that my comp needed an IP address in the same range as the hardware IP for the router. The hardware IP is just an address that allows the router and the comp to talk to each other, know where and what each other is. That's the 192.168 range of IPs my setup has.

Now, my router's public IP, the one seen by the internet, including other comps that want to connect via a application, is the one that needs to be connected to, different than the hardware IP. The router then IDs the app being used, recognizes that the app uses port 7023 and routes incoming/outgoing data through port 7023. But where to and where from?

That's where the 192.168 IPs come in. The router knows that my comp has an IP of 192.168.x.x and that anything using said application and x port number gets forwarded to the comps IP.

This doesn't happen when the comp is in DMZ, because the router sees my comp as having the same IP as it, so the incoming data goes no further than the gateway.

It was difficult for me to get this done because of the GUI that my router's software uses, not very sophisticated. It seems to be designed for more casual internet users, that don't have much need for opening/closing ports and such. Other software GUIs are undoubtedly easier to manuever through.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...