Jump to content

I'm Still Getting Error 13


Recommended Posts

I've posted about this before, but my system has changed somewhat since then, and the problem persists.

I have a Powermac 8500 with a Powerlogix G3 upgrade runnning at 320 MHz. It has 240 MB RAM, two 4 GB HDD's, an 8x CD-ROM, and an ATI Xclaim 3D+ video card (w/ 8MB RAM). I recently upgraded to MacOS 9.0.4, but I had exactly the same problem with 8.1. Oh, and yes, I do have the latest drivers from ATI (I tried some older drivers, too, but that didn't help).

When I first got CM, it ran fine. when I installed the G3 ugrade a few weeks later, CM still ran fine. For the past two months, however, I've been unable to play it at all, and I don't know what changed to cause this problem.

What happens is this: I can start up a game (quick battle or scenario - I haven't tried operations yet), and during the deployment phase, after about a minute, the game quits with an error 13. This happens regardless of what screen resolution I use, or what version of CM I use. I've tried turning off the G3's backside cache (no effect), turning off virtual memory (no effect) and increasing CM's memory allotment (no effect). If I skip the deployment phase (just press GO as soon as the game starts), then I can play for a few turns (much more than a minute), but eventually the game will quit.

I'm guessing that this has something to do with my video card, because Bugdom and Nanosaur (the only other 3D intensive games that I have) also exhibit this behavior. They run for a minute or so, then quit. (they both did this with 8.1 as well)

The change that I've made since my first post on this topic is that I swapped my old 1 GB HDD for a 4 GB HDD, and I upgraded from system 8.1 to 9.0.4 (clean install). I hoped that this would fix things, but it hasnt helped at all.

Does anyone have any ideas on what might be causing this problem?

Link to comment
Share on other sites

An "error 13" is an "uninstalled interrupt error" according to Apple. This seems to suggest that there may be something wrong with your drivers or hardware (that, however, it just a guess).

What is the exact model of your 8500 and which PowerLogix upgrade do you have installed ?

This is the most common suggestion probably made on the Mac - have you tried to minimize the number of extensions and control panels that you load up (especially screen savers or other desktop modifier programs) ? I would suggest checking out any ATI/QuickTime/QuickDraw related extensions also. You may want to post your System Profiler results here and people can make further suggestions.

When you performed a "clean install" of 9.0.4 was it to a completely empty partition ?

Do you have any problems loading up a lot of programs (to fill up your memory) ? I'd assume that you would see other errors if you had memory problems though.

This is a stab in the dark (and typically should make no difference whatsoever on a Mac), you may want to try another PCI slot on your PowerMac and make sure that the contacts on your ATI card are clean and debris free. You may also want to check you memory modules while you're inside by removing them and reseating them in their slots.

The latest version of the PowerLogix Cache Profiler is 1.3; is this the version that you're using ?

If this problem continues to torment you, then I would suggest removing (temporarily) your PowerLogix upgrade and see if the error continues (you'll, of course, want to pull out your PowerLogix extensions before doing this). Of course your system will be a lot slower, but it would be interesting to see if your problems stem from your upgraded CPU.

[This message has been edited by Schrullenhaft (edited 10-22-2000).]

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...