Jump to content

Neomagic Magicmedia 256AV purple colour workaround - CMBO


Recommended Posts

I have managed to find a workaround for the Neomagic 256AV problem in CMBO of white being displayed as purple on my old Toshiba Tecra 8000.

Laptop: Toshiba Tecra 8000

Video driver: 4.11.01.5207-Q2.07.04 Driver here

DirectX 9c

Resolution: software mode

Windows 98SE

The solution consists of alt-tabbing to desktop once game has loaded, changing desktop colours to 256, and alt-tabbing back.

After playing, you need to reset the desktop colours back to what you normally use. If 256 colours are always selected, the game still shows purple - it seems the act of changing to 256 colour mode resets something.

Resolution of the game is software mode, so the graphics are slow and nasty, but at least the colours are ok.

The screen is very dim when you alt-tab from CM so I found it easiest to open display properties first, with 256 colours highlit (but not entered) before running the game. Then all you have to do is discern the OK button when you've alt-tabbed back to this screen.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...