Jump to content

CMBO Has Stopped Working


Recommended Posts

I've had CMBO for a couple of years. It started out running just fine, with a couple of graphics limitations because of the NvG2 card, but that was minimal. Now, things have gone for the worse.

During a game, at different points, I have everything stop on me. The only thing I can do is move the cursor around, and when I left-click I get a bell sound. I have to get out using Control-Alt-Delete, and use Task Manager to shut it down.

At other times I get sent to a DOS-style failure page, sometimes saying something about "not less or equal" or something like that, or exception not handled, and sometimes mentioning that a memory dump is in progress. Sometimes I can Control-Alt-Delete and get my computer back. Other times I have to hit the computer reset button. Sometimes the computer goes to restart by itself. When this happens, I lose my computer's history!

Because of these problems I upgraded DirectX to 9.1 runtime (I believe), and later upgraded the NVidia driver to 4410. I reinstalled CMBO. At first, everything was fine, but after playing a number of times, the problems have returned. Today I get the stoppage on setup of one of the set scenarios.

I'm really curious to know what's doing this, and if there's a fix.

Link to comment
Share on other sites

Since CMBO hasn't been updated since March 2001 and you've run fine for several years; I'd say there is something up with your computer rather than with CMBO. CMBO just brings the problem out rather than acting as a defective product itself.

So don't expect any patches to CMBO to fix your particular problem because it is a hardware (generally speaking) and not a software issue with CMBO.

In your case you may have heat problems with your CPU, videocard or power supply (or motherboard). The CPU or videocard are the most likely culprits. You may want to 'dust' out your computer and make sure that it isn't sitting in direct sunlight (which could elevate the temp of all components in the case several degrees). You may also want to check for the 'spinning status' of fans (power supply, CPU, videocard and case). Often a fan may slow down in speed and will not cool to the level that it was before (often this can be discerned with the 'oscillating' pattern of spinning - speed up, slow down, etc.).

Link to comment
Share on other sites

Skoonj,

I have exactly the symptoms you describe, but I got there a little differently. I have:

Windows XP Pro

Athalon 1.8g

750 mg memory

GeForce 2 Pro

DirectX 9

I re-installed CMBB after a long hiatus, only to have it run VERY slowly (1-2 fps). As suggested on this forum, I reverted to the 28.xx version of the detonator drivers, and that solved the slowness. However, the stop with bell thing you described began happening. Now, since I did not run the game very long at the 1-2fps speed, it is possible I had the problem then and did not know it. I have since installed about 5 different versions of the detonator driver, including the very latest, 45.20 from 3dGuru.com. I also ran Detonator R.I.P to remove the leftover bits of the detonators. I have also disabled FSAA, and anything else I can find. No joy.

Other important Data: My system runs MANY other games just fine. I recently installed DirectX 9.

I am beginning to suspect that this is not a video driver issue. It could be directX 9. I installed that during the hiatus, and it's the only system wide change that I can think of, other than joining this box to a domain.

I am reasonably sure this is not a hardware issue. This is my main developemnt box, and it is rock solid, showing no problems AT ALL other than CMBB puking.

Any thoughts?

Jody

Link to comment
Share on other sites

When do you experience the 'ding' sound ? Is this in solo play, TCPIP, PBEM, etc. ? Is this a particular scenario that you're attempting to play or is this any QB, PBEM, etc. ? How long does it take for this error to start occuring ? Does it occur consistently (i.e. - you could load up CM and within 2 minutes or so it will lockup almost everytime) ?

Actually the 30.82/30.87 drivers are latest drivers that perform without a problem (though the latest GeForce they'll work with is the 4 series that maxes out at 4X AGP - not an issue for you). However the 28.xx series should work fine too (if I recall).

Unfortunately I don't know of any reliable method of back-dating your DirectX install. So confirming your suspicions about DirectX 9.x being the culprit behind your problems would require a reinstallation of XP in one manner or another. However be aware that there are a lot of other players in this forum running GeForce cards, DirectX 9.x and a variety of Detonator drivers who aren't experiencing the 'ding' problem that you mention (at least they're not reporting it occuring on any consistent basis).

Depending on your motherboard, you may want to install the chipset drivers for it. However this may make little difference in XP, but it may give you some options for tweaking the video card or drivers (AGP settings). You could also download one of the tweaking utilities at Guru3D (RivaTuner 2.0, GeForce Tweak Utility, PowerStrip 3.02 or NVMax, etc.) or get PowerStrip 3.43 directly from Entech (you may want to check out the 'PCIList' utility too).

Link to comment
Share on other sites

Yesterday I brought my computer to the shop, and they took a look inside. They told me three fans had their leads disconnected (out of, I think, seven in the box), and these have been reconnected. Also, two fans are apparently slowly dying, since their bearings are making noise at start. Fortunately, they are fine after warming up just a little. One of these is an Asus motherboard fan for my A7m266 board. They didn't have a new fan to put in, but this should last a while longer and maybe Asus has a replacement.

My computer, made by Game PC:

AMD 1.2gig Athlon

512 Megs RAM, DDR 266

NVidia Geforce2 4410 driver

Hitachi CM771 19" screen

W2000 Pro

DX9.1 0r 9.2

This is now 2+ years old, and I will at some point have to upgrade, but can't afford it at this time.

I brought the computer home and ran it up. I played three games (St. Ann's Chapelle) and had no problem. You may well have been right on the cause.

One of the really bad things that resulted from the problem was that when it hit I would have the computer restarted as part of the problem, and when it came back, much of my history was gone too. All forums I went to no longer showed me which posts I've seen and which I haven't. Annoying!

Thanks for helping. This may have solved it.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...