Jump to content

Radeon slowdown bug


Recommended Posts

Here's the problem: Demo runs like crap with Radeon 64 DDR, Radeon 7000 and Radeon 7500. CPUs from 1 to 1.4GHz. RAM from 256MB to 768MB. W2k, XP or Win98.

Specific symptoms - Selecting any of YOUR units except for mortars and ATGs causes big slowdown in game framerate. Opening unit stats box causes huge slowdown. If you have unit selected when you hit "go", calculating turn file takes 20% longer. (55sec vs 45 sec on 1st turn). Selecting enemy units is no problem.

Any other fix except to buy Nvidia?

[ September 01, 2002, 01:40 PM: Message edited by: Barleyman ]

Link to comment
Share on other sites

Oh, I'm using latest leaked Catalyst drivers (6143) :rolleyes: No reason to get excited, I already figured out a workaround:

I figured it out. There's a bug in CMBB and/or Radeon's drivers. If you're experiencing extreme slowdowns, disable "Z-Mask" feature.

Go grab a good Radeon tweaker. You'll find the setting under Direct3D stuff, right at the end. You might want to create a profile that runs every time you run CMBB demo.

Turning Anti-aliasing on helps as well.

Link to comment
Share on other sites

Originally posted by Barleyman:

Oh, I'm using latest leaked Catalyst drivers (6143) :rolleyes: No reason to get excited, I already figured out a workaround:

</font><blockquote>quote:</font><hr />I figured it out. There's a bug in CMBB and/or Radeon's drivers. If you're experiencing extreme slowdowns, disable "Z-Mask" feature.

Go grab a good Radeon tweaker. You'll find the setting under Direct3D stuff, right at the end. You might want to create a profile that runs every time you run CMBB demo.

Turning Anti-aliasing on helps as well.

</font>
Link to comment
Share on other sites

Originally posted by Barleyman:

Oh, I'm using latest leaked Catalyst drivers (6143) :rolleyes: No reason to get excited, I already figured out a workaround:

</font><blockquote>quote:</font><hr />I figured it out. There's a bug in CMBB and/or Radeon's drivers. If you're experiencing extreme slowdowns, disable "Z-Mask" feature.

Go grab a good Radeon tweaker. You'll find the setting under Direct3D stuff, right at the end. You might want to create a profile that runs every time you run CMBB demo.

Turning Anti-aliasing on helps as well.

</font>
Link to comment
Share on other sites

Originally posted by John D Salt:

Unless there is more to disabling the Z-mask than toggling the appropriate tick-box at the end of the DirectX menu in the Rage tweaker, this does not work on my machine.

Something's not working right :D

Does your Tweaker & driver versions match? Latest tweaker (3.5) only works with Catalyst drivers.

Rage3D Tweak is not the most intuitive apps out there, "ok" is not the same as "apply". Apply is what you do want. If the tick box has a red border, the setting is not present in registry. If the box is gray, it's set and "disabled".

So, if you have a gray box, hit apply, close the display properties box and start cmbb.. And it's still broken, you have got something different.

Link to comment
Share on other sites

Originally posted by Schrullenhaft:

When you hit 'Go' the video card isn't responsible for any slow down, its the memory and CPU since the turn calculation & AI plotting are done with those components.

Famous programmer's excuse: "But I never touched that module..!"

I did some stopwatch testing and yelnia shows quite a bit of difference. 1st turn after setup without changing german positions, from pressing "GO" to the start of playback:

Z-Mask on with unit selected: 55 seconds

Z-Mask on with no unit selected: 45 seconds

Z-Mask disabled: 25 seconds

(1GHz Athlon blah blah)

Link to comment
Share on other sites

Perhaps the video driver is 'stealing' a bit of extra face time with the CPU or it's eating up some extra memory.

Of course you have to recalculate that exact turn with the exact same orders or the data is useless since there are a number of variables that affect the turn calculation.

[ September 02, 2002, 03:34 AM: Message edited by: Schrullenhaft ]

Link to comment
Share on other sites

Originally posted by Schrullenhaft:

Of course you have to recalculate that exact turn with the exact same orders or the data is useless since there are a number of variables that affect the turn calculation.

Sure, I didn't touch the setup and CPU had scenario defaults. I didn't issue any orders before hitting "GO".. I repeated it twice with each variation, yielding results within 1 second..
Link to comment
Share on other sites

Originally posted by Barleyman:

Something's not working right :D

Does your Tweaker & driver versions match? Latest tweaker (3.5) only works with Catalyst drivers.

Ok, that's fixed it. Downloading the latest driver from the (amazingly broken-looking in Opera) ATI support page at

http://www.ati.com/support/driver.html

and installing it makes the demo work as fast as CM:BO did.

If only using an ordinary desktop PC to play games could be made as straightforward as Unix system administration was... tongue.gif

All the best,

John.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...